summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-11-03 12:44:43 +0100
committerJeroen Roovers <jer@gentoo.org>2016-11-03 12:46:24 +0100
commit633d3723e0759af60df3bdcd7b86b80f05b2daa3 (patch)
tree59f830dad05e20b3d087a1a25bd99d858d8cb737 /net-dns/libidn2/libidn2-0.11.ebuild
parentpackage.mask: mask mail-filter/spamprobe for removal (diff)
downloadgentoo-633d3723e0759af60df3bdcd7b86b80f05b2daa3.tar.gz
gentoo-633d3723e0759af60df3bdcd7b86b80f05b2daa3.tar.bz2
gentoo-633d3723e0759af60df3bdcd7b86b80f05b2daa3.zip
net-dns/libidn2: Version bump.
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-dns/libidn2/libidn2-0.11.ebuild')
-rw-r--r--net-dns/libidn2/libidn2-0.11.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-dns/libidn2/libidn2-0.11.ebuild b/net-dns/libidn2/libidn2-0.11.ebuild
new file mode 100644
index 000000000000..7e6128bc7967
--- /dev/null
+++ b/net-dns/libidn2/libidn2-0.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
+HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2"
+SRC_URI="mirror://gnu-alpha/libidn/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10-examples.patch
+ "${FILESDIR}"/${PN}-0.10-Werror.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ default
+
+ prune_libtool_files
+}