summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManoj Gupta <manojgupta@google.com>2020-06-09 14:18:02 -0700
committerMike Gilbert <floppym@gentoo.org>2020-06-14 12:07:54 -0400
commit2628627eb9ee2ce925cd5c7cab6650d1f88606e8 (patch)
tree2ff41d6d206aa7d45096c53a7b2e01c15a9e95cc /net-dns/libidn2
parentdev-libs/libgcrypt: Respect portage host cc variable (diff)
downloadgentoo-2628627eb9ee2ce925cd5c7cab6650d1f88606e8.tar.gz
gentoo-2628627eb9ee2ce925cd5c7cab6650d1f88606e8.tar.bz2
gentoo-2628627eb9ee2ce925cd5c7cab6650d1f88606e8.zip
net-dns/libidn2: Respect portage host cc
Pass CC_FOR_BUILD to configure. Otherwise it invokes gcc instead of portage specified HOST/BUILD CC. Signed-off-by: Manoj Gupta <manojgupta@google.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/16152
Diffstat (limited to 'net-dns/libidn2')
-rw-r--r--net-dns/libidn2/libidn2-2.3.0.ebuild3
-rw-r--r--net-dns/libidn2/libidn2-99999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/net-dns/libidn2/libidn2-2.3.0.ebuild b/net-dns/libidn2/libidn2-2.3.0.ebuild
index 3fb6a9375886..e9f815344540 100644
--- a/net-dns/libidn2/libidn2-2.3.0.ebuild
+++ b/net-dns/libidn2/libidn2-2.3.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multilib-minimal
+inherit multilib-minimal toolchain-funcs
DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2 https://gitlab.com/libidn/libidn2"
@@ -40,6 +40,7 @@ src_prepare() {
multilib_src_configure() {
econf \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
$(use_enable static-libs static) \
--disable-doc \
--disable-gcc-warnings \
diff --git a/net-dns/libidn2/libidn2-99999.ebuild b/net-dns/libidn2/libidn2-99999.ebuild
index c678e41668b3..8b64b763df11 100644
--- a/net-dns/libidn2/libidn2-99999.ebuild
+++ b/net-dns/libidn2/libidn2-99999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools git-r3 multilib-minimal
+inherit autotools git-r3 multilib-minimal toolchain-funcs
DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2 https://gitlab.com/libidn/libidn2"
@@ -53,6 +53,7 @@ src_prepare() {
multilib_src_configure() {
econf \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
$(use_enable static-libs static) \
--disable-doc \
--disable-gcc-warnings \