summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-23 23:04:20 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-23 23:21:03 +0200
commit61748721dbd0136b7598a0648b6e0f8d10753430 (patch)
tree97f60a7194d15c31ffc9b086146c2967e9575ef3 /net-dns/nsd
parentsys-apps/sysvinit: Bump to version 2.96_beta (diff)
downloadgentoo-61748721dbd0136b7598a0648b6e0f8d10753430.tar.gz
gentoo-61748721dbd0136b7598a0648b6e0f8d10753430.tar.bz2
gentoo-61748721dbd0136b7598a0648b6e0f8d10753430.zip
net-dns/nsd: Bump to version 4.2.2
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-dns/nsd')
-rw-r--r--net-dns/nsd/Manifest1
-rw-r--r--net-dns/nsd/nsd-4.2.2.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index 7b095555077d..3e7686fa6e67 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -1,3 +1,4 @@
DIST nsd-4.1.27.tar.gz 1131881 BLAKE2B 94a7f7efe23d130b04258faca0f73690712919e14268e6efabf4029bc30273d8ef3155259b072190776b6cde32050b61ade0584175f00eef0129e4621d5896a3 SHA512 9c75041f5a6213cdba7238c2e51fc73031f6f073e06587659f93992fed49418ee789642b25b5522d48642507050ac15021f385927eed81ce5ea649f974e66402
DIST nsd-4.2.0.tar.gz 1141796 BLAKE2B 3e3df373e2ff00c170b9c104e1a4ca7038f98ad613104f045c594b7df17d4d66be1473a07e545deb9096c6a3945570530c5639c7b2f4c76234f643bce8c4fb40 SHA512 caa14fcd599ddc631cb74c3a56e571044dae1deb2fa9bd6b062f143954f9207b64b42ab5eab917360161f96bae8711df932f3e18b58be98b3f7b640071e7e807
DIST nsd-4.2.1.tar.gz 1145713 BLAKE2B 2cb265dbe274b68e2b038b98b37cf44b4dda4eb576f0fdae1c57686a3b99b0e2cdfd7f893ce196316ea02d1d872371cb36c00a35a5ddf8f83d66a981bf5b2560 SHA512 8f40baf7cc72b72a84f3c4eb45847f03b2f91e47dd7f3dfc89270c774565a8cc692363cee3547b0a2a124e9c43b23eed8887f95ae55b2e63af96c65467b85796
+DIST nsd-4.2.2.tar.gz 1149182 BLAKE2B 1cbac527063f7d14da589bd5060117da10fdd6a9e34b04eb763dbb94fe6c9cf09dc351985de3d099aea3377a4c945622871566c06e7f78aede885aa0c2bc5937 SHA512 43e2ee980a11ed0ad521cc9d8be1e2d29fa8ab552bdda043ffa7e5bc71cf07ad49319629f71e93dcf1dabd315f93bcfb9fd8b5847f27b125cf151fb4f63779b2
diff --git a/net-dns/nsd/nsd-4.2.2.ebuild b/net-dns/nsd/nsd-4.2.2.ebuild
new file mode 100644
index 000000000000..0eba80ae8a8a
--- /dev/null
+++ b/net-dns/nsd/nsd-4.2.2.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats dnstap ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl systemd libressl"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ acct-group/nsd
+ acct-user/nsd
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ libevent? ( dev-libs/libevent )
+ munin? ( net-analyzer/munin )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ systemd? ( virtual/pkgconfig )
+"
+
+PATCHES=(
+ # Fix the paths in the munin plugin to match our install
+ "${FILESDIR}"/nsd_munin_.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-largefile
+ --enable-pie
+ --enable-relro-now
+ --enable-tcp-fastopen
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable dnstap)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_enable systemd)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED}"/run || die "Failed to remove /run"
+
+ keepdir /var/db/${PN}
+}
+
+pkg_postinst() {
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/lib/nsd
+}