summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2021-05-26 19:14:15 +0200
committerSam James <sam@gentoo.org>2021-06-08 07:38:41 +0000
commit292990315147cf4c2e0491b4b5db6af9ae1ec832 (patch)
tree41941153d7e52e582525dc12c5e5004ccd53fb0d /net-dns
parentsci-mathematics/relational: add support for python-3.9 (diff)
downloadgentoo-292990315147cf4c2e0491b4b5db6af9ae1ec832.tar.gz
gentoo-292990315147cf4c2e0491b4b5db6af9ae1ec832.tar.bz2
gentoo-292990315147cf4c2e0491b4b5db6af9ae1ec832.zip
net-dns/knot: bump to 3.0.6
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Pierre-Olivier Mercier <nemunaire@nemunai.re> Closes: https://github.com/gentoo/gentoo/pull/21000 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/knot/Manifest1
-rw-r--r--net-dns/knot/knot-3.0.6.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index 0d9f877f1599..e0f31406e8d6 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -1,2 +1,3 @@
DIST knot-2.9.8.tar.xz 1194284 BLAKE2B c4329e5b2fc499851112d008af10c1a73bbe50cd07a4b5af984e99f389606b6f11c0b321dc26c14f872eb7cc70a99290a033f9aa9ff23a2b3694427605ffc704 SHA512 8104c3bdef2db4a79d6cd0fa4a30be1aa6edfa01363b97738d873445198cd031b4f5ab581d1a5277de49a8a042bb5340334be0579ceefa4b614e34c2cd454904
DIST knot-3.0.4.tar.xz 1347928 BLAKE2B c97df0c04dbd6b96d2f2805a2bbb07bc3fd0ac64160619a55fdf93ac02e6d3f797dfae43ac8bc79450c59c88e0a521911517577ea19d67bb41186cfcd07dd743 SHA512 d674faaafcbe882539d28e53f1cd6cdda61ca8065f66dc0b9127f249f34b59a9d3d1ac206799c2974a2d38264842a2387db35f814bd05f3eaeac0b35b90b21ac
+DIST knot-3.0.6.tar.xz 1333296 BLAKE2B 74ee1133dbf954234c4b07a29986cb91363256f3450b3d270f6d458d723e89bd1f7434881aa51632f02c369a16ca461e8ab892c34a2cf2ed612aa9040c91d535 SHA512 f1bfb0bc3a4cf622a68562409e71c8b84ee628a5452b48e172148bcac9cd0827b60a0c060075b80a086ca65da958d2d63e33ef7e373ab300b50089d06af3e5d0
diff --git a/net-dns/knot/knot-3.0.6.ebuild b/net-dns/knot/knot-3.0.6.ebuild
new file mode 100644
index 000000000000..ff2ab85cf4eb
--- /dev/null
+++ b/net-dns/knot/knot-3.0.6.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+KNOT_MODULES=(
+ "+cookies"
+ "+dnsproxy"
+ "dnstap"
+ "geoip"
+ "+noudp"
+ "+onlinesign"
+ "+queryacl"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn +libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ acct-group/knot
+ acct-user/knot
+ dev-db/lmdb
+ dev-libs/libedit
+ dev-libs/userspace-rcu:=
+ dev-python/lmdb
+ net-libs/gnutls:=
+ caps? ( sys-libs/libcap-ng )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c:=
+ )
+ geoip? ( dev-libs/libmaxminddb:= )
+ idn? (
+ !libidn2? ( net-dns/libidn:0= !net-dns/libidn2 )
+ libidn2? ( net-dns/libidn2:= )
+ )
+ systemd? ( sys-apps/systemd:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=(
+ --with-storage="${EPREFIX}/var/lib/${PN}"
+ --with-rundir="${EPREFIX}/var/run/${PN}"
+ $(use_enable fastparser)
+ $(use_enable dnstap)
+ $(use_enable doc documentation)
+ $(use_enable utils utilities)
+ --enable-systemd=$(usex systemd)
+ $(use_with idn libidn)
+ )
+
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with ${u} module-${u})")
+ done
+
+ econf "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ use doc && emake -C doc html
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+
+ default
+
+ rmdir "${D}/var/run/${PN}" "${D}/var/run/" || die
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}