summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-05-11 07:36:11 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2020-05-11 07:36:23 -0400
commit2f70f9e0cc5e56946b90a21efc41b413b14793d4 (patch)
tree495e12c924c94018842827b3cf7f4f9363a71df2 /net-dns
parentkde-apps/kio-extras: amd64 stable wrt bug #722152 (diff)
downloadgentoo-2f70f9e0cc5e56946b90a21efc41b413b14793d4.tar.gz
gentoo-2f70f9e0cc5e56946b90a21efc41b413b14793d4.tar.bz2
gentoo-2f70f9e0cc5e56946b90a21efc41b413b14793d4.zip
net-dns/ddclient: Bump to 3.9.1
Upstream has moved. So, updated homepage and SRC_URI as well. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/ddclient/Manifest1
-rw-r--r--net-dns/ddclient/ddclient-3.9.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-dns/ddclient/Manifest b/net-dns/ddclient/Manifest
index 65a72add02cf..351f7482edcf 100644
--- a/net-dns/ddclient/Manifest
+++ b/net-dns/ddclient/Manifest
@@ -1 +1,2 @@
DIST ddclient-3.9.0.tar.gz 59018 BLAKE2B b9b58108d9f124fcd5a72cc57bfb0e6a5bc2e115edc27a1d5950a929670d67d5c703b09f51e7e82e977ccfb544d115da177b0ac8dc06a76a800aa207cde5a42d SHA512 ae314c96a37dd90256d6acf62f4a4523b72f540194131e351a032239b00b4520351f6549d3b20a9209fe49ccc6de7ce158ffa8635d341066ea71b789dc667438
+DIST v3.9.1.tar.gz 63469 BLAKE2B 8ae6543353d96f76d926117ae53d74da6e8bc8f116fa15b8b0d39bc29a4c334bfc3d673b8f1c57139213b91414d1b9a2063fde9e1015f03fb76ba70a60956a7e SHA512 a8a4d6cb94e4239a7b7b4fc7d9ebef703cbd6c45fc3394b644694a053b5b8aa8d109410b5b8b3676a5f30b18474d24c7feb16c65c30b28bd7d941d8a214b1346
diff --git a/net-dns/ddclient/ddclient-3.9.1.ebuild b/net-dns/ddclient/ddclient-3.9.1.ebuild
new file mode 100644
index 000000000000..6e9b734e93fe
--- /dev/null
+++ b/net-dns/ddclient/ddclient-3.9.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="Perl client used to update dynamic DNS entries"
+HOMEPAGE="https://ddclient.net/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="examples iproute2"
+
+RDEPEND="
+ acct-group/ddclient
+ acct-user/ddclient
+ dev-lang/perl
+ dev-perl/Data-Validate-IP
+ dev-perl/Digest-SHA1
+ dev-perl/IO-Socket-INET6
+ dev-perl/IO-Socket-SSL
+ virtual/perl-Digest-SHA
+ virtual/perl-JSON-PP
+ iproute2? ( sys-apps/iproute2 )
+"
+
+src_prepare() {
+ # Remove PID setting, to reliably setup the environment for the init script
+ sed -e '/^pid/d' -i sample-etc_ddclient.conf || die
+
+ # Remove windows executable
+ if use examples; then
+ rm sample-etc_dhcpc_dhcpcd-eth0.exe || die
+ fi
+
+ # Use sys-apps/iproute2 instead of sys-apps/net-tools
+ use iproute2 && eapply "${FILESDIR}"/${PN}-3.9.0-use_iproute2.patch
+
+ default
+}
+
+src_install() {
+ dobin ddclient
+
+ insinto /etc/ddclient
+ insopts -m 0600 -o ddclient -g ddclient
+ newins sample-etc_ddclient.conf ddclient.conf
+
+ newinitd "${FILESDIR}"/ddclient.initd-r6 ddclient
+ systemd_newunit "${FILESDIR}"/ddclient.service-r1 ddclient.service
+ systemd_newtmpfilesd "${FILESDIR}"/ddclient.tmpfiles ddclient.conf
+
+ dodoc Change* README* RELEASENOTE TODO UPGRADE
+
+ if use examples; then
+ docinto examples
+ dodoc sample-*
+ fi
+}