summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2016-11-20 21:07:06 +0000
committerSven Wegener <swegener@gentoo.org>2016-11-20 21:07:55 +0000
commit4bcf4c432dcff57befea68d05a7fe6f0ff87ab41 (patch)
treeccac1f824e54bc59844f2b4e59fd284097e91b39 /net-dns
parentnet-firewall/ipsec-tools: stable on ppc and ppc64, bug #550118 (diff)
downloadgentoo-4bcf4c432dcff57befea68d05a7fe6f0ff87ab41.tar.gz
gentoo-4bcf4c432dcff57befea68d05a7fe6f0ff87ab41.tar.bz2
gentoo-4bcf4c432dcff57befea68d05a7fe6f0ff87ab41.zip
net-dns/pdns-recursor: Fix building with disabled ECDSA support, bug #590370
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns-recursor/files/pdns-recursor-4.0.3-ecdsa.patch29
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.0.3.ebuild1
2 files changed, 30 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/files/pdns-recursor-4.0.3-ecdsa.patch b/net-dns/pdns-recursor/files/pdns-recursor-4.0.3-ecdsa.patch
new file mode 100644
index 000000000000..52826c9617af
--- /dev/null
+++ b/net-dns/pdns-recursor/files/pdns-recursor-4.0.3-ecdsa.patch
@@ -0,0 +1,29 @@
+commit 3d59c6f7d83f54d5c73013de5ab61e9a0ecd1460
+Author: Remi Gacogne <remi.gacogne@powerdns.com>
+Date: Mon Oct 17 10:07:26 2016 +0200
+
+ Fix building with ECDSA support disabled in libcrypto
+
+ (cherry picked from commit aa74d164ae29269168d048d2cc8d7e1f984774c4)
+
+diff --git a/opensslsigners.cc b/opensslsigners.cc
+index 9e919a0..acf8f08 100644
+--- a/opensslsigners.cc
++++ b/opensslsigners.cc
+@@ -128,6 +128,7 @@ static inline int RSA_set0_crt_params(RSA* rsakey, BIGNUM* dmp1, BIGNUM* dmq1, B
+ return 1;
+ }
+
++#ifdef HAVE_LIBCRYPTO_ECDSA
+ static inline void ECDSA_SIG_get0(const ECDSA_SIG* signature, const BIGNUM** pr, const BIGNUM** ps) {
+ *pr = signature->r;
+ *ps = signature->s;
+@@ -140,6 +141,8 @@ static inline int ECDSA_SIG_set0(ECDSA_SIG* signature, BIGNUM* pr, BIGNUM* ps) {
+ signature->s = ps;
+ return 1;
+ }
++#endif /* HAVE_LIBCRYPTO_ECDSA */
++
+ #else
+ void openssl_thread_setup() {}
+ void openssl_thread_cleanup() {}
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.0.3.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.0.3.ebuild
index 321a847fee18..954fcbd25ef3 100644
--- a/net-dns/pdns-recursor/pdns-recursor-4.0.3.ebuild
+++ b/net-dns/pdns-recursor/pdns-recursor-4.0.3.ebuild
@@ -32,6 +32,7 @@ S="${WORKDIR}"/${P/_/-}
PATCHES=(
"${FILESDIR}"/${P}-boost-1.61-fcontext.patch
+ "${FILESDIR}"/${P}-ecdsa.patch
)
pkg_setup() {