summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-06-26 03:12:40 +0200
committerJeroen Roovers <jer@gentoo.org>2017-06-26 03:13:34 +0200
commit5ac43983c6eec180fa8e845cb00e197ce1def2e0 (patch)
tree09ea3dc75deb18978a2321a2343706c82f86818d /net-dns
parentapp-office/libreoffice: DEPEND on dev-libs/xmlsec[nss] instead of bundled (diff)
downloadgentoo-5ac43983c6eec180fa8e845cb00e197ce1def2e0.tar.gz
gentoo-5ac43983c6eec180fa8e845cb00e197ce1def2e0.tar.bz2
gentoo-5ac43983c6eec180fa8e845cb00e197ce1def2e0.zip
net-dns/knot: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/knot/Manifest2
-rw-r--r--net-dns/knot/knot-2.4.5.ebuild78
-rw-r--r--net-dns/knot/knot-2.5.2.ebuild77
3 files changed, 157 insertions, 0 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index 2e6422b051ca..2381fe895e29 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -1,3 +1,5 @@
DIST knot-2.3.3.tar.xz 1071160 SHA256 a929bce3b957a81776b1db7b43b0e4473339bf16be8dbba5abb4b0593bf43c94 SHA512 ed7b93c2d0ae15819d09a8bf77c2d12505a035dcd7777e9ac453b58c36d302c3cbaa2766e1f6d2163a71234d005494a7d9b5be436c0e16b443de4da97f7a5d9f WHIRLPOOL 4bdf92d537d90e2ad412bb0619a7b4b8f0752c9dc981b3522beece19514f22d88db083e59c0f833d9492b0a1f8d347e008350d108d4c7337c9ee748d007bbde7
DIST knot-2.4.4.tar.xz 1111116 SHA256 9e9e743399f565129fc5f94380912514498817e18dd32ec4f8780d60452e563c SHA512 b35a4d93929a226c768e13ff315a40a5752167ad6470521a3a01f73df91d093a7ee1c864ec2a37609e563c130efa2c6db287bd762edd82e0d9bf8a2854783800 WHIRLPOOL e4b4e7a9e5880c34731818a3a5937f74d78920a15a484c4f3aa5f86b0e9e4c0d4d36ac1ca83556b1265ac1e8f2f4bfed933162a8761e1a87af34d156c40e3fdd
+DIST knot-2.4.5.tar.xz 1111536 SHA256 87ce8ccc83511c5a1f4eadd3f0122f2f5ae86fb68e9b72f0700c6f5340ba95cb SHA512 db4919dbe2dc688f401e6611d784d47e1d40a0f8ec8c8cd6240d89ab9dd2ce7dd1976ac7cb24c712ed8aa074e0026ff0a10e9d6d5e685929d271ae554d9a1cff WHIRLPOOL cdfdf0bc2591df8436f8ab0959581129cb1a4d86138f6bb75b507d83280c7d567eb794e3b76b8374d4087721de53e4afd7566411b8e51fa2655e9e5462357ef4
DIST knot-2.5.1.tar.xz 1070108 SHA256 6c08cdc0a0182e262136b936a968ad667abce112195d99c27e50ea22afc08398 SHA512 83e65f0d16fc53377a31baedcd2b23f32ec7ac2c7e83728d0df1455935cad980534e27daf1e230bb8cd319728cc340d96d4de5a921220e651a5beabb2a9f9fcb WHIRLPOOL 67c67bc937591ea53a05cf185e815b862b4d39e87fd681057ce5011c55d052cd09ce350667d4ad144e305943acb6da44d802bee344d5d7229cce080182b31dbb
+DIST knot-2.5.2.tar.xz 1071648 SHA256 286671a4ee35a5207b2e45fd0812962b481b1b543bf3d5df3a8c319c26e2f5e9 SHA512 bc40ec34dfab45daa3e41839ad9bf1590c36240678a7cb6256103f42a95603e24213f7258cf9fa323a26690de482e848270048d624bf4da7f989d9efb6ea2a11 WHIRLPOOL a465ff278d735b227a35733c0f57b5167a77399c678f088d56a620ea5d51198a5d4aab785235476bdcdf14290fbc7550944ea7d8971c66486c1643423bfbe0c3
diff --git a/net-dns/knot/knot-2.4.5.ebuild b/net-dns/knot/knot-2.4.5.ebuild
new file mode 100644
index 000000000000..50af785a49d1
--- /dev/null
+++ b/net-dns/knot/knot-2.4.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 eutils systemd user
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="http://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dnstap doc caps +fastparser idn systemd"
+
+RDEPEND="
+ >=net-libs/gnutls-3.3:=
+ >=dev-libs/jansson-2.3
+ >=dev-db/lmdb-0.9.15
+ >=dev-libs/userspace-rcu-0.5.4
+ caps? ( >=sys-libs/libcap-ng-0.6.4 )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ idn? ( net-dns/libidn )
+ dev-libs/libedit
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ econf \
+ --with-storage="${EPREFIX}/var/lib/${PN}" \
+ --with-rundir="${EPREFIX}/var/run/${PN}" \
+ --with-lmdb \
+ --with-bash-completions="$(get_bashcompdir)" \
+ $(use_enable fastparser) \
+ $(use_enable dnstap) \
+ $(use_enable doc documentation) \
+ $(use_with idn libidn) \
+ --enable-systemd=$(usex systemd)
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ keepdir /var/lib/${PN}
+
+ newinitd "${FILESDIR}/knot.init" knot
+ systemd_dounit "${FILESDIR}/knot.service"
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ enewgroup knot 53
+ enewuser knot 53 -1 /var/lib/knot knot
+}
diff --git a/net-dns/knot/knot-2.5.2.ebuild b/net-dns/knot/knot-2.5.2.ebuild
new file mode 100644
index 000000000000..4644120da23f
--- /dev/null
+++ b/net-dns/knot/knot-2.5.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 eutils systemd user
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="http://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dnstap doc caps +fastparser idn systemd"
+
+RDEPEND="
+ >=net-libs/gnutls-3.3:=
+ >=dev-db/lmdb-0.9.15
+ >=dev-libs/userspace-rcu-0.5.4
+ caps? ( >=sys-libs/libcap-ng-0.6.4 )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ idn? ( || ( net-dns/libidn >=net-dns/libidn2-2.0.0 ) )
+ dev-libs/libedit
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ econf \
+ --with-storage="${EPREFIX}/var/lib/${PN}" \
+ --with-rundir="${EPREFIX}/var/run/${PN}" \
+ --with-lmdb \
+ --with-bash-completions="$(get_bashcompdir)" \
+ $(use_enable fastparser) \
+ $(use_enable dnstap) \
+ $(use_enable doc documentation) \
+ $(use_with idn libidn) \
+ --enable-systemd=$(usex systemd)
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ keepdir /var/lib/${PN}
+
+ newinitd "${FILESDIR}/knot.init" knot
+ systemd_dounit "${FILESDIR}/knot.service"
+
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ enewgroup knot 53
+ enewuser knot 53 -1 /var/lib/knot knot
+}