summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-16 23:36:45 +0000
committerSam James <sam@gentoo.org>2022-11-16 23:36:45 +0000
commit7c17f8e073c73523ec0421684dfa6d41c6cc20bb (patch)
tree6d2ae5d4a8887edcd742f7eac77c09287aa9ca93 /net-dns
parentdev-perl/Crypt-OpenSSL-RSA: Stabilize 0.330.0 arm64, #881375 (diff)
downloadgentoo-7c17f8e073c73523ec0421684dfa6d41c6cc20bb.tar.gz
gentoo-7c17f8e073c73523ec0421684dfa6d41c6cc20bb.tar.bz2
gentoo-7c17f8e073c73523ec0421684dfa6d41c6cc20bb.zip
net-dns/updatedd: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/848747 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/updatedd/files/updatedd-2.6-respect-docdir.patch25
-rw-r--r--net-dns/updatedd/updatedd-2.6-r7.ebuild (renamed from net-dns/updatedd/updatedd-2.6-r6.ebuild)27
2 files changed, 43 insertions, 9 deletions
diff --git a/net-dns/updatedd/files/updatedd-2.6-respect-docdir.patch b/net-dns/updatedd/files/updatedd-2.6-respect-docdir.patch
new file mode 100644
index 000000000000..437d326a6e30
--- /dev/null
+++ b/net-dns/updatedd/files/updatedd-2.6-respect-docdir.patch
@@ -0,0 +1,25 @@
+From 8e484c4b0ceac8e7c37492fdf5e5b89f18451277 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Sat, 14 Jan 2017 01:06:48 -0500
+Subject: [PATCH 1/1] Use the autotools "docdir" in Documentation/Makefile.am.
+
+--- a/Documentation/Makefile.am
++++ b/Documentation/Makefile.am
+@@ -2,12 +2,12 @@
+
+ ## install documentation
+ install-data-local:
+- $(INSTALL) -d $(DESTDIR)$(datadir)/doc/updatedd
+- $(INSTALL) $(srcdir)/updatedd-*.pdf $(DESTDIR)$(datadir)/doc/updatedd
+- $(INSTALL) $(srcdir)/updatedd-pppd-rc $(DESTDIR)$(datadir)/doc/updatedd
++ $(INSTALL) -d $(DESTDIR)$(docdir)
++ $(INSTALL) $(srcdir)/updatedd-*.pdf $(DESTDIR)$(docdir)
++ $(INSTALL) $(srcdir)/updatedd-pppd-rc $(DESTDIR)$(docdir)
+
+-uninstall-local:
+- $(RM) -r $(DESTDIR)$(datadir)/doc/updatedd
++uninstall-local:/
++ $(RM) -r $(DESTDIR)$(datadir)/updatedd
+
+ ## include debian files
+ EXTRA_DIST = updatedd-2.4-english.pdf updatedd-2.4-german.pdf updatedd-pppd-rc COPYING
diff --git a/net-dns/updatedd/updatedd-2.6-r6.ebuild b/net-dns/updatedd/updatedd-2.6-r7.ebuild
index d55cae76e39c..4b7df5532d7e 100644
--- a/net-dns/updatedd/updatedd-2.6-r6.ebuild
+++ b/net-dns/updatedd/updatedd-2.6-r7.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit autotools
DESCRIPTION="Dynamic DNS client with plugins for several dynamic dns services"
HOMEPAGE="https://savannah.nongnu.org/projects/updatedd/"
@@ -10,20 +12,27 @@ SRC_URI="https://savannah.nongnu.org/download/updatedd/${PN}_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ppc x86"
-IUSE=""
-DEPEND=""
-RDEPEND="dev-lang/perl
- dev-perl/IO-Socket-Timeout"
+RDEPEND="
+ dev-lang/perl
+ dev-perl/IO-Socket-Timeout
+"
PATCHES=(
"${FILESDIR}/${P}-options.patch"
"${FILESDIR}/fix-ovh-DYNDNSHOST.patch"
- "${FILESDIR}/respect-docdir.patch"
"${FILESDIR}/set-socket-timeouts-for-ipserv.patch"
"${FILESDIR}/fix-ovh-support.patch"
+ "${FILESDIR}/${P}-respect-docdir.patch"
)
-src_configure() {
- econf --disable-static
+src_prepare() {
+ default
+
+ # Needed for Clang 16
+ eautoreconf
+}
+
+src_install() {
+ find "${ED}" -name '*.la' -delete || die
}