summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-03-28 01:09:51 +0000
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-03-27 19:00:00 -0700
commit91634390617c42008d78565a1c8db3f38da145ad (patch)
treeccf7cc7925d993dd00253b5b7060ded0688a833a /net-dns
parentprofiles/package.mask: security mask dev-java/icedtea-web (diff)
downloadgentoo-91634390617c42008d78565a1c8db3f38da145ad.tar.gz
gentoo-91634390617c42008d78565a1c8db3f38da145ad.tar.bz2
gentoo-91634390617c42008d78565a1c8db3f38da145ad.zip
net-dns/dnscrypt-proxy: Bump to 2.0.42
Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnscrypt-proxy/Manifest1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.42.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index 0fd119dfa6f6..054695abc37c 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -1,3 +1,4 @@
DIST dnscrypt-proxy-2.0.33.tar.gz 2723092 BLAKE2B 26ed819f264c1a536b2e47d9ffa412097eba5c9597ad2a5e7ff7a485ad660aeb882c5ce527bb072a5f7b5782387ce1b72cc74400973f9cebd66a50bd2308d830 SHA512 5c6eb655aa70457889253cbf630e7e37011a461a7f181f0a667694d53146ad9dee88bbbf80c7db3187bba0054af2a63b7b5be1a229800b2566a9758e9d047429
DIST dnscrypt-proxy-2.0.39.tar.gz 2814424 BLAKE2B 59be804a9c9641dd43e6b49e95c58c7d20dfdc940f2279a47a9ced707d1bbe64b1864c65feab2cada6c12945567ffd93478bd0a8129d40ea65c0fef50e5e90e4 SHA512 d4eacd8d1989b99d9932d66ef609948558af26f9db1fc37acd6b5609e2a410d20828e32f2b79f2f9fbdf822998af641aec20128e4c58233663929106e29d8e24
DIST dnscrypt-proxy-2.0.41.tar.gz 2323421 BLAKE2B 572a0ad15df6c40d1738b296972584f5d8fe382ca3c0a05b4fc74e986e767a058227dda2127c843127bc0b90e8b7bbe17a5eaee42175f0b77e21160ac63f7a88 SHA512 26be163daa03633f2d76f1121fb1987e0155613bd84cbb2aad2ba0eedbd35ec0b393d1c1a0aaba47968b3a08bd0273ad929a164695ce35d2ebe05ce3b5f5dfd1
+DIST dnscrypt-proxy-2.0.42.tar.gz 2324442 BLAKE2B 8444eca1fc2bfc6029c1848bbeb77697b9b9c228c1bd0d17ed357b73667524c7052b33410a92847743533c3712f749fd93dbac46a81da48dae367e2a515cad8c SHA512 093b07ee8eb44c1264e6ea4b60ad32e0221b1b02c1d61f142b1fbf37dc5181533cc3c5d6e7468d0f7488611de4620947684269da9f08f21da0aa501ba70be711
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.42.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.42.ebuild
new file mode 100644
index 000000000000..b5bda3db325f
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.42.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/DNSCrypt/${PN}"
+
+inherit fcaps go-module systemd
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+else
+ SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+fi
+
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
+
+LICENSE="Apache-2.0 BSD ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="pie"
+
+BDEPEND=">=dev-lang/go-1.13"
+
+RDEPEND="
+ acct-group/dnscrypt-proxy
+ acct-user/dnscrypt-proxy
+"
+
+FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
+
+PATCHES=( "${FILESDIR}"/config-full-paths-r11.patch )
+
+src_compile() {
+ pushd "${PN}" >/dev/null || die
+ go build -v -x -mod=readonly -mod=vendor -buildmode="$(usex pie pie default)" || die
+ popd >/dev/null || die
+}
+
+src_install() {
+ pushd "${PN}" >/dev/null || die
+
+ dobin dnscrypt-proxy
+
+ insinto /etc/dnscrypt-proxy
+ newins example-dnscrypt-proxy.toml dnscrypt-proxy.toml
+ doins example-{blacklist.txt,whitelist.txt}
+ doins example-{cloaking-rules.txt,forwarding-rules.txt}
+
+ popd >/dev/null || die
+
+ insinto /usr/share/dnscrypt-proxy
+ doins -r "utils/generate-domains-blacklists/."
+
+ newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
+ newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
+
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/dnscrypt-proxy.logrotate dnscrypt-proxy
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ go-module_pkg_postinst
+
+ if ! use filecaps; then
+ ewarn "'filecaps' USE flag is disabled"
+ ewarn "${PN} will fail to listen on port 53"
+ ewarn "please do one the following:"
+ ewarn "1) re-enable 'filecaps'"
+ ewarn "2) change port to > 1024"
+ ewarn "3) configure to run ${PN} as root (not recommended)"
+ ewarn
+ fi
+
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "Using systemd socket activation may cause issues with speed"
+ elog "latency and reliability of ${PN} and is discouraged by upstream"
+ elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
+ elog "It is disabled by default for new installations"
+ elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
+ elog
+
+ fi
+
+ elog "After starting the service you will need to update your"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
+ elog "with:"
+ elog
+ elog "nameserver 127.0.0.1"
+ elog
+ elog "Also see https://github.com/DNSCrypt/${PN}/wiki"
+}