summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-04-22 13:49:12 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-04-22 13:49:12 -0400
commit9b7844d3644f110e48232114171c36a4bc311d71 (patch)
tree540cfa421d8952abf805cd7872e93128bf7b7f76 /net-dns
parentprofiles: improve webstart masks wording (diff)
downloadgentoo-9b7844d3644f110e48232114171c36a4bc311d71.tar.gz
gentoo-9b7844d3644f110e48232114171c36a4bc311d71.tar.bz2
gentoo-9b7844d3644f110e48232114171c36a4bc311d71.zip
net-dns/rbldnsd: fix CC detection at configure time.
The build system for rbldnsd is hand-written. While we were already passing CC to the "emake" command, it turns out that the ./configure script checks for it as well. Thus it was possible for src_configure() to fail if the ./configure script couldn't guess which compiler wouldn't be used anyway. Whee. Fixed by passing the same CC that emake will use to ./configure, too. Closes: https://bugs.gentoo.org/718888 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/rbldnsd/rbldnsd-0.998b-r2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-dns/rbldnsd/rbldnsd-0.998b-r2.ebuild b/net-dns/rbldnsd/rbldnsd-0.998b-r2.ebuild
index a95bcde36f78..fb38ede3d4c6 100644
--- a/net-dns/rbldnsd/rbldnsd-0.998b-r2.ebuild
+++ b/net-dns/rbldnsd/rbldnsd-0.998b-r2.ebuild
@@ -28,8 +28,10 @@ RESTRICT=test
src_configure() {
# The ./configure file is handwritten and doesn't support a `make
# install` target, so there are no --prefix options. The econf
- # function appends those automatically, so we can't use it.
- ./configure \
+ # function appends those automatically, so we can't use it. We
+ # Have to set $CC here, too (and not just in the call to emake),
+ # because the ./configure script checks for it.
+ CC="$(tc-getCC)" ./configure \
$(use_enable ipv6) \
$(use_enable zlib) \
|| die "./configure failed"