summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-05-17 10:18:19 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-17 13:26:56 -0700
commitd7e21fcab1e828d5818511fd9ca7f433ee9a3c0c (patch)
tree3437903c9de4645954354c5588319093c08dc9da /net-dns
parentprofiles: powerpc: Add matplotlib-python2[qt5,test] to p.use.stable.mask (diff)
downloadgentoo-d7e21fcab1e828d5818511fd9ca7f433ee9a3c0c.tar.gz
gentoo-d7e21fcab1e828d5818511fd9ca7f433ee9a3c0c.tar.bz2
gentoo-d7e21fcab1e828d5818511fd9ca7f433ee9a3c0c.zip
net-nds/dnsmasq: drop old
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsmasq/Manifest1
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.80-r2.ebuild214
-rw-r--r--net-dns/dnsmasq/files/dnsmasq-2.80-cve-2019-14834.patch39
-rw-r--r--net-dns/dnsmasq/files/dnsmasq-2.80-linux-headers-5.2.patch25
-rw-r--r--net-dns/dnsmasq/files/dnsmasq-2.80-nettle-3.5.patch42
5 files changed, 0 insertions, 321 deletions
diff --git a/net-dns/dnsmasq/Manifest b/net-dns/dnsmasq/Manifest
index 39931332aaa9..2fc501fa830f 100644
--- a/net-dns/dnsmasq/Manifest
+++ b/net-dns/dnsmasq/Manifest
@@ -1,2 +1 @@
-DIST dnsmasq-2.80.tar.xz 501072 BLAKE2B 39c9808df43a22e32286105c9e001b2f817a4f68b92b84282eeb8cfeaa61404d64275bbb3f944bec6fac1b015987fba6aeab7a88201446c0cff67f02c8d88d8c SHA512 58e56beb553fc41311e5dc16d8b0eb3b6801e2bdfbcd0e7a6659703f08960b6ad10d48b0b14a4d727636faf35483e01597cff2ae49e7fe9fa9e214f437b1c068
DIST dnsmasq-2.81.tar.xz 510648 BLAKE2B 07861888df11f6e2e02d1b80f4e82a407b558ddb34e016f7bda5cb449ee870db000683264b2e36987ece16d50ab773f239bf12dd3468b9529ae4dccd77ecb8ee SHA512 85550c9782fef9b0710d0e233523ed1fe26e877a8bc53fcea3f7cf1fb17c3a79c46f284a99dab2bdaf6a107ea3f1a71cec476ab6d4e1b936da6591aaef42c88e
diff --git a/net-dns/dnsmasq/dnsmasq-2.80-r2.ebuild b/net-dns/dnsmasq/dnsmasq-2.80-r2.ebuild
deleted file mode 100644
index b1920a182914..000000000000
--- a/net-dns/dnsmasq/dnsmasq-2.80-r2.ebuild
+++ /dev/null
@@ -1,214 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs flag-o-matic user systemd
-
-DESCRIPTION="Small forwarding DNS server"
-HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/doc.html"
-SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
-
-IUSE="auth-dns conntrack dbus +dhcp dhcp-tools dnssec +dumpfile id idn libidn2"
-IUSE+=" +inotify ipv6 lua nls script selinux static tftp"
-
-DM_LINGUAS=(de es fi fr id it no pl pt_BR ro)
-
-BDEPEND="app-arch/xz-utils
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-
-COMMON_DEPEND="dbus? ( sys-apps/dbus:= )
- idn? (
- !libidn2? ( net-dns/libidn:0= )
- libidn2? ( >=net-dns/libidn2-2.0:= )
- )
- lua? ( dev-lang/lua:* )
- conntrack? ( net-libs/libnetfilter_conntrack:= )
- nls? ( sys-devel/gettext )
-"
-
-DEPEND="${COMMON_DEPEND}
- dnssec? (
- dev-libs/nettle:=[gmp]
- static? ( >=dev-libs/nettle-3.4[static-libs(+)] )
- )
-"
-
-RDEPEND="${COMMON_DEPEND}
- dnssec? (
- !static? (
- >=dev-libs/nettle-3.4:=[gmp]
- )
- )
- selinux? ( sec-policy/selinux-dnsmasq )
-"
-
-REQUIRED_USE="dhcp-tools? ( dhcp )
- lua? ( script )
- libidn2? ( idn )"
-
-PATCHES=(
- "${FILESDIR}/dnsmasq-2.80-nettle-3.5.patch"
- "${FILESDIR}/dnsmasq-2.80-linux-headers-5.2.patch"
- "${FILESDIR}/dnsmasq-2.80-cve-2019-14834.patch"
-)
-
-use_have() {
- local useflag no_only uword
- if [[ ${1} == '-n' ]]; then
- no_only=1
- shift
- fi
- useflag="${1}"
- shift
-
- uword="${1:-${useflag}}"
- shift
-
- while [[ ${uword} ]]; do
- uword="${uword^^}"
-
- if ! use "${useflag}"; then
- printf -- " -DNO_%s" "${uword}"
- elif [[ -z "${no_only}" ]]; then
- printf -- " -DHAVE_%s" "${uword}"
- fi
- uword="${1}"
- shift
- done
-}
-
-pkg_pretend() {
- if use static; then
- einfo "Only sys-libs/gmp and dev-libs/nettle are statically linked."
- use dnssec || einfo "Thus, ${P}[!dnssec,static] makes no sense;" \
- "the static USE flag is ignored."
- fi
-}
-
-pkg_setup() {
- enewgroup dnsmasq
- enewuser dnsmasq -1 -1 /dev/null dnsmasq
-}
-
-src_prepare() {
- default
-
- sed -i -r 's:lua5.[0-9]+:lua:' Makefile
- sed -i "s:%%PREFIX%%:${EPREFIX}/usr:" dnsmasq.conf.example
-}
-
-src_configure() {
- COPTS=(
- "$(use_have -n auth-dns auth)"
- "$(use_have conntrack)"
- "$(use_have dbus)"
- "$(use libidn2 || use_have idn)"
- "$(use_have libidn2)"
- "$(use_have -n inotify)"
- "$(use_have -n dhcp dhcp dhcp6)"
- "$(use_have -n ipv6 ipv6 dhcp6)"
- "$(use_have -n id id)"
- "$(use_have lua luascript)"
- "$(use_have -n script)"
- "$(use_have -n tftp)"
- "$(use_have dnssec)"
- "$(use_have static dnssec_static)"
- "$(use_have -n dumpfile)"
- )
-}
-
-src_compile() {
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- COPTS="${COPTS[*]}" \
- CONFFILE="/etc/${PN}.conf" \
- all$(use nls && printf -- "-i18n\n")
-
- use dhcp-tools && emake -C contrib/lease-tools \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- CC="$(tc-getCC)" \
- PKG_CONFIG="$(tc-getPKG_CONFIG)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- all
-}
-
-src_install() {
- local lingua puid
- emake \
- PREFIX=/usr \
- MANDIR=/usr/share/man \
- COPTS="${COPTS[*]}" \
- DESTDIR="${ED}" \
- install$(use nls && printf -- "-i18n\n")
-
- for lingua in "${DM_LINGUAS[@]}"; do
- has ${lingua} ${LINGUAS-${lingua}} \
- || rm -rf "${ED}"/usr/share/locale/${lingua}
- done
- [[ -d "${D}"/usr/share/locale/ ]] && \
- rmdir --ignore-fail-on-non-empty "${ED}"/usr/share/locale/
-
- dodoc CHANGELOG CHANGELOG.archive FAQ dnsmasq.conf.example
- dodoc -r logo
-
- docinto html/
- dodoc *.html
-
- newinitd "${FILESDIR}"/dnsmasq-init-r4 ${PN}
- newconfd "${FILESDIR}"/dnsmasq.confd-r1 ${PN}
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/dnsmasq.logrotate ${PN}
-
- insinto /etc
- newins dnsmasq.conf.example dnsmasq.conf
-
- insinto /usr/share/dnsmasq
- doins trust-anchors.conf
-
- if use dhcp; then
- keepdir /var/lib/misc
- newinitd "${FILESDIR}"/dnsmasq-init-dhcp-r3 ${PN}
- fi
- if use dbus; then
- insinto /etc/dbus-1/system.d
- doins dbus/dnsmasq.conf
- fi
-
- if use dhcp-tools; then
- dosbin contrib/lease-tools/{dhcp_release,dhcp_lease_time}
- doman contrib/lease-tools/{dhcp_release,dhcp_lease_time}.1
- if use ipv6; then
- dosbin contrib/lease-tools/dhcp_release6
- doman contrib/lease-tools/dhcp_release6.1
- fi
- fi
-
- systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
-}
-
-pkg_preinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f /var/lib/misc/dnsmasq.leases ]] && \
- cp /var/lib/misc/dnsmasq.leases "${T}"
-}
-
-pkg_postinst() {
- # temporary workaround to (hopefully) prevent leases file from being removed
- [[ -f "${T}"/dnsmasq.leases ]] && \
- cp "${T}"/dnsmasq.leases /var/lib/misc/dnsmasq.leases
-}
diff --git a/net-dns/dnsmasq/files/dnsmasq-2.80-cve-2019-14834.patch b/net-dns/dnsmasq/files/dnsmasq-2.80-cve-2019-14834.patch
deleted file mode 100644
index a44ceabece71..000000000000
--- a/net-dns/dnsmasq/files/dnsmasq-2.80-cve-2019-14834.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Fix memory leak in helper.c
-
-Thanks to Xu Mingjie <xumingjie1995@outlook.com> for spotting this.
-
-author: Simon Kelley <simon@thekelleys.org.uk>
-commit-url: http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=69bc94779c2f035a9fffdb5327a54c3aeca73ed5
-diff --git a/src/helper.c b/src/helper.c
-index 33ba120..c392eec 100644 (file)
---- a/src/helper.c
-+++ b/src/helper.c
-@@ -80,7 +80,8 @@ int create_helper(int event_fd, int err_fd, uid_t uid, gid_t gid, long max_fd)
- pid_t pid;
- int i, pipefd[2];
- struct sigaction sigact;
--
-+ unsigned char *alloc_buff = NULL;
-+
- /* create the pipe through which the main program sends us commands,
- then fork our process. */
- if (pipe(pipefd) == -1 || !fix_fd(pipefd[1]) || (pid = fork()) == -1)
-@@ -186,11 +187,16 @@ int create_helper(int event_fd, int err_fd, uid_t uid, gid_t gid, long max_fd)
- struct script_data data;
- char *p, *action_str, *hostname = NULL, *domain = NULL;
- unsigned char *buf = (unsigned char *)daemon->namebuff;
-- unsigned char *end, *extradata, *alloc_buff = NULL;
-+ unsigned char *end, *extradata;
- int is6, err = 0;
- int pipeout[2];
-
-- free(alloc_buff);
-+ /* Free rarely-allocated memory from previous iteration. */
-+ if (alloc_buff)
-+ {
-+ free(alloc_buff);
-+ alloc_buff = NULL;
-+ }
-
- /* we read zero bytes when pipe closed: this is our signal to exit */
- if (!read_write(pipefd[0], (unsigned char *)&data, sizeof(data), 1))
diff --git a/net-dns/dnsmasq/files/dnsmasq-2.80-linux-headers-5.2.patch b/net-dns/dnsmasq/files/dnsmasq-2.80-linux-headers-5.2.patch
deleted file mode 100644
index 21bd7cd39ff6..000000000000
--- a/net-dns/dnsmasq/files/dnsmasq-2.80-linux-headers-5.2.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 3052ce208acf602f0163166dcefb7330d537cedb Mon Sep 17 00:00:00 2001
-From: Jiri Slaby <jslaby@suse.cz>
-Date: Wed, 24 Jul 2019 17:34:48 +0100
-Subject: [PATCH] Fix build after y2038 changes in glib.
-
-SIOCGSTAMP is defined in linux/sockios.h, not asm/sockios.h now.
----
- src/dnsmasq.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/dnsmasq.h b/src/dnsmasq.h
-index ff3204a..3ef04ad 100644
---- a/src/dnsmasq.h
-+++ b/src/dnsmasq.h
-@@ -137,6 +137,7 @@ typedef unsigned long long u64;
- #endif
-
- #if defined(HAVE_LINUX_NETWORK)
-+#include <linux/sockios.h>
- #include <linux/capability.h>
- /* There doesn't seem to be a universally-available
- userspace header for these. */
---
-1.7.10.4
-
diff --git a/net-dns/dnsmasq/files/dnsmasq-2.80-nettle-3.5.patch b/net-dns/dnsmasq/files/dnsmasq-2.80-nettle-3.5.patch
deleted file mode 100644
index 7d77a21de7cb..000000000000
--- a/net-dns/dnsmasq/files/dnsmasq-2.80-nettle-3.5.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 6fd9aba7abe1e084123bc5002959350897774ace Mon Sep 17 00:00:00 2001
-From: Vladislav Grishenko <themiron@mail.ru>
-Date: Wed, 26 Jun 2019 20:27:11 +0500
-Subject: [PATCH] Fix build with libnettle 3.5
-
----
- src/crypto.c | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/src/crypto.c b/src/crypto.c
-index 1f1c12b..9cfe371 100644
---- a/src/crypto.c
-+++ b/src/crypto.c
-@@ -296,6 +296,10 @@ static int dnsmasq_ecdsa_verify(struct blockdata *key_data, unsigned int key_len
- static struct ecc_point *key_256 = NULL, *key_384 = NULL;
- static mpz_t x, y;
- static struct dsa_signature *sig_struct;
-+#if NETTLE_VERSION_MAJOR == 3 && NETTLE_VERSION_MINOR < 4
-+#define nettle_get_secp_256r1() (&nettle_secp_256r1)
-+#define nettle_get_secp_384r1() (&nettle_secp_384r1)
-+#endif
-
- if (!sig_struct)
- {
-@@ -315,7 +319,7 @@ static int dnsmasq_ecdsa_verify(struct blockdata *key_data, unsigned int key_len
- if (!(key_256 = whine_malloc(sizeof(struct ecc_point))))
- return 0;
-
-- nettle_ecc_point_init(key_256, &nettle_secp_256r1);
-+ nettle_ecc_point_init(key_256, nettle_get_secp_256r1());
- }
-
- key = key_256;
-@@ -328,7 +332,7 @@ static int dnsmasq_ecdsa_verify(struct blockdata *key_data, unsigned int key_len
- if (!(key_384 = whine_malloc(sizeof(struct ecc_point))))
- return 0;
-
-- nettle_ecc_point_init(key_384, &nettle_secp_384r1);
-+ nettle_ecc_point_init(key_384, nettle_get_secp_384r1());
- }
-
- key = key_384;