summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-01 00:02:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-01 00:02:43 +0100
commitb3b858110724cc3bf88b1048de07e56246f01033 (patch)
treec2ccdae32e614e2d350f6f10d7faeb0de4bd358b /net-firewall/firewalld
parentx11-libs/libfm: stable 1.2.5 for ppc, bug #625180 (diff)
downloadgentoo-b3b858110724cc3bf88b1048de07e56246f01033.tar.gz
gentoo-b3b858110724cc3bf88b1048de07e56246f01033.tar.bz2
gentoo-b3b858110724cc3bf88b1048de07e56246f01033.zip
net-firewall/firewalld: Re-add current stable
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-firewall/firewalld')
-rw-r--r--net-firewall/firewalld/Manifest1
-rw-r--r--net-firewall/firewalld/firewalld-0.4.3.3.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/net-firewall/firewalld/Manifest b/net-firewall/firewalld/Manifest
index 867d62e1570c..f07683c26504 100644
--- a/net-firewall/firewalld/Manifest
+++ b/net-firewall/firewalld/Manifest
@@ -1 +1,2 @@
+DIST firewalld-0.4.3.3.tar.bz2 679617 BLAKE2B 37d3acda80f046e7e208f570688e9b554feb985c4b6c4d910236ed296113385bbc0c86fd4ae815538e0b68bef216154568b095023098d2b0620a1749af5cea4f SHA512 21cb91b9545263f6da4a6ff218c939b610c7fe5dba2ad509803673d9c01cf6fecb4ab32bacf1a04e3d579fd9699a03760475285f824a6641902037c81ad2243a
DIST firewalld-0.5.1.tar.gz 1155989 BLAKE2B 8e5f67dc74738cec178715b0e3713afa7296be61b376a8d545b1ae1c01c0f0df78ec48222b6926bdce1d93c58f7d02fad14bc46c1ddd24840e8853e5e76b73ff SHA512 8c8ea1a07fc81b12f53fbc84112d18c65c4332e8f7b7d575dc1ccba8a12418c874f8503b0062b49990f8bcfdf5fdaa7c0e4e3ddc0e9b1d0a91f49eff284b22be
diff --git a/net-firewall/firewalld/firewalld-0.4.3.3.ebuild b/net-firewall/firewalld/firewalld-0.4.3.3.ebuild
new file mode 100644
index 000000000000..566a084ed4b0
--- /dev/null
+++ b/net-firewall/firewalld/firewalld-0.4.3.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+#BACKPORTS=
+
+inherit autotools eutils gnome2-utils python-r1 systemd multilib bash-completion-r1
+
+DESCRIPTION="A firewall daemon with D-BUS interface providing a dynamic firewall"
+HOMEPAGE="http://www.firewalld.org/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.bz2
+ ${BACKPORTS:+https://dev.gentoo.org/~cardoe/distfiles/${P}-${BACKPORTS}.tar.xz}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="gui"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/python-slip-0.2.7[dbus,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ net-firewall/ebtables
+ net-firewall/iptables[ipv6]
+ net-firewall/ipset
+ || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
+ gui? (
+ x11-libs/gtk+:3
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-libs/glib:2
+ >=dev-util/intltool-0.35
+ sys-devel/gettext"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ python_setup
+
+ econf \
+ --enable-systemd \
+ --with-iptables="${EPREFIX}/sbin/iptables" \
+ --with-ip6tables="${EPREFIX}/sbin/ip6tables" \
+ --with-iptables_restore="${EPREFIX}/sbin/iptables-restore" \
+ --with-ip6tables_restore="${EPREFIX}/sbin/ip6tables-restore" \
+ --with-ebtables="${EPREFIX}/sbin/ebtables" \
+ --with-ebtables_restore="${EPREFIX}/sbin/ebtables-restore" \
+ "$(systemd_with_unitdir 'systemd-unitdir')" \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}
+
+src_install() {
+ # manually split up the installation to avoid "file already exists" errors
+ emake -C config DESTDIR="${D}" install
+ emake -C po DESTDIR="${D}" install
+ emake -C shell-completion DESTDIR="${D}" install
+ emake -C doc DESTDIR="${D}" install
+
+ install_python() {
+ emake -C src DESTDIR="${D}" pythondir="$(python_get_sitedir)" install
+ python_optimize
+ }
+ python_foreach_impl install_python
+
+ python_replicate_script "${D}"/usr/bin/firewall-{offline-cmd,cmd,applet,config}
+ python_replicate_script "${D}/usr/sbin/firewalld"
+
+ # Get rid of junk
+ rm -rf "${D}/etc/rc.d/"
+ rm -rf "${D}/etc/sysconfig/"
+
+ # For non-gui installs we need to remove GUI bits
+ if ! use gui; then
+ rm -rf "${D}/etc/xdg/autostart"
+ rm -f "${D}/usr/bin/firewall-applet"
+ rm -f "${D}/usr/bin/firewall-config"
+ rm -rf "${D}/usr/share/applications"
+ rm -rf "${D}/usr/share/icons"
+ fi
+
+ newinitd "${FILESDIR}"/firewalld.init firewalld
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}