summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-28 18:19:50 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-28 18:36:35 -0500
commit574a37fafc49e0165c952af204821f8d25967f88 (patch)
tree4662a6097e05a76a0fde494b853008e85bb675c7 /net-firewall/ipkungfu/ipkungfu-0.5.2-r2.ebuild
parentnet-dns/mydns: remove mydns-1.2.8.31 (diff)
downloadgentoo-574a37fafc49e0165c952af204821f8d25967f88.tar.gz
gentoo-574a37fafc49e0165c952af204821f8d25967f88.tar.bz2
gentoo-574a37fafc49e0165c952af204821f8d25967f88.zip
net-firewall/ipkungfu: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-firewall/ipkungfu/ipkungfu-0.5.2-r2.ebuild')
-rw-r--r--net-firewall/ipkungfu/ipkungfu-0.5.2-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-firewall/ipkungfu/ipkungfu-0.5.2-r2.ebuild b/net-firewall/ipkungfu/ipkungfu-0.5.2-r2.ebuild
new file mode 100644
index 000000000000..804a5293e422
--- /dev/null
+++ b/net-firewall/ipkungfu/ipkungfu-0.5.2-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A nice iptables firewall script"
+HOMEPAGE="http://www.linuxkungfu.org/"
+SRC_URI="http://www.linuxkungfu.org/ipkungfu/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables"
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_unpack() {
+ unpack ${A}
+
+ # Patch ipkungfu to load the right module for ip_nat_ftp
+ # Fixes bug #42443. Thanks to George L. Emigh <george@georgelemigh.com>
+ cd "${WORKDIR}"/${P} && epatch "${FILESDIR}"/nat_ftp.patch
+
+ # man page comes bzip2'd, so bunzip2 it.
+ cd "${WORKDIR}"/${P}/files
+ bunzip2 ipkungfu.8.bz2
+}
+
+src_install() {
+
+ # Package comes with a hard coded shell script, so here we
+ # replicate what they did, but so it's compatible with portage.
+
+ # Install shell script executable
+ dosbin ipkungfu
+
+ # Install Gentoo init script
+ newinitd "${FILESDIR}"/ipkungfu.init ipkungfu
+
+ # Install config files into /etc
+ dodir /etc/ipkungfu
+ insinto /etc/ipkungfu
+ doins files/*.conf
+
+ # Install man page
+ doman files/ipkungfu.8
+
+ # Install documentation
+ dodoc COPYRIGHT Changelog FAQ INSTALL README gpl.txt
+}
+
+pkg_postinst() {
+ einfo "Be sure to edit the config files"
+ einfo "in /etc/ipkungfu before running"
+}