summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2015-11-03 01:10:22 -0500
committerNicholas Vinson <nvinson234@gmail.com>2015-11-03 01:11:28 -0500
commit37bdeb0c57ba3978658d2b4373a5e2958f0ca5a6 (patch)
tree7a8159f92125ca1f7c10b8db1d64ae8f0e5e1bc2 /net-firewall
parentnet-firewall/nftables: Create systemd unit files (diff)
downloadgentoo-37bdeb0c57ba3978658d2b4373a5e2958f0ca5a6.tar.gz
gentoo-37bdeb0c57ba3978658d2b4373a5e2958f0ca5a6.tar.bz2
gentoo-37bdeb0c57ba3978658d2b4373a5e2958f0ca5a6.zip
net-firewall/nftables: revbump to nftables-0.5-r2
Required for supporting systemd Package-Manager: portage-2.2.23
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/nftables/nftables-0.5-r2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-firewall/nftables/nftables-0.5-r2.ebuild b/net-firewall/nftables/nftables-0.5-r2.ebuild
new file mode 100644
index 000000000000..a495588efb8f
--- /dev/null
+++ b/net-firewall/nftables/nftables-0.5-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools linux-info eutils systemd
+
+DESCRIPTION="Linux kernel (3.13+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://netfilter.org/projects/nftables/"
+SRC_URI="http://git.netfilter.org/nftables/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug gmp +readline"
+
+RDEPEND=">=net-libs/libmnl-1.0.3
+ >=net-libs/libnftnl-1.0.5
+ gmp? ( dev-libs/gmp:0= )
+ readline? ( sys-libs/readline:0= )"
+DEPEND="${RDEPEND}
+ >=app-text/docbook2X-0.8.8-r4
+ sys-devel/bison
+ sys-devel/flex"
+
+S="${WORKDIR}"/v${PV}
+
+pkg_setup() {
+ if kernel_is ge 3 13; then
+ CONFIG_CHECK="~NF_TABLES"
+ linux-info_pkg_setup
+ else
+ eerror "This package requires kernel version 3.13 or newer to work properly."
+ fi
+}
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sbindir="${EPREFIX}"/sbin \
+ $(use_enable debug) \
+ $(use_with readline cli) \
+ $(use_with !gmp mini_gmp)
+}
+
+src_install() {
+ default
+
+ dodir /usr/libexec/${PN}
+ cp -p "${FILESDIR}"/libexec/${PN}.sh "${D}"/usr/libexec/${PN}/${PN}.sh
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.init-r2 ${PN}
+ keepdir /var/lib/nftables
+
+ systemd_dounit "${FILESDIR}"/systemd/${PN}{,-{re,}store}.service
+}