summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-03-21 09:43:33 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-03-21 09:44:18 -0500
commit47c7b978fde49799a24ebc0872c820caacb0dd45 (patch)
tree101abe9a149ae8445d7409ed9e2ea3441c37cef5 /net-firewall
parentnet-proxy/pingtunnel: Use proper POSIX #include's (diff)
downloadgentoo-47c7b978fde49799a24ebc0872c820caacb0dd45.tar.gz
gentoo-47c7b978fde49799a24ebc0872c820caacb0dd45.tar.bz2
gentoo-47c7b978fde49799a24ebc0872c820caacb0dd45.zip
net-firewall/firewalld: fix ipset path
Closes: https://bugs.gentoo.org/713658 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/firewalld/Manifest1
-rw-r--r--net-firewall/firewalld/firewalld-0.6.3-r1.ebuild102
-rw-r--r--net-firewall/firewalld/firewalld-0.7.1-r1.ebuild101
-rw-r--r--net-firewall/firewalld/firewalld-0.7.1-r3.ebuild (renamed from net-firewall/firewalld/firewalld-0.7.1-r2.ebuild)2
-rw-r--r--net-firewall/firewalld/firewalld-0.7.3-r1.ebuild (renamed from net-firewall/firewalld/firewalld-0.7.3.ebuild)2
5 files changed, 2 insertions, 206 deletions
diff --git a/net-firewall/firewalld/Manifest b/net-firewall/firewalld/Manifest
index a8be639b1e7c..e07f1e31102f 100644
--- a/net-firewall/firewalld/Manifest
+++ b/net-firewall/firewalld/Manifest
@@ -1,3 +1,2 @@
-DIST firewalld-0.6.3.tar.gz 2294470 BLAKE2B 09bb971d8142e5d28b6a085527e7f5275090f15e5dc4ccf2b16b6ed837049ed75443b09a54db76e37c6f0c5db6524ba85cf34c5117c1139bba0e3b223f289d57 SHA512 ea9e8bad34d3608257ef2a38851855974eff97b21dbab93ca3d8cfad90339734a8124447ed531a978b41546ab4040135bb61c8fdc9677ba0df9188d7ee4422ee
DIST firewalld-0.7.1.tar.gz 2326020 BLAKE2B 1ab435bfd97608ce246657a24daebe6ca83f72560a627c702e940de64bf4fb34f26ebe9abf62468972fd8cd9394c5e885acd6882ec3cad112dfe62bca3905c7a SHA512 6be842d4c2849f56fc0e6c13219aed7d767635a3b190ef41f1516cecf51de71ad9af77ccc96b699d11bed56407abf9837cdbd0cfbf93ab716b5de5e4c2f94c68
DIST firewalld-0.7.3.tar.gz 1247590 BLAKE2B 80b34749ab47fa3f2733c6c2fe6dec9483b38baa3485c91875888ecce4bacc16a05e69d5734aaed017408ec2ba8b33155aa0c08e93b1f8eac5c6708682edf238 SHA512 49ab1403b29b215ef69d54baf9060826917ab2a6d632f0a53b458170576639e74580e4399e5c78a74bf12a4999479db86aadacbc17c749ab25e9de8ed686146f
diff --git a/net-firewall/firewalld/firewalld-0.6.3-r1.ebuild b/net-firewall/firewalld/firewalld-0.6.3-r1.ebuild
deleted file mode 100644
index 3035cef8c28a..000000000000
--- a/net-firewall/firewalld/firewalld-0.6.3-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
-
-inherit autotools gnome2-utils linux-info python-single-r1 systemd bash-completion-r1
-
-DESCRIPTION="A firewall daemon with D-BUS interface providing a dynamic firewall"
-HOMEPAGE="http://www.firewalld.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="gui"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- !!net-firewall/gshield
- || ( net-firewall/ebtables net-firewall/iptables[nftables] )
- net-firewall/iptables[ipv6]
- net-firewall/ipset
- net-firewall/nftables
- || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
- $(python_gen_cond_dep '
- dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
- dev-python/decorator[${PYTHON_MULTI_USEDEP}]
- >=dev-python/python-slip-0.2.7[dbus,${PYTHON_MULTI_USEDEP}]
- dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
- gui? (
- x11-libs/gtk+:3
- dev-python/PyQt5[gui,widgets,${PYTHON_MULTI_USEDEP}]
- )
- ')"
-DEPEND="${RDEPEND}
- dev-libs/glib:2
- >=dev-util/intltool-0.35
- sys-devel/gettext"
-
-RESTRICT="test" # bug 650760
-
-pkg_setup() {
- local CONFIG_CHECK="~NF_CONNTRACK ~NF_CONNTRACK_IPV4 ~NF_CONNTRACK_IPV6 ~NETFILTER_XT_MATCH_CONNTRACK"
- linux-info_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- python_setup
-
- econf \
- --enable-systemd \
- --with-iptables="${EPREFIX}/sbin/iptables" \
- --with-ip6tables="${EPREFIX}/sbin/ip6tables" \
- --with-iptables_restore="${EPREFIX}/sbin/iptables-restore" \
- --with-ip6tables_restore="${EPREFIX}/sbin/ip6tables-restore" \
- --with-ebtables="${EPREFIX}/sbin/ebtables" \
- --with-ebtables_restore="${EPREFIX}/sbin/ebtables-restore" \
- --with-nft="${EPREFIX}/sbin/nft" \
- --with-systemd-unitdir="$(systemd_get_systemunitdir)" \
- --with-bashcompletiondir="$(get_bashcompdir)"
-}
-
-src_install() {
- default
- python_optimize
-
- # Get rid of junk
- rm -rf "${D}/etc/rc.d/" || die
- rm -rf "${D}/etc/sysconfig/" || die
-
- # For non-gui installs we need to remove GUI bits
- if ! use gui; then
- rm -rf "${D}/etc/xdg/autostart" || die
- rm -f "${D}/usr/bin/firewall-applet" || die
- rm -f "${D}/usr/bin/firewall-config" || die
- rm -rf "${D}/usr/share/applications" || die
- rm -rf "${D}/usr/share/icons" || die
- fi
-
- newinitd "${FILESDIR}"/firewalld.init firewalld
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
- gnome2_schemas_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- gnome2_schemas_update
-}
diff --git a/net-firewall/firewalld/firewalld-0.7.1-r1.ebuild b/net-firewall/firewalld/firewalld-0.7.1-r1.ebuild
deleted file mode 100644
index af7ce3dfdc23..000000000000
--- a/net-firewall/firewalld/firewalld-0.7.1-r1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
-
-inherit autotools bash-completion-r1 gnome2-utils linux-info python-single-r1 systemd xdg-utils
-
-DESCRIPTION="A firewall daemon with D-BUS interface providing a dynamic firewall"
-HOMEPAGE="http://www.firewalld.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE="gui"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- !!net-firewall/gshield
- net-firewall/iptables[ipv6]
- || ( net-firewall/iptables[nftables] net-firewall/ebtables )
- net-firewall/ipset
- net-firewall/nftables
- || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
- $(python_gen_cond_dep '
- dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
- dev-python/decorator[${PYTHON_MULTI_USEDEP}]
- >=dev-python/python-slip-0.2.7[dbus,${PYTHON_MULTI_USEDEP}]
- dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
- gui? (
- x11-libs/gtk+:3
- dev-python/PyQt5[gui,widgets,${PYTHON_MULTI_USEDEP}]
- )
- ')"
-DEPEND="${RDEPEND}
- dev-libs/glib:2
- >=dev-util/intltool-0.35
- sys-devel/gettext"
-
-RESTRICT="test" # bug 650760
-
-pkg_setup() {
- local CONFIG_CHECK="~NF_CONNTRACK ~NF_CONNTRACK_IPV4 ~NF_CONNTRACK_IPV6 ~NETFILTER_XT_MATCH_CONNTRACK"
- linux-info_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- python_setup
-
- econf \
- --enable-systemd \
- --with-iptables="${EPREFIX}/sbin/iptables" \
- --with-ip6tables="${EPREFIX}/sbin/ip6tables" \
- --with-iptables_restore="${EPREFIX}/sbin/iptables-restore" \
- --with-ip6tables_restore="${EPREFIX}/sbin/ip6tables-restore" \
- --with-ebtables="${EPREFIX}/sbin/ebtables" \
- --with-ebtables_restore="${EPREFIX}/sbin/ebtables-restore" \
- --with-nft="${EPREFIX}/sbin/nft" \
- --with-systemd-unitdir="$(systemd_get_systemunitdir)" \
- --with-bashcompletiondir="$(get_bashcompdir)"
-}
-
-src_install() {
- default
- python_optimize
-
- # Get rid of junk
- rm -rf "${D}/etc/rc.d/" || die
- rm -rf "${D}/etc/sysconfig/" || die
-
- # For non-gui installs we need to remove GUI bits
- if ! use gui; then
- rm -rf "${D}/etc/xdg/autostart" || die
- rm -f "${D}/usr/bin/firewall-applet" || die
- rm -f "${D}/usr/bin/firewall-config" || die
- rm -rf "${D}/usr/share/applications" || die
- rm -rf "${D}/usr/share/icons" || die
- fi
-
- newinitd "${FILESDIR}"/firewalld.init firewalld
-}
-
-pkg_preinst() {
- gnome2_schemas_savelist
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- gnome2_schemas_update
-}
diff --git a/net-firewall/firewalld/firewalld-0.7.1-r2.ebuild b/net-firewall/firewalld/firewalld-0.7.1-r3.ebuild
index fef6cc88e2ad..28feae85d15a 100644
--- a/net-firewall/firewalld/firewalld-0.7.1-r2.ebuild
+++ b/net-firewall/firewalld/firewalld-0.7.1-r3.ebuild
@@ -76,7 +76,7 @@ src_configure() {
$(use_with iptables ip6tables_restore "${EPREFIX}/sbin/ip6tables-restore")
$(use_with iptables ebtables "${EPREFIX}/sbin/ebtables")
$(use_with iptables ebtables_restore "${EPREFIX}/sbin/ebtables-restore")
- $(use_with iptables ipset "${EPREFIX}/sbin/ipset")
+ $(use_with iptables ipset "${EPREFIX}/usr/sbin/ipset")
--with-systemd-unitdir="$(systemd_get_systemunitdir)"
--with-bashcompletiondir="$(get_bashcompdir)"
)
diff --git a/net-firewall/firewalld/firewalld-0.7.3.ebuild b/net-firewall/firewalld/firewalld-0.7.3-r1.ebuild
index ff392560d7c5..8f68175271de 100644
--- a/net-firewall/firewalld/firewalld-0.7.3.ebuild
+++ b/net-firewall/firewalld/firewalld-0.7.3-r1.ebuild
@@ -76,7 +76,7 @@ src_configure() {
$(use_with iptables ip6tables_restore "${EPREFIX}/sbin/ip6tables-restore")
$(use_with iptables ebtables "${EPREFIX}/sbin/ebtables")
$(use_with iptables ebtables_restore "${EPREFIX}/sbin/ebtables-restore")
- $(use_with iptables ipset "${EPREFIX}/sbin/ipset")
+ $(use_with iptables ipset "${EPREFIX}/usr/sbin/ipset")
--with-systemd-unitdir="$(systemd_get_systemunitdir)"
--with-bashcompletiondir="$(get_bashcompdir)"
)