summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-10 01:17:28 +0000
committerSam James <sam@gentoo.org>2021-03-10 01:17:28 +0000
commit4a82baeb81975640ef3840783cf979b94a178a99 (patch)
tree324b7fd08b361c0c2f5161c58d8ec8e7fc6aba97 /net-firewall
parentdev-libs/geoip: update EAPI 6 -> 7, fix invalid ROOT usage (diff)
downloadgentoo-4a82baeb81975640ef3840783cf979b94a178a99.tar.gz
gentoo-4a82baeb81975640ef3840783cf979b94a178a99.tar.bz2
gentoo-4a82baeb81975640ef3840783cf979b94a178a99.zip
net-firewall/ipt_netflow: BDEPEND for EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-2.5.1-r1.ebuild7
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-9999.ebuild9
2 files changed, 10 insertions, 6 deletions
diff --git a/net-firewall/ipt_netflow/ipt_netflow-2.5.1-r1.ebuild b/net-firewall/ipt_netflow/ipt_netflow-2.5.1-r1.ebuild
index d64a581002f0..bf18a5d00831 100644
--- a/net-firewall/ipt_netflow/ipt_netflow-2.5.1-r1.ebuild
+++ b/net-firewall/ipt_netflow/ipt_netflow-2.5.1-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit linux-info linux-mod toolchain-funcs
DESCRIPTION="Netflow iptables module"
@@ -21,10 +22,12 @@ RDEPEND="
net-firewall/iptables:0=
snmp? ( net-analyzer/net-snmp )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/linux-sources
virtual/pkgconfig
"
+
PATCHES=(
"${FILESDIR}/${PN}-2.0-configure.patch" # bug #455984
"${FILESDIR}/${PN}-2.5-gentoo.patch"
diff --git a/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild b/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
index d4305e2fc5c5..55047faefa34 100644
--- a/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
+++ b/net-firewall/ipt_netflow/ipt_netflow-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit git-r3 linux-info linux-mod toolchain-funcs
DESCRIPTION="Netflow iptables module"
@@ -13,18 +14,18 @@ EGIT_REPO_URI="https://github.com/aabc/ipt-netflow"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-
IUSE="debug natevents snmp"
RDEPEND="
net-firewall/iptables:0=
snmp? ( net-analyzer/net-snmp )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/linux-sources
virtual/pkgconfig
"
+
PATCHES=(
"${FILESDIR}/${PN}-2.0-configure.patch" # bug #455984
"${FILESDIR}/${PN}-9999-gentoo.patch"