summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-02 13:58:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-02 13:58:46 +0200
commit4b3c4d93cb24b19cbd514839c648a9b9d11b9ba7 (patch)
treeb665635bc5d0fcdcc7e0cb54ce86d558934d6dfc /net-firewall
parentdev-util/Orange: remove old (diff)
downloadgentoo-4b3c4d93cb24b19cbd514839c648a9b9d11b9ba7.tar.gz
gentoo-4b3c4d93cb24b19cbd514839c648a9b9d11b9ba7.tar.bz2
gentoo-4b3c4d93cb24b19cbd514839c648a9b9d11b9ba7.zip
net-firewall/arptables: Bump to version 0.0.4
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/arptables/Manifest1
-rw-r--r--net-firewall/arptables/arptables-0.0.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-firewall/arptables/Manifest b/net-firewall/arptables/Manifest
index 1ffc750253ce..734506104974 100644
--- a/net-firewall/arptables/Manifest
+++ b/net-firewall/arptables/Manifest
@@ -1 +1,2 @@
DIST arptables-v0.0.3-4.tar.gz 44335 SHA256 e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928 SHA512 a566b6df5c4b22c9c15d22c3801763e640f15b76043123c4ca8db1cc753a20a99b8b7b6dae2f0d9277cc6c49bcb269ba481958bcff3f6a516c7c9d8b553d35b5 WHIRLPOOL a045489531c2eec53cc57b18639291d38fa443a9b4e4539e096fa2afbaaa8585bfa387c4759e0a02d407d76ef0ed87f602b4f847edd49d3be9c1113264e69996
+DIST arptables-v0.0.4.tar.gz 45380 SHA256 277985e29ecd93bd759a58242cad0e02ba9d4a6e1b7795235e3b507661bc0049 SHA512 bd84e93ab5e0a038753aa17dae9e1f48364f2d2b1492dce2edac117e21edd5aa912be7b9e21bf4fb3698031d2f765a75fa067fe10ce20a1c8951ae7efcc5dbbd WHIRLPOOL 6209b2837e22fa1a3ef9d8d090210a8dda7b6199ec58cbdd565e646f24eb499ae4e3d36175e3ed215eb47783f33ae4a02a50e0b7df5aec78a82a6b5e2c7b1660
diff --git a/net-firewall/arptables/arptables-0.0.4.ebuild b/net-firewall/arptables/arptables-0.0.4.ebuild
new file mode 100644
index 000000000000..23c063983b07
--- /dev/null
+++ b/net-firewall/arptables/arptables-0.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_P="${PN}-v${PV}"
+
+DESCRIPTION="set up, maintain, and inspect the tables of ARP rules in the Linux kernel"
+HOMEPAGE="http://ebtables.sourceforge.net/"
+SRC_URI="ftp://ftp.netfilter.org/pub/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # -O0 does not work and at least -O2 is required, bug #240752
+ emake CC="$(tc-getCC)" COPT_FLAGS="-O2 ${CFLAGS//-O0/-O2}"
+ sed -ie 's:__EXEC_PATH__:/sbin:g' arptables-save arptables-restore \
+ || die "sed failed"
+}
+
+src_install() {
+ into /
+ dosbin arptables arptables-restore arptables-save
+ doman arptables.8
+}