summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-11-08 22:43:40 +0000
committerJames Le Cuirot <chewi@gentoo.org>2022-11-08 22:43:40 +0000
commit659557f22c2738833fb3a588880a2b0e53a6679b (patch)
treeb0d0e9fc255f8bd7c3daee08f9f7bcc11baa1665 /net-firewall
parentsys-apps/dbus: drop 1.14.0-r4, 1.14.2, 1.14.4, 1.15.0-r1 (diff)
downloadgentoo-659557f22c2738833fb3a588880a2b0e53a6679b.tar.gz
gentoo-659557f22c2738833fb3a588880a2b0e53a6679b.tar.bz2
gentoo-659557f22c2738833fb3a588880a2b0e53a6679b.zip
net-firewall/firehol: Set bash and iprange versions to aid cross-compiling
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/firehol/firehol-3.1.7-r2.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/net-firewall/firehol/firehol-3.1.7-r2.ebuild b/net-firewall/firehol/firehol-3.1.7-r2.ebuild
index 79ef83977169..f750bfab3a7b 100644
--- a/net-firewall/firehol/firehol-3.1.7-r2.ebuild
+++ b/net-firewall/firehol/firehol-3.1.7-r2.ebuild
@@ -14,16 +14,22 @@ SLOT="0"
IUSE="doc ipv6 ipset"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
-RDEPEND="net-firewall/iptables
+# Set the dependency versions to aid cross-compiling. Keep them at their
+# minimums as the configure script merely checks whether they are sufficient.
+MY_BASH_VERSION=4.0
+MY_IPRANGE_VERSION=1.0.2
+
+RDEPEND="
+ app-arch/gzip
+ >=app-shells/bash-${MY_BASH_VERSION}:0
+ net-analyzer/traceroute
+ net-firewall/iptables
+ >=net-misc/iprange-${MY_IPRANGE_VERSION}:0
+ net-misc/iputils[ipv6(+)?]
sys-apps/iproute2[-minimal,ipv6(+)?]
sys-apps/kmod[tools]
- net-misc/iputils[ipv6(+)?]
- net-misc/iprange
- net-analyzer/traceroute
- app-arch/gzip
- ipset? (
- net-firewall/ipset
- )"
+ ipset? ( net-firewall/ipset )
+"
DEPEND="${RDEPEND}"
pkg_setup() {
@@ -50,6 +56,9 @@ pkg_setup() {
}
src_configure() {
+ # This erroneously checks for BASH_VERSION_PATH rather than BASH_VERSION.
+ BASH_VERSION_PATH=${MY_BASH_VERSION} \
+ IPRANGE_VERSION=${MY_IPRANGE_VERSION} \
econf \
--disable-vnetbuild \
$(use_enable ipset update-ipsets) \