summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-01 14:32:44 +0100
committerSam James <sam@gentoo.org>2023-05-01 14:32:44 +0100
commit741ef8be1b312d576bd62eaa00ea92ed392ae069 (patch)
treecafb70876ada886317965d0dd1259bf86b398a6e /net-firewall
parentnet-firewall/firewalld: drop 1.3.0, 1.3.1 (diff)
downloadgentoo-741ef8be1b312d576bd62eaa00ea92ed392ae069.tar.gz
gentoo-741ef8be1b312d576bd62eaa00ea92ed392ae069.tar.bz2
gentoo-741ef8be1b312d576bd62eaa00ea92ed392ae069.zip
net-firewall/ipset: drop 7.15, 7.16-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipset/Manifest2
-rw-r--r--net-firewall/ipset/files/ipset-7.4-fix-pkgconfig-dir.patch11
-rw-r--r--net-firewall/ipset/ipset-7.15.ebuild114
-rw-r--r--net-firewall/ipset/ipset-7.16-r1.ebuild119
4 files changed, 0 insertions, 246 deletions
diff --git a/net-firewall/ipset/Manifest b/net-firewall/ipset/Manifest
index 6320f121cb5b..a65795385364 100644
--- a/net-firewall/ipset/Manifest
+++ b/net-firewall/ipset/Manifest
@@ -1,3 +1 @@
-DIST ipset-7.15.tar.bz2 680383 BLAKE2B 10acff9741370ad80a2845605be1be4f691e987b271f4dcf1fab3abfe158c63c7d39e6b3453ba7cd361dee3df92f85419cfb70806a71b6806555f6571c70b1ed SHA512 0fc936d971c30a0925c585d506c8840e782fdaeec09bc8fd249e874fe838fa55a4dbb697f6e1423a6769abf07a1ce2195abc37cb641e8e4ad70f1b4c7130916a
-DIST ipset-7.16.tar.bz2 684512 BLAKE2B c2c58bd6250bab41c3c5cb2ed6a39b1cd5e47a60eca5ed19373dad6c611f5263c61cf12915b5d658700e8e78f4f445788900a2b89cdcdbef3407375b4131fb04 SHA512 e69ddee956f0922c8e08e7e5d358d6b5b24178a9f08151b20957cc3465baaba9ecd6aa938ae157f2cd286ccd7f0b7a279cfd89cec2393a00b43e4d945c275307
DIST ipset-7.17.tar.bz2 684983 BLAKE2B 43b74ab7caf5a963787184aa75b6c071388c8d28997681444b72118aba68b843e961b50418c3fa70b451b4cb090ec62940b770abac2156910442115edbf90d41 SHA512 e308a0d7707ccf7d0cb06a32cf9a822f97862e007abdbab8a91a5a0d5bfbd9f2fb9a3f5e8f36b250ec0d565438c8648a31e8e5b45d8205a76558e90f46e6e597
diff --git a/net-firewall/ipset/files/ipset-7.4-fix-pkgconfig-dir.patch b/net-firewall/ipset/files/ipset-7.4-fix-pkgconfig-dir.patch
deleted file mode 100644
index b10ddbd4fae0..000000000000
--- a/net-firewall/ipset/files/ipset-7.4-fix-pkgconfig-dir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/lib/Makefile.am
-+++ b/lib/Makefile.am
-@@ -46,7 +46,7 @@ EXTRA_libipset_la_SOURCES = \
-
- EXTRA_DIST = $(IPSET_SETTYPE_LIST) libipset.map
-
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/$(libdir)/pkgconfig
- pkgconfig_DATA = libipset.pc
-
- dist_man_MANS = libipset.3
diff --git a/net-firewall/ipset/ipset-7.15.ebuild b/net-firewall/ipset/ipset-7.15.ebuild
deleted file mode 100644
index fad8d3142d3b..000000000000
--- a/net-firewall/ipset/ipset-7.15.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-MODULES_OPTIONAL_USE=modules
-inherit autotools linux-info linux-mod systemd
-
-DESCRIPTION="IPset tool for iptables, successor to ippool"
-HOMEPAGE="https://ipset.netfilter.org/"
-SRC_URI="https://ipset.netfilter.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
-
-BDEPEND="virtual/pkgconfig"
-
-RDEPEND=">=net-firewall/iptables-1.4.7
- net-libs/libmnl:="
-DEPEND="${RDEPEND}"
-
-DOCS=( ChangeLog INSTALL README UPGRADE )
-
-PATCHES=( "${FILESDIR}"/${PN}-7.4-fix-pkgconfig-dir.patch )
-
-# configurable from outside, e.g. /etc/portage/make.conf
-IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
-
-BUILD_TARGETS="modules"
-MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
-MODULE_NAMES="xt_set(kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/)"
-MODULE_NAMES+=" em_ipset(kernel/net/sched/:${S}/kernel/net/sched/)"
-for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,mac,mark,port{,ip,net}},mac,net{,port{,net},iface,net}},_list_set}; do
- MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
-done
-
-pkg_setup() {
- get_version
- CONFIG_CHECK="NETFILTER"
- ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
- CONFIG_CHECK+=" NETFILTER_NETLINK"
- ERROR_NETFILTER_NETLINK="ipset requires NETFILTER_NETLINK support in your kernel."
- # It does still build without NET_NS, but it may be needed in future.
- #CONFIG_CHECK="${CONFIG_CHECK} NET_NS"
- #ERROR_NET_NS="ipset requires NET_NS (network namespace) support in your kernel."
- CONFIG_CHECK+=" !PAX_CONSTIFY_PLUGIN"
- ERROR_PAX_CONSTIFY_PLUGIN="ipset contains constified variables (#614896)"
-
- build_modules=0
- if use modules; then
- if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
- if linux_chkconfig_present "IP_NF_SET" || \
- linux_chkconfig_present "IP_SET"; then #274577
- eerror "There is IP{,_NF}_SET or NETFILTER_XT_SET support in your kernel."
- eerror "Please either build ipset with modules USE flag disabled"
- eerror "or rebuild kernel without IP_SET support and make sure"
- eerror "there is NO kernel ip_set* modules in /lib/modules/<your_kernel>/... ."
- die "USE=modules and in-kernel ipset support detected."
- else
- einfo "Modular kernel detected. Gonna build kernel modules..."
- build_modules=1
- fi
- else
- eerror "Nonmodular kernel detected, but USE=modules. Either build"
- eerror "modular kernel (without IP_SET) or disable USE=modules"
- die "Nonmodular kernel detected, will not build kernel modules"
- fi
- fi
- [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
-}
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_with modules kmod) \
- --disable-static \
- --with-maxsets=${IP_NF_SET_MAX} \
- --libdir="${EPREFIX}/$(get_libdir)" \
- --with-ksource="${KV_DIR}" \
- --with-kbuild="${KV_OUT_DIR}"
-}
-
-src_compile() {
- einfo "Building userspace"
- emake
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Building kernel modules"
- set_arch_to_kernel
- emake modules
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- default
-
- find "${ED}" -name '*.la' -delete || die
-
- newinitd "${FILESDIR}"/ipset.initd-r4 ${PN}
- newconfd "${FILESDIR}"/ipset.confd ${PN}
- systemd_newunit "${FILESDIR}"/ipset.systemd ${PN}.service
- keepdir /var/lib/ipset
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Installing kernel modules"
- linux-mod_src_install
- fi
-}
diff --git a/net-firewall/ipset/ipset-7.16-r1.ebuild b/net-firewall/ipset/ipset-7.16-r1.ebuild
deleted file mode 100644
index 0954044f712d..000000000000
--- a/net-firewall/ipset/ipset-7.16-r1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MODULES_OPTIONAL_USE=modules
-inherit autotools bash-completion-r1 linux-info linux-mod systemd
-
-DESCRIPTION="IPset tool for iptables, successor to ippool"
-HOMEPAGE="https://ipset.netfilter.org/"
-SRC_URI="https://ipset.netfilter.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
-
-RDEPEND="
- >=net-firewall/iptables-1.4.7
- net-libs/libmnl:=
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( ChangeLog INSTALL README UPGRADE )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-7.16-bashism.patch
-)
-
-# configurable from outside, e.g. /etc/portage/make.conf
-IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
-
-BUILD_TARGETS="modules"
-MODULE_NAMES_ARG="kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/ipset"
-MODULE_NAMES="xt_set(kernel/net/netfilter/ipset/:${S}/kernel/net/netfilter/)"
-MODULE_NAMES+=" em_ipset(kernel/net/sched/:${S}/kernel/net/sched/)"
-for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,mac,mark,port{,ip,net}},mac,net{,port{,net},iface,net}},_list_set}; do
- MODULE_NAMES+=" ${i}(${MODULE_NAMES_ARG})"
-done
-
-pkg_setup() {
- get_version
- CONFIG_CHECK="NETFILTER"
- ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
- CONFIG_CHECK+=" NETFILTER_NETLINK"
- ERROR_NETFILTER_NETLINK="ipset requires NETFILTER_NETLINK support in your kernel."
- # It does still build without NET_NS, but it may be needed in future.
- #CONFIG_CHECK="${CONFIG_CHECK} NET_NS"
- #ERROR_NET_NS="ipset requires NET_NS (network namespace) support in your kernel."
- CONFIG_CHECK+=" !PAX_CONSTIFY_PLUGIN"
- ERROR_PAX_CONSTIFY_PLUGIN="ipset contains constified variables (#614896)"
-
- build_modules=0
- if use modules; then
- if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
- if linux_chkconfig_present "IP_NF_SET" || \
- linux_chkconfig_present "IP_SET"; then #274577
- eerror "There is IP{,_NF}_SET or NETFILTER_XT_SET support in your kernel."
- eerror "Please either build ipset with modules USE flag disabled"
- eerror "or rebuild kernel without IP_SET support and make sure"
- eerror "there is NO kernel ip_set* modules in /lib/modules/<your_kernel>/... ."
- die "USE=modules and in-kernel ipset support detected."
- else
- einfo "Modular kernel detected. Gonna build kernel modules..."
- build_modules=1
- fi
- else
- eerror "Nonmodular kernel detected, but USE=modules. Either build"
- eerror "modular kernel (without IP_SET) or disable USE=modules"
- die "Nonmodular kernel detected, will not build kernel modules"
- fi
- fi
- [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
-}
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- export bashcompdir="$(get_bashcompdir)"
-
- econf \
- --enable-bashcompl \
- $(use_with modules kmod) \
- --with-maxsets=${IP_NF_SET_MAX} \
- --with-ksource="${KV_DIR}" \
- --with-kbuild="${KV_OUT_DIR}"
-}
-
-src_compile() {
- einfo "Building userspace"
- emake
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Building kernel modules"
- set_arch_to_kernel
- emake modules
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- default
-
- find "${ED}" -name '*.la' -delete || die
-
- newinitd "${FILESDIR}"/ipset.initd-r4 ${PN}
- newconfd "${FILESDIR}"/ipset.confd ${PN}
- systemd_newunit "${FILESDIR}"/ipset.systemd ${PN}.service
- keepdir /var/lib/ipset
-
- if [[ ${build_modules} -eq 1 ]]; then
- einfo "Installing kernel modules"
- linux-mod_src_install
- fi
-}