summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-12-06 14:23:22 +0800
committerYixun Lan <dlan@gentoo.org>2021-12-06 14:32:43 +0800
commitc91aab7ed97c3970611e11f91e4c83a230db5b98 (patch)
tree628a88919fcc466c9bff421ffbf0580c12722345 /net-fs/autofs
parentmail-mta/postfix: bump to 3.7_pre20211205 (diff)
downloadgentoo-c91aab7ed97c3970611e11f91e4c83a230db5b98.tar.gz
gentoo-c91aab7ed97c3970611e11f91e4c83a230db5b98.tar.bz2
gentoo-c91aab7ed97c3970611e11f91e4c83a230db5b98.zip
net-fs/autofs: fix dmalloc compiling err
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-fs/autofs')
-rw-r--r--net-fs/autofs/autofs-5.1.8.ebuild2
-rw-r--r--net-fs/autofs/files/autofs-5.1.8-dmalloc.patch53
2 files changed, 55 insertions, 0 deletions
diff --git a/net-fs/autofs/autofs-5.1.8.ebuild b/net-fs/autofs/autofs-5.1.8.ebuild
index ede180337421..3c519f852c70 100644
--- a/net-fs/autofs/autofs-5.1.8.ebuild
+++ b/net-fs/autofs/autofs-5.1.8.ebuild
@@ -43,6 +43,8 @@ PATCHES=(
"${FILESDIR}/${PN}-5.1.7-glibc.patch"
"${FILESDIR}/${PN}-5.1.6-musl.patch"
"${FILESDIR}/${PN}-5.1.6-pid.patch"
+ "${FILESDIR}/${PN}-5.1.6-pid.patch"
+ "${FILESDIR}/${P}-dmalloc.patch"
)
pkg_setup() {
diff --git a/net-fs/autofs/files/autofs-5.1.8-dmalloc.patch b/net-fs/autofs/files/autofs-5.1.8-dmalloc.patch
new file mode 100644
index 000000000000..e2ed58fb1766
--- /dev/null
+++ b/net-fs/autofs/files/autofs-5.1.8-dmalloc.patch
@@ -0,0 +1,53 @@
+diff --git a/include/mounts.h b/include/mounts.h
+index ddb7e4c..854e1fb 100644
+--- a/include/mounts.h
++++ b/include/mounts.h
+@@ -84,7 +84,7 @@ typedef void (*tree_free_t) (struct tree_node *n);
+ struct tree_ops {
+ tree_new_t new;
+ tree_cmp_t cmp;
+- tree_free_t free;
++ tree_free_t set_free;
+ };
+
+ typedef int (*tree_work_fn_t) (struct tree_node *n, void *ptr);
+diff --git a/lib/mounts.c b/lib/mounts.c
+index 4c86688..1e54a33 100644
+--- a/lib/mounts.c
++++ b/lib/mounts.c
+@@ -75,7 +75,7 @@ static void tree_mnt_free(struct tree_node *n);
+ static struct tree_ops mnt_ops = {
+ .new = tree_mnt_new,
+ .cmp = tree_mnt_cmp,
+- .free = tree_mnt_free,
++ .set_free = tree_mnt_free,
+ };
+ static struct tree_ops *tree_mnt_ops = &mnt_ops;
+
+@@ -86,7 +86,7 @@ static void tree_host_free(struct tree_node *n);
+ static struct tree_ops host_ops = {
+ .new = tree_host_new,
+ .cmp = tree_host_cmp,
+- .free = tree_host_free,
++ .set_free = tree_host_free,
+ };
+ static struct tree_ops *tree_host_ops = &host_ops;
+
+@@ -97,7 +97,7 @@ static void tree_mapent_free(struct tree_node *n);
+ static struct tree_ops mapent_ops = {
+ .new = tree_mapent_new,
+ .cmp = tree_mapent_cmp,
+- .free = tree_mapent_free,
++ .set_free = tree_mapent_free,
+ };
+ static struct tree_ops *tree_mapent_ops = &mapent_ops;
+
+@@ -1360,7 +1360,7 @@ void tree_free(struct tree_node *root)
+ tree_free(root->right);
+ if (root->left)
+ tree_free(root->left);
+- ops->free(root);
++ ops->set_free(root);
+ }
+
+ int tree_traverse_inorder(struct tree_node *n, tree_work_fn_t work, void *ptr)