summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-01 23:01:24 -0500
committerTim Harder <radhermit@gentoo.org>2017-10-01 23:08:47 -0500
commite65850c69b04c2648732cb7ef11b7527025e0265 (patch)
tree0bf9f7a822669a3a24796ac4bcdd426c5b4f78ed /net-fs/btfs/btfs-2.17.ebuild
parentdev-vcs/git: cleanup old ebuilds. (diff)
downloadgentoo-e65850c69b04c2648732cb7ef11b7527025e0265.tar.gz
gentoo-e65850c69b04c2648732cb7ef11b7527025e0265.tar.bz2
gentoo-e65850c69b04c2648732cb7ef11b7527025e0265.zip
net-fs/btfs: version bump to 2.17
Diffstat (limited to 'net-fs/btfs/btfs-2.17.ebuild')
-rw-r--r--net-fs/btfs/btfs-2.17.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-fs/btfs/btfs-2.17.ebuild b/net-fs/btfs/btfs-2.17.ebuild
new file mode 100644
index 000000000000..00453fa98b64
--- /dev/null
+++ b/net-fs/btfs/btfs-2.17.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit autotools python-r1
+
+DESCRIPTION="a bittorrent filesystem based on FUSE"
+HOMEPAGE="https://github.com/johang/btfs"
+SRC_URI="https://github.com/johang/btfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND=">=sys-fs/fuse-2.8.0:0
+ >=net-misc/curl-7.22.0
+ dev-libs/boost:=
+ >=net-libs/libtorrent-rasterbar-0.16.0:="
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # don't install btplay via make
+ sed -i '/^SUBDIRS =/s/scripts//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ python_foreach_impl python_doscript scripts/btplay
+}