summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2021-01-23 01:11:07 -0700
committerTim Harder <radhermit@gentoo.org>2021-01-23 01:11:56 -0700
commit33d5fd88534fdba8d82543ad26e1bbe5a113ad67 (patch)
tree834c2849c5663bb7e314cf2935b055ec529d2347 /net-fs/btfs/btfs-2.23.ebuild
parentmedia-gfx/feh: remove old (diff)
downloadgentoo-33d5fd88534fdba8d82543ad26e1bbe5a113ad67.tar.gz
gentoo-33d5fd88534fdba8d82543ad26e1bbe5a113ad67.tar.bz2
gentoo-33d5fd88534fdba8d82543ad26e1bbe5a113ad67.zip
net-fs/btfs: version bump to 2.23
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'net-fs/btfs/btfs-2.23.ebuild')
-rw-r--r--net-fs/btfs/btfs-2.23.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-fs/btfs/btfs-2.23.ebuild b/net-fs/btfs/btfs-2.23.ebuild
new file mode 100644
index 000000000000..ec77a5957b93
--- /dev/null
+++ b/net-fs/btfs/btfs-2.23.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit autotools python-r1
+
+DESCRIPTION="a bittorrent filesystem based on FUSE"
+HOMEPAGE="https://github.com/johang/btfs"
+SRC_URI="https://github.com/johang/btfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND=">=sys-fs/fuse-2.8.0:0
+ >=net-misc/curl-7.22.0
+ dev-libs/boost:=
+ >=net-libs/libtorrent-rasterbar-0.16.0:="
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # don't install btplay via make
+ sed -i '/^SUBDIRS =/s/scripts//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ python_foreach_impl python_doscript scripts/btplay
+}