summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@binghamton.edu>2016-05-15 23:46:45 -0400
committerIan Delaney <idella4@gentoo.org>2016-05-17 13:48:12 +0800
commit80446750d4dc314dfe9080f69e22b03385e3d16d (patch)
treeffe89b59d1f031ce17be743b326ffa038354c89e /net-fs/davfs2/davfs2-1.5.4.ebuild
parentnet-analyzer/cacti: Stable for HPPA (bug #582996). (diff)
downloadgentoo-80446750d4dc314dfe9080f69e22b03385e3d16d.tar.gz
gentoo-80446750d4dc314dfe9080f69e22b03385e3d16d.tar.bz2
gentoo-80446750d4dc314dfe9080f69e22b03385e3d16d.zip
net-fs/davfs2: bump to 1.5.4, eapi bump, add nls flag, update license
- Bump to EAPI 6 - Add a "nls" USE flag along with the gettext build time, and libintl and libiconv runtime deps - The source is licensed with GPL-3+ now Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1475 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'net-fs/davfs2/davfs2-1.5.4.ebuild')
-rw-r--r--net-fs/davfs2/davfs2-1.5.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-fs/davfs2/davfs2-1.5.4.ebuild b/net-fs/davfs2/davfs2-1.5.4.ebuild
new file mode 100644
index 000000000000..469e30343889
--- /dev/null
+++ b/net-fs/davfs2/davfs2-1.5.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit user
+
+DESCRIPTION="Linux FUSE (or coda) driver that allows you to mount a WebDAV resource"
+HOMEPAGE="https://savannah.nongnu.org/projects/davfs2"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+RESTRICT="test"
+
+RDEPEND="dev-libs/libxml2
+ net-libs/neon
+ sys-libs/zlib
+ nls? ( virtual/libintl virtual/libiconv )
+"
+DEPEND="${REPEND}
+ nls? ( sys-devel/gettext )
+"
+
+pkg_setup() {
+ enewgroup davfs2
+}
+
+src_configure() {
+ econf dav_user=nobody --enable-largefile $(use_enable nls)
+}
+
+pkg_postinst() {
+ elog
+ elog "Quick setup:"
+ elog " (as root)"
+ elog " # gpasswd -a \${your_user} davfs2"
+ elog " # echo 'http://path/to/dav /home/\${your_user}/dav davfs rw,user,noauto 0 0' >> /etc/fstab"
+ elog " (as user)"
+ elog " \$ mkdir -p ~/dav"
+ elog " \$ mount ~/dav"
+ elog
+}