summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-15 08:46:36 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-15 10:21:55 +0200
commitc17038c603822582a9296224a03345ecdab007c2 (patch)
tree3076ae9c6d283c394b8dfa0a86d90cf99c9c66ca /net-fs/libnfs/libnfs-1.9.8.ebuild
parentapp-i18n/ibus: version bump 1.5.14 (diff)
downloadgentoo-c17038c603822582a9296224a03345ecdab007c2.tar.gz
gentoo-c17038c603822582a9296224a03345ecdab007c2.tar.bz2
gentoo-c17038c603822582a9296224a03345ecdab007c2.zip
net-fs/libnfs: Bump to version 1.9.8
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-fs/libnfs/libnfs-1.9.8.ebuild')
-rw-r--r--net-fs/libnfs/libnfs-1.9.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-fs/libnfs/libnfs-1.9.8.ebuild b/net-fs/libnfs/libnfs-1.9.8.ebuild
new file mode 100644
index 000000000000..c60aaecfa705
--- /dev/null
+++ b/net-fs/libnfs/libnfs-1.9.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF="1"
+
+inherit eutils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/sahlberg/libnfs.git"
+ inherit git-2 autotools-utils
+else
+ SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86"
+ inherit autotools-utils
+fi
+
+DESCRIPTION="Client library for accessing NFS shares over a network"
+HOMEPAGE="https://github.com/sahlberg/libnfs"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0/8" # sub-slot matches SONAME major
+IUSE="examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ # --enable-examples configure switch just compiles them
+ # better install sources instead
+ exeinto /usr/share/doc/${PF}/examples/
+ for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
+ doexe examples/${program}.c
+ done
+ fi
+}