summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-07-21 19:19:55 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-07-21 19:53:41 +0200
commit91a41fe8c9405eac2e11f2310890fe9e80b6c2c6 (patch)
treee407974e73885004840a26782c9c43038a8ae24d /net-fs/libnfs
parentnet-fs/libnfs: Bump to v2.0.0 (diff)
downloadgentoo-91a41fe8c9405eac2e11f2310890fe9e80b6c2c6.tar.gz
gentoo-91a41fe8c9405eac2e11f2310890fe9e80b6c2c6.tar.bz2
gentoo-91a41fe8c9405eac2e11f2310890fe9e80b6c2c6.zip
net-fs/libnfs: Changes from v2.0.0 bump integrated into live ebuild
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-fs/libnfs')
-rw-r--r--net-fs/libnfs/libnfs-9999.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/net-fs/libnfs/libnfs-9999.ebuild b/net-fs/libnfs/libnfs-9999.ebuild
index 8c3007a32bef..267c88a3ab41 100644
--- a/net-fs/libnfs/libnfs-9999.ebuild
+++ b/net-fs/libnfs/libnfs-9999.ebuild
@@ -1,25 +1,24 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
AUTOTOOLS_AUTORECONF="1"
-inherit eutils
+inherit eutils autotools autotools-utils
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/sahlberg/libnfs.git"
- inherit git-2 autotools-utils
+ EGIT_REPO_URI="https://github.com/sahlberg/libnfs.git"
+ inherit git-2
else
SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86"
- inherit autotools-utils
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86"
fi
DESCRIPTION="Client library for accessing NFS shares over a network"
HOMEPAGE="https://github.com/sahlberg/libnfs"
LICENSE="LGPL-2.1 GPL-3"
-SLOT="0/8" # sub-slot matches SONAME major
+SLOT="0/11" # sub-slot matches SONAME major
IUSE="examples static-libs"
RDEPEND=""
@@ -28,6 +27,14 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${PN}-${P}"
+src_prepare() {
+ default
+
+ epatch_user
+
+ eautoreconf
+}
+
src_install() {
autotools-utils_src_install
if use examples; then