summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 05:53:54 +0000
committerSam James <sam@gentoo.org>2021-02-27 06:19:32 +0000
commiteb437d523be016555c89ba66b6b09977d62c75fc (patch)
tree608e3ad10f4a6499f662ff4f509245c20a4ebfb7 /net-fs/smbtad
parentprofiles/base/package.use.mask: mask sci-mathematics/yafu[sieve] (diff)
downloadgentoo-eb437d523be016555c89ba66b6b09977d62c75fc.tar.gz
gentoo-eb437d523be016555c89ba66b6b09977d62c75fc.tar.bz2
gentoo-eb437d523be016555c89ba66b6b09977d62c75fc.zip
net-fs/smbtad: fix gcc 10 build
Closes: https://bugs.gentoo.org/707778 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs/smbtad')
-rw-r--r--net-fs/smbtad/smbtad-1.2.6.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-fs/smbtad/smbtad-1.2.6.ebuild b/net-fs/smbtad/smbtad-1.2.6.ebuild
index 8a0ed2811e4b..e1a62c8d8bc1 100644
--- a/net-fs/smbtad/smbtad-1.2.6.ebuild
+++ b/net-fs/smbtad/smbtad-1.2.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils
+inherit cmake-utils flag-o-matic
DESCRIPTION="Data receiver of the SMB Traffic Analyzer project"
HOMEPAGE="https://github.com/hhetter/smbtad"
@@ -28,6 +28,9 @@ DOCS=( README AUTHORS )
src_prepare() {
cmake-utils_src_prepare
+ # bug #707778
+ append-cflags -fcommon
+
sed -i \
-e '/CMAKE_C_FLAGS/d' \
CMakeLists.txt || die