summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-03-28 14:53:50 -0700
committerZac Medico <zmedico@gentoo.org>2018-03-28 14:55:35 -0700
commitca7746f52fa2122c716be52765e1ac3515c6fc54 (patch)
tree99bde8c413c4b944b1a6de8786bef0d499a4581d /net-fs
parentsys-kernel/vanilla-sources: Version bump to 4.9.91 (diff)
downloadgentoo-ca7746f52fa2122c716be52765e1ac3515c6fc54.tar.gz
gentoo-ca7746f52fa2122c716be52765e1ac3515c6fc54.tar.bz2
gentoo-ca7746f52fa2122c716be52765e1ac3515c6fc54.zip
net-fs/torus: remove package (dead upstream, no consumers)
Closes: https://bugs.gentoo.org/651844
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/torus/Manifest3
-rw-r--r--net-fs/torus/metadata.xml11
-rw-r--r--net-fs/torus/torus-0.1.2.ebuild82
3 files changed, 0 insertions, 96 deletions
diff --git a/net-fs/torus/Manifest b/net-fs/torus/Manifest
deleted file mode 100644
index 403db5c41d1b..000000000000
--- a/net-fs/torus/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST glide-0.10.2.tar.gz 204775 BLAKE2B 018325db34f92844cae7e763c87d3351deba2d54a0caf0f9f31bd1421e358fbadc7ce68c8ef972d1d18bde66fc64962d2ab5bb5bc22b631339b1f0dc05ce9456 SHA512 5e8ecf20de7ce53236d16e52e98acf46f4611d84b742665009d4aea44efe9ba09344f9fe5a6d3f6d6b67ba168ac0f825f620ea419a24ddd826a3ecd83aeea320
-DIST gogo-protobuf-0.3.tar.gz 2116795 BLAKE2B 6b90ad97648e75724c69bb9b8d3cfb17b919a1121813c09ec463df99c290c117b0e0b87f43b285eb5147a205f2f926c223cc4b4d58205a286af2afa87dbd7f5b SHA512 57e1b1715d4811800da8cf9f2c72d202deae622d89715d7eff2ff0c406a0ea3778c187443abb17b072ae6fe57382844807f103837032759dab5420c860b99fb8
-DIST torus-0.1.2.tar.gz 8319943 BLAKE2B 19b146b91769fe9481dd775b95fd7d2c68da87b1f46af58938e4a4eb87a4f661164986eb64ae607b9b368390418586b9baa736fc0a4803fa267ce922c2938c5a SHA512 46d56f560d92cf0b0c357d57d5249584f9a8444dc6bb0c3e00db3a288eea496fbc19c73be87ac9d534a4707ed74769e91354c95bac4b354fc62104a006239912
diff --git a/net-fs/torus/metadata.xml b/net-fs/torus/metadata.xml
deleted file mode 100644
index d39e23bd6dca..000000000000
--- a/net-fs/torus/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- <name>Zac Medico</name>
- </maintainer>
- <upstream>
- <remote-id type="github">coreos/torus</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/net-fs/torus/torus-0.1.2.ebuild b/net-fs/torus/torus-0.1.2.ebuild
deleted file mode 100644
index 0c209a63b960..000000000000
--- a/net-fs/torus/torus-0.1.2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGO_PN="github.com/coreos/${PN}/..."
-SRC_URI="https://${EGO_PN%/*}/releases/download/v${PV}/${PN}_v${PV}_src.tar.gz -> ${P}.tar.gz
- https://github.com/Masterminds/glide/archive/0.10.2.tar.gz -> glide-0.10.2.tar.gz
- test? ( https://github.com/gogo/protobuf/archive/v0.3.tar.gz -> gogo-protobuf-0.3.tar.gz )"
-
-DESCRIPTION="A distributed storage system coordinated through etcd"
-HOMEPAGE="https://${EGO_PN%/*}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-
-DEPEND=">=dev-lang/go-1.6:="
-RDEPEND=""
-
-get_archive_go_package() {
- local archive=${1} uri x
- for x in ${SRC_URI}; do
- if [[ ${x} == http* ]]; then
- uri=${x}
- elif [[ ${x} == ${archive} ]]; then
- break
- fi
- done
- uri=${uri#https://}
- uri=${uri%/archive/*}
- case ${uri} in
- ${EGO_PN%/*}*)
- echo "${EGO_PN%/*}|${PN}_*"
- ;;
- *)
- echo "${uri}|${uri##*/}-*"
- ;;
- esac
-}
-
-unpack_go_packages() {
- local go_package x
- # Unpack packages to appropriate locations for GOPATH
- for x in ${A}; do
- unpack ${x}
- if [[ ${x} == *.tar.gz ]]; then
- go_package=$(get_archive_go_package ${x})
- x=${go_package#*|}
- go_package=${go_package%|*}
- mkdir -p src/${go_package%/*}
- mv ${x} src/${go_package} || die
- fi
- done
-}
-
-src_unpack() {
- mkdir "${S}" || die
- cd "${S}" || die
- unpack_go_packages
-}
-
-src_compile() {
- GOPATH="${S}" go install -v -work -x github.com/Masterminds/glide/... || die
- mkdir -p "${S}/src/${EGO_PN%/*}/tools" || die
- mv "${S}/bin/glide" "${S}/src/${EGO_PN%/*}/tools/glide" || die
- GOPATH="${S}" \
- emake -C "${S}/src/${EGO_PN%/*}" VERSION=v${PV} build
-}
-
-src_test() {
- GOPATH="${S}" \
- emake -C "${S}/src/${EGO_PN%/*}" VERSION=v${PV} test
-}
-
-src_install() {
- cd "${S}/src/${EGO_PN%/*}"|| die
- dobin bin/${PN}*
- dodoc README.md
- use doc && dodoc -r Documentation
-}