summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-04 10:06:44 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-04 10:15:53 +0200
commit560e1424231156c902846c80d40c256a85b59d2e (patch)
treee9978ff31165f7622eadf63a4d353dae68ca6ff6 /net-ftp/filezilla
parentdev-libs/tinyxml-2.6.2-r2: keyworded for ~alpha (diff)
downloadgentoo-560e1424231156c902846c80d40c256a85b59d2e.tar.gz
gentoo-560e1424231156c902846c80d40c256a85b59d2e.tar.bz2
gentoo-560e1424231156c902846c80d40c256a85b59d2e.zip
net-ftp/filezilla: Bump to version 3.22.1
Package-Manager: portage-2.3.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/files/filezilla-3.22.1-debug.patch12
-rw-r--r--net-ftp/filezilla/filezilla-3.22.1.ebuild69
3 files changed, 82 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index c04ff94aa44d..ec4c5500e083 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -2,3 +2,4 @@ DIST FileZilla_3.12.0.2_src.tar.bz2 4440836 SHA256 7a296fc2cd94d00d3a14ad29b84ff
DIST FileZilla_3.14.1_src.tar.bz2 4411187 SHA256 b10871b6ced5f52062b44deda037edb8a38090b226a018b9b64b1a1feb59d46c SHA512 c97767ed01f4538a2f4b8760601778ca7f9aa99b5b928cb86c9508eba0490bbc1f31921d098e0ccd30712ff06dc9f21d323201fb8bee80b9fb7a6528fbb03368 WHIRLPOOL 1fbccfbb0de5111fad14eb0b38ee190aefc4c80777c3611189c74412dfefdf2fd96d4a42c917791d3a3318b6ae22f01a7d24a4a0904386b22a98693151b5a822
DIST FileZilla_3.21.0_src.tar.bz2 4428270 SHA256 209bcdfcd60ae2278fa2fa8d99421682e0db146add9e96cb1e8455c3378c80e4 SHA512 d58573c58e524a257cdbcb60fdb5c749d8e4f8a390b728b458721944b3e836cedf3478ff55565885ff1853ddb3f368d6e6e6d45142f19a9a4ee755b88ceb56b4 WHIRLPOOL 20e5e553f359731e205fb9fdcbb4d62329fda33e2d81e944a9b504c8958aa89beb80bb62de2ac01c0544f4ed3319cbcb9ddeb403f486e56232da2cd34a1ead10
DIST FileZilla_3.22.0_src.tar.bz2 4446165 SHA256 60b48314f356f682712c9cec0a27c6469bf888da781c658054bb7f0b23dcfacf SHA512 ce84ac614670e07454e80139f6f3d4299559b3faf74683989db3672358e1d2352017765b643519f4a6c272f24a13adcffbe90e925404d835fe9c5e6cb26528ae WHIRLPOOL fcff9115dc796d15aba9f843469268afeba3dbb6668c9dffbff1608d1a07215877ca9b7866e01756e0ea4da52212a94ca8fd0db8f1eed7449e24ef09cbef8d5c
+DIST FileZilla_3.22.1_src.tar.bz2 4446400 SHA256 2ea8a0d613e062c34c01b0a1c0860e1328bb8247eb02aa73ef4597d984e4285f SHA512 c03435e56279d384f1b0716e61082553a6f8157b305bc200d4666a27543094d3403d471153c7ceb8a2e9af00516186663e8b8840350930938a25b456e72c5c4a WHIRLPOOL 4ab2f77a4b89b0078e944a192fecf9ae955dee133afb8f3f6bc46d6ddc8b0c66eddc0009a1c395c4426aa4d2bd377bad45d83d6b5c1af8aa9b28b4f3c5d16109
diff --git a/net-ftp/filezilla/files/filezilla-3.22.1-debug.patch b/net-ftp/filezilla/files/filezilla-3.22.1-debug.patch
new file mode 100644
index 000000000000..71430db1c79e
--- /dev/null
+++ b/net-ftp/filezilla/files/filezilla-3.22.1-debug.patch
@@ -0,0 +1,12 @@
+--- filezilla-3.22.1/configure.ac
++++ filezilla-3.22.1/configure.ac
+@@ -36,9 +36,7 @@
+
+ if test "X$GCC" = Xyes; then
+ AX_APPEND_FLAG(-Wall, CFLAGS)
+- AX_APPEND_FLAG(-g, CFLAGS)
+ AX_APPEND_FLAG(-Wall, CXXFLAGS)
+- AX_APPEND_FLAG(-g, CXXFLAGS)
+ fi
+
+ # Do this early: Compiler and linker flags to work around a nasty bug in Xcode.
diff --git a/net-ftp/filezilla/filezilla-3.22.1.ebuild b/net-ftp/filezilla/filezilla-3.22.1.ebuild
new file mode 100644
index 000000000000..6f3f380da4a7
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.22.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit autotools eutils flag-o-matic multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.7.0
+ >=dev-libs/pugixml-1.7
+ net-dns/libidn
+ >=net-libs/gnutls-3.4.0
+ >=x11-libs/wxGTK-3.0.2.0-r1:3.0[X] x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.22.1-debug.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-pugixml=system \
+ --disable-autoupdatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ doicon src/interface/resources/48x48/${PN}.png
+
+ dodoc AUTHORS ChangeLog NEWS
+}