summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-28 12:03:52 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-28 12:13:35 +0200
commitfd79bfc0c19fd6985c6b4dcd4782006eb2123a66 (patch)
treeafeab6dbb109814f6019b43e4d1ecbe622fd955a /net-ftp/gproftpd/files
parentnet-libs/serf: add patch for LibreSSL (diff)
downloadgentoo-fd79bfc0c19fd6985c6b4dcd4782006eb2123a66.tar.gz
gentoo-fd79bfc0c19fd6985c6b4dcd4782006eb2123a66.tar.bz2
gentoo-fd79bfc0c19fd6985c6b4dcd4782006eb2123a66.zip
net-ftp/gproftpd: Fix building with CFLAGS=-fno-common
Also: - EAPI=7 - Use HTTPS (except for SRC_URI which was already failing) - Drop pointless USE flags (see below) - Fix dependencies: openssl is not used (drop USE=ssl), proftpd should not be a dependency at all as gproftpd merely edits its run-time configuration files, add gettext/libiconv - Fix .desktop file and install it at the correct location (drop USE=gnome) - Drop configuration flags that very obviously belong to proftpd and not gproftpd Package-Manager: Portage-2.3.100, Repoman-2.3.22 Closes: https://bugs.gentoo.org/710878 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-ftp/gproftpd/files')
-rw-r--r--net-ftp/gproftpd/files/gproftpd-8.3.2-desktop.patch12
-rw-r--r--net-ftp/gproftpd/files/gproftpd-8.3.2-fno-common.patch25
-rw-r--r--net-ftp/gproftpd/files/gproftpd-8.3.2-install.patch39
3 files changed, 76 insertions, 0 deletions
diff --git a/net-ftp/gproftpd/files/gproftpd-8.3.2-desktop.patch b/net-ftp/gproftpd/files/gproftpd-8.3.2-desktop.patch
new file mode 100644
index 000000000000..a7ac93e0c4af
--- /dev/null
+++ b/net-ftp/gproftpd/files/gproftpd-8.3.2-desktop.patch
@@ -0,0 +1,12 @@
+--- a/desktop/net-gproftpd.desktop
++++ b/desktop/net-gproftpd.desktop
+@@ -16,7 +16,7 @@
+ GenericName=GPROFTPD
+ Comment=Proftpd FTP server administration
+ Exec=gproftpd
+-Icon=gproftpd.png
++Icon=gproftpd
+ Terminal=false
+ Type=Application
+-Categories=Application;Network;X-Red-Hat-ServerConfig;X-Red-Hat-Base;
++Categories=Network
diff --git a/net-ftp/gproftpd/files/gproftpd-8.3.2-fno-common.patch b/net-ftp/gproftpd/files/gproftpd-8.3.2-fno-common.patch
new file mode 100644
index 000000000000..af3b579d77f7
--- /dev/null
+++ b/net-ftp/gproftpd/files/gproftpd-8.3.2-fno-common.patch
@@ -0,0 +1,25 @@
+--- a/src/apply_user.c
++++ b/src/apply_user.c
+@@ -52,11 +52,6 @@
+ //gchar *dir; // ???
+ extern gchar *homedir;
+
+-/* The 18 checkbox values */
+-gchar *dir_val[19]; // ???
+-
+-char *user_profile; // ???
+-
+ extern long num_rows;
+ extern int row_pos;
+
+--- a/src/dir_treeview_funcs.h
++++ b/src/dir_treeview_funcs.h
+@@ -18,6 +18,8 @@
+ *
+ */
+
++extern gchar *dir_val[19];
++extern char *user_profile;
+
+ gboolean dirs_foreach(GtkTreeModel *model, GtkTreePath *path,
+ GtkTreeIter *iter, struct w *widgets);
diff --git a/net-ftp/gproftpd/files/gproftpd-8.3.2-install.patch b/net-ftp/gproftpd/files/gproftpd-8.3.2-install.patch
new file mode 100644
index 000000000000..3db967d01a1d
--- /dev/null
+++ b/net-ftp/gproftpd/files/gproftpd-8.3.2-install.patch
@@ -0,0 +1,39 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -19,26 +19,28 @@
+ fi \
+ done \
+ fi;
+- if test -d $(DESTDIR)$(datadir)/pixmaps; then \
++ if test -d $(datadir)/pixmaps; then \
+ cp pixmaps/gproftpd.png $(DESTDIR)$(datadir)/pixmaps/; \
+ fi;
+- if test -f $(DESTDIR)$(bindir)/consolehelper && test ! -f $(DESTDIR)$(bindir)/gproftpd; then \
++ if test -f $(bindir)/consolehelper && test ! -f $(DESTDIR)$(bindir)/gproftpd; then \
+ ln -s $(DESTDIR)$(bindir)/consolehelper $(DESTDIR)$(bindir)/gproftpd; \
+ fi;
+ @echo "Failsafe for a mixed environment"
+ if test -f $(DESTDIR)/usr/local/bin/consolehelper && test ! -f $(DESTDIR)/usr/local/bin/gproftpd; then \
+ ln -s $(DESTDIR)/usr/local/bin/consolehelper $(DESTDIR)/usr/local/bin/gproftpd; \
+ fi;
+- if test -d $(DESTDIR)$(sysconfdir)/pam.d; then \
++ if test -d $(sysconfdir)/pam.d; then \
++ $(mkinstalldirs) $(DESTDIR)$(sysconfdir)/pam.d; \
+ cp etc/pam.d/gproftpd $(DESTDIR)$(sysconfdir)/pam.d/; \
+ fi;
+- if test -d $(DESTDIR)$(sysconfdir)/security/console.apps; then \
++ if test -d $(sysconfdir)/security/console.apps; then \
+ cp etc/security/console.apps/gproftpd $(DESTDIR)$(sysconfdir)/security/console.apps/; \
+- fi;
+- if test -d $(DESTDIR)$(datadir)/applications; then \
+- cp desktop/net-gproftpd.desktop $(DESTDIR)$(datadir)/applications/; \
+ fi;
+- if test -d $(DESTDIR)$(datadir)/gnome/apps/Internet; then \
++ if test -d $(datadir)/applications; then \
++ $(mkinstalldirs) $(DESTDIR)$(datadir)/applications/; \
++ cp desktop/net-gproftpd.desktop $(DESTDIR)$(datadir)/applications/gproftpd.desktop; \
++ fi;
++ if test -d $(datadir)/gnome/apps/Internet; then \
+ cp desktop/net-gproftpd.desktop $(DESTDIR)$(datadir)/gnome/apps/Internet/; \
+ fi;
+ if test ! -d $(DESTDIR)$(datadir)/doc/gproftpd; then \