summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-27 11:15:13 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-27 11:21:08 +0100
commit1224a05ef18f8e30298366873ffc7d8065fae62a (patch)
treeb9b7fe46358a286f63a2a9cd70a8c211688a3e14 /net-ftp/ncftp/ncftp-3.2.6-r1.ebuild
parentpackage.mask: Last rite dev-python/twisted-* and co. no-revdep (diff)
downloadgentoo-1224a05ef18f8e30298366873ffc7d8065fae62a.tar.gz
gentoo-1224a05ef18f8e30298366873ffc7d8065fae62a.tar.bz2
gentoo-1224a05ef18f8e30298366873ffc7d8065fae62a.zip
net-ftp/ncftp: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-ftp/ncftp/ncftp-3.2.6-r1.ebuild')
-rw-r--r--net-ftp/ncftp/ncftp-3.2.6-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-ftp/ncftp/ncftp-3.2.6-r1.ebuild b/net-ftp/ncftp/ncftp-3.2.6-r1.ebuild
new file mode 100644
index 000000000000..7c177b45e9f7
--- /dev/null
+++ b/net-ftp/ncftp/ncftp-3.2.6-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+DESCRIPTION="An extremely configurable ftp client"
+HOMEPAGE="http://www.ncftp.com/"
+SRC_URI="
+ ftp://ftp.${PN}.com/${PN}/${P}-src.tar.xz -> ${P}.tar.xz
+"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x86-solaris"
+IUSE="pch"
+
+DEPEND="
+ sys-libs/ncurses:*
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.6-fno-common.patch
+)
+
+src_prepare() {
+ default
+
+ AT_M4DIR=autoconf_local/ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ LC_ALL="C" \
+ LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses)" \
+ econf \
+ $(use_enable pch precomp) \
+ --disable-ccdv \
+ --disable-universal
+}
+
+src_install() {
+ default
+ dodoc README.txt doc/*.txt
+ docinto html
+ dodoc doc/html/*.html
+}