summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-01-07 00:55:13 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-01-07 00:55:13 +0100
commit02ee042c7a7dc589b95ca521013f9fa35545f49a (patch)
tree7e53587a2a2364da36733fa3c19b4b5c158bb10f /net-ftp
parentdev-libs/libfilezilla: Bump to version 0.26.0 (diff)
downloadgentoo-02ee042c7a7dc589b95ca521013f9fa35545f49a.tar.gz
gentoo-02ee042c7a7dc589b95ca521013f9fa35545f49a.tar.bz2
gentoo-02ee042c7a7dc589b95ca521013f9fa35545f49a.zip
net-ftp/filezilla: Bump to version 3.52.0.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.52.0.3.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index 75a8269a9ce4..67c399bcef47 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -1,3 +1,4 @@
DIST FileZilla_3.47.2.1_src.tar.bz2 4733941 BLAKE2B 0517d43bfba8aa116ae4031d56e5070aadbcaf81ace2311f6cfddb47e7f67ec62396ae3690c139bcc1a8368be690776b3163dd6d53a6ebb27ee5e99300b3c67b SHA512 8919eab7762e0e30241637a8978fbf61f02ac4c52aac293191315b931d52b41ae228b753f4e3b7530835578836dfee7f91772841273e9fc2bdf75ff7ed48fafc
DIST FileZilla_3.50.0_src.tar.bz2 4791977 BLAKE2B c0352eea9c4cd0a10d25b21b0a6982a762df6353a8da0703179270ef27be71bf151591011c45aae6e303437ac5ecca6a340635c392e2ed6db1a4a9d4002f4d7b SHA512 5edcb18aa7e4a0a59678d589d20996d7f6311f717e55a70c9dacafe42e3df6cba79be778bef34ff399672941dfb78a4732b83f21016b721702c763f0408b3e40
DIST FileZilla_3.51.0_src.tar.bz2 4808717 BLAKE2B 67f614032145abe7f715254fd47756d3a537d2eca63be976c29351f79e15d3620e77c1bb7beccc2b61a1df8b86484334a3e77639402c93e8ce28d4b12eb8884f SHA512 b5e0f80b61eb168b41f7582bf10bf0067da76aec3165ffe13819e20eb842ffc0fb12b01c54843b3ec4e7355111c36be249db3526e2ea2eaa77ba4274ffa03e93
+DIST FileZilla_3.52.0.3_src.tar.bz2 4812006 BLAKE2B 34a812e2a3fef0ec610d60a1916f4495c6e5d57acff66ba4b32525c9ee82e0ba401bbafd40ef79a4dadde9ddc5c7de1a2d3c2456218e8ef083c302166eccda39 SHA512 18ee90bd54d0e71f64bd960bf80601792fa99381eec5f970d3807d17e670bdba91d484e5db6c198bba4f5b09e63cd4b2312cb19491f50a20558188ad76ac0ff0
diff --git a/net-ftp/filezilla/filezilla-3.52.0.3.ebuild b/net-ftp/filezilla/filezilla-3.52.0.3.ebuild
new file mode 100644
index 000000000000..ba2ce7335de1
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.52.0.3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.26.0:=
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.5.7
+ >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( >=dev-util/cppunit-1.13.0 )"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+ "${FILESDIR}"/${PN}-3.47.0-metainfo.patch
+ "${FILESDIR}"/${PN}-3.47.0-disable-shellext_conf.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-autoupdatecheck
+ --with-pugixml=system
+ $(use_enable nls locales)
+ $(use_with dbus)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}