summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac.paragon@gmail.com>2022-01-16 14:10:28 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-01-19 19:21:07 +0100
commit294d5ec820bddfa0aded7dc0043e06c903050722 (patch)
tree9737f63fb1b7f973d47c0307fd9a968773b04178 /net-ftp
parentwww-apps/moodle: version bumps to 3.9.12, 3.10.9, 3.11.5 (diff)
downloadgentoo-294d5ec820bddfa0aded7dc0043e06c903050722.tar.gz
gentoo-294d5ec820bddfa0aded7dc0043e06c903050722.tar.bz2
gentoo-294d5ec820bddfa0aded7dc0043e06c903050722.zip
net-ftp/ncftp: bump to EAPI 8 and fix bugs
Closes: https://bugs.gentoo.org/727774 Closes: https://bugs.gentoo.org/727788 Closes: https://bugs.gentoo.org/821610 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Viorel Munteanu <ceamac.paragon@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23823 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ncftp/metadata.xml13
-rw-r--r--net-ftp/ncftp/ncftp-3.2.6-r4.ebuild55
2 files changed, 65 insertions, 3 deletions
diff --git a/net-ftp/ncftp/metadata.xml b/net-ftp/ncftp/metadata.xml
index 17eb3eeb039e..454915700044 100644
--- a/net-ftp/ncftp/metadata.xml
+++ b/net-ftp/ncftp/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription>
+ <maintainer type="person" proxied="yes">
+ <email>ceamac.paragon@gmail.com</email>
+ <name>Viorel Munteanu</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
NcFTP Client (also known as just NcFTP) is a set of FREE application
programs implementing the File Transfer Protocol (FTP).
@@ -11,5 +18,5 @@ popular alternative to the FTP program, /usr/bin/ftp. NcFTP offers many
ease-of-use and performance enhancements over the stock ftp client, and
runs on a wide variety of UNIX platforms as well as operating systems
such as Microsoft Windows and Apple Mac OS X.
-</longdescription>
+ </longdescription>
</pkgmetadata>
diff --git a/net-ftp/ncftp/ncftp-3.2.6-r4.ebuild b/net-ftp/ncftp/ncftp-3.2.6-r4.ebuild
new file mode 100644
index 000000000000..ec444773157b
--- /dev/null
+++ b/net-ftp/ncftp/ncftp-3.2.6-r4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools toolchain-funcs
+
+DESCRIPTION="An extremely configurable ftp client"
+HOMEPAGE="https://www.ncftp.com/"
+SRC_URI="
+ https://ftp.mirrorservice.org/sites/ftp.${PN}.com/${PN}/${P}-src.tar.xz
+"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="pch"
+
+DEPEND="
+ sys-libs/ncurses:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.2.6-fno-common.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e '/^AR=/d' autoconf_local/aclocal.m4 || die
+ # 727774
+ sed -i -e 's/STRIP=".*"/STRIP=":"/' autoconf_local/aclocal.m4 || die
+
+ AT_M4DIR=autoconf_local/ eautoreconf
+}
+
+src_configure() {
+ tc-export AR CC
+ LC_ALL="C" \
+ LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses)" \
+ econf \
+ $(use_enable pch precomp) \
+ --disable-ccdv \
+ --disable-universal
+}
+
+src_install() {
+ default
+ dodoc README.txt doc/*.txt
+ docinto html
+ dodoc doc/html/*.html
+}