summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-11-15 18:56:56 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-15 18:57:04 +0000
commit42f481bed6d26d48b34ca9c90ea2fdd176ac91e3 (patch)
treef1fca2f6242dae6274be9ed933dc57078dc8cd99 /net-ftp
parentgames-arcade/moleinvasion: Port to EAPI 7 (diff)
downloadgentoo-42f481bed6d26d48b34ca9c90ea2fdd176ac91e3.tar.gz
gentoo-42f481bed6d26d48b34ca9c90ea2fdd176ac91e3.tar.bz2
gentoo-42f481bed6d26d48b34ca9c90ea2fdd176ac91e3.zip
net-ftp/lftp: backport libressl support
Backported upstream patch. Reported-by: m1027 Closes: https://bugs.gentoo.org/754225 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/files/lftp-4.9.2-libressl.patch40
-rw-r--r--net-ftp/lftp/lftp-4.9.2.ebuild1
2 files changed, 41 insertions, 0 deletions
diff --git a/net-ftp/lftp/files/lftp-4.9.2-libressl.patch b/net-ftp/lftp/files/lftp-4.9.2-libressl.patch
new file mode 100644
index 000000000000..51de51f780dd
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-4.9.2-libressl.patch
@@ -0,0 +1,40 @@
+https://github.com/lavv17/lftp/commit/0276d5c239c41b3a63f738a5dc47fd56ac389cf0.patch
+
+From 0276d5c239c41b3a63f738a5dc47fd56ac389cf0 Mon Sep 17 00:00:00 2001
+From: Ganael Laplanche <ganael.laplanche@martymac.org>
+Date: Thu, 20 Aug 2020 12:29:05 +0200
+Subject: [PATCH] Fix build with LibreSSL (following commit 537f37898)
+
+---
+ src/lftp_ssl.cc | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+--- a/src/lftp_ssl.cc
++++ b/src/lftp_ssl.cc
+@@ -34,7 +34,7 @@
+ #include "misc.h"
+ #include "network.h"
+ #include "buffer.h"
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || LIBRESSL_VERSION_NUMBER
+ #define X509_STORE_CTX_get_by_subject X509_STORE_get_by_subject
+ #endif
+ extern "C" {
+@@ -840,7 +840,7 @@ lftp_ssl_openssl_instance::lftp_ssl_openssl_instance()
+ ssl_ctx=SSL_CTX_new();
+ X509_set_default_verify_paths(ssl_ctx->cert);
+ #else
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || LIBRESSL_VERSION_NUMBER
+ SSLeay_add_ssl_algorithms();
+ #endif
+ ssl_ctx=SSL_CTX_new(SSLv23_client_method());
+@@ -1080,7 +1080,7 @@ void lftp_ssl_openssl::copy_sid(const lftp_ssl_openssl *o)
+
+ const char *lftp_ssl_openssl::strerror()
+ {
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || LIBRESSL_VERSION_NUMBER
+ SSL_load_error_strings();
+ #endif
+ int error=ERR_get_error();
diff --git a/net-ftp/lftp/lftp-4.9.2.ebuild b/net-ftp/lftp/lftp-4.9.2.ebuild
index 94f6e46a85eb..121ccc94638b 100644
--- a/net-ftp/lftp/lftp-4.9.2.ebuild
+++ b/net-ftp/lftp/lftp-4.9.2.ebuild
@@ -59,6 +59,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.8.2-libdir-openssl.patch
"${FILESDIR}"/${PN}-4.8.2-libdir-zlib.patch
"${FILESDIR}"/${PN}-4.9.1-libdir-readline.patch
+ "${FILESDIR}"/${PN}-4.9.2-libressl.patch
)
src_prepare() {