summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-14 08:26:34 +0000
committerSam James <sam@gentoo.org>2023-02-14 21:41:35 +0000
commit800629fbe1e806757c79537eaa1bf5b37b937174 (patch)
tree38fff9d8a2791ff7e0db4eaab59ceeeac922a967 /net-ftp
parentprofiles: masking dev-ml/ppxfind (diff)
downloadgentoo-800629fbe1e806757c79537eaa1bf5b37b937174.tar.gz
gentoo-800629fbe1e806757c79537eaa1bf5b37b937174.tar.bz2
gentoo-800629fbe1e806757c79537eaa1bf5b37b937174.zip
net-ftp/lftp: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/lftp/files/lftp-4.9.2-configure-clang16.patch22
-rw-r--r--net-ftp/lftp/lftp-4.9.2-r1.ebuild (renamed from net-ftp/lftp/lftp-4.9.2.ebuild)3
2 files changed, 24 insertions, 1 deletions
diff --git a/net-ftp/lftp/files/lftp-4.9.2-configure-clang16.patch b/net-ftp/lftp/files/lftp-4.9.2-configure-clang16.patch
new file mode 100644
index 000000000000..d039390ffb80
--- /dev/null
+++ b/net-ftp/lftp/files/lftp-4.9.2-configure-clang16.patch
@@ -0,0 +1,22 @@
+https://github.com/lavv17/lftp/commit/8af97cc255c3d2488adb107515bd1047dbedadfe
+
+From 8af97cc255c3d2488adb107515bd1047dbedadfe Mon Sep 17 00:00:00 2001
+From: DJ Delorie <dj@redhat.com>
+Date: Wed, 8 Feb 2023 23:37:37 -0500
+Subject: [PATCH] Fix C99 compatibility issue
+
+Related to:
+
+ <https://fedoraproject.org/wiki/Changes/PortingToModernC>
+ <https://fedoraproject.org/wiki/Toolchain/PortingToModernC>
+--- a/m4/needtrio.m4
++++ b/m4/needtrio.m4
+@@ -9,6 +9,7 @@ AC_DEFUN([LFTP_NEED_TRIO],[
+ else
+
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[
++ #include <stdio.h>
+ int main()
+ {
+ unsigned long long x=0,x1;
+
diff --git a/net-ftp/lftp/lftp-4.9.2.ebuild b/net-ftp/lftp/lftp-4.9.2-r1.ebuild
index 59f56239e17f..9047ab306f17 100644
--- a/net-ftp/lftp/lftp-4.9.2.ebuild
+++ b/net-ftp/lftp/lftp-4.9.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -57,6 +57,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-4.8.2-libdir-zlib.patch
"${FILESDIR}"/${PN}-4.9.1-libdir-readline.patch
"${FILESDIR}"/${PN}-4.9.2-ac-270.patch
+ "${FILESDIR}"/${PN}-4.9.2-configure-clang16.patch
)
src_prepare() {