summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-02-09 22:41:45 -0600
committerTim Harder <radhermit@gentoo.org>2019-02-09 22:46:03 -0600
commit73ccf4a6bbacf812ff1d4da6e5e7f30de7d67aa4 (patch)
treebd84debe701e845c692857ad89b4ccb9eefafe9d /net-im/bitlbee/bitlbee-9999.ebuild
parentapp-text/robodoc: remove old 4.99.36 (diff)
downloadgentoo-73ccf4a6bbacf812ff1d4da6e5e7f30de7d67aa4.tar.gz
gentoo-73ccf4a6bbacf812ff1d4da6e5e7f30de7d67aa4.tar.bz2
gentoo-73ccf4a6bbacf812ff1d4da6e5e7f30de7d67aa4.zip
net-im/bitlbee: version bump to 3.6
Also, simplify the init script. Bug: https://bugs.gentoo.org/631072 Closes: https://bugs.gentoo.org/640126 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'net-im/bitlbee/bitlbee-9999.ebuild')
-rw-r--r--net-im/bitlbee/bitlbee-9999.ebuild29
1 files changed, 5 insertions, 24 deletions
diff --git a/net-im/bitlbee/bitlbee-9999.ebuild b/net-im/bitlbee/bitlbee-9999.ebuild
index ba55773394df..703647ae05d3 100644
--- a/net-im/bitlbee/bitlbee-9999.ebuild
+++ b/net-im/bitlbee/bitlbee-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit user systemd toolchain-funcs
@@ -48,7 +48,6 @@ DEPEND="${COMMON_DEPEND}
test? ( dev-libs/check )"
RDEPEND="${COMMON_DEPEND}
- virtual/logger
xinetd? ( sys-apps/xinetd )"
pkg_setup() {
@@ -57,12 +56,7 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} != "9999" ]]; then
- eapply \
- "${FILESDIR}"/${P}-systemd-user.patch \
- "${FILESDIR}"/${P}-verbose-build.patch
- fi
-
+ [[ ${PV} != "9999" ]] && eapply "${FILESDIR}"/${PN}-3.5-systemd-user.patch
eapply_user
}
@@ -143,8 +137,8 @@ src_install() {
newins doc/bitlbee.xinetd bitlbee
fi
- newinitd "${FILESDIR}"/bitlbee.initd-r1 bitlbee
- newconfd "${FILESDIR}"/bitlbee.confd-r1 bitlbee
+ newinitd "${FILESDIR}"/bitlbee.initd-r2 bitlbee
+ newconfd "${FILESDIR}"/bitlbee.confd-r2 bitlbee
exeinto /usr/share/bitlbee
doexe utils/{convert_purple.py,bitlbee-ctl.pl}
@@ -152,17 +146,4 @@ src_install() {
pkg_postinst() {
chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
- [[ -d "${ROOT}"/var/run/bitlbee ]] &&
- chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- einfo
- elog "The bitlbee init script will now attempt to stop all processes owned by the"
- elog "bitlbee user, including per-client forks."
- elog
- elog "Tell the init script not to touch anything besides the main bitlbee process"
- elog "by changing the BITLBEE_STOP_ALL variable in"
- elog " /etc/conf.d/bitlbee"
- einfo
- fi
}