summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/climm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/climm')
-rw-r--r--net-im/climm/Manifest1
-rw-r--r--net-im/climm/climm-0.7.1.ebuild64
-rw-r--r--net-im/climm/metadata.xml8
3 files changed, 73 insertions, 0 deletions
diff --git a/net-im/climm/Manifest b/net-im/climm/Manifest
new file mode 100644
index 000000000000..5bfadcd03868
--- /dev/null
+++ b/net-im/climm/Manifest
@@ -0,0 +1 @@
+DIST climm-0.7.1.tgz 1296303 SHA256 6212ada46947f0572fb6734b920a2cfd91b6a632cbd044d87476791a318af052 SHA512 8ee8b716229b4181a3b2f7ff3323b4587e80200ca753347f670616da9f25e8fd7cae4da597435d6f71b3a104ad89f3cfe4fd3f9524e259feef220255b6f7d138 WHIRLPOOL 4ca9f3af34512ac5af3f22413b170017a1cba11a42762211fcfd64c948a1c20263f2b9db339e63b829805f45212b5a0feb07c8e04044def07c0001c65dd7e27a
diff --git a/net-im/climm/climm-0.7.1.ebuild b/net-im/climm/climm-0.7.1.ebuild
new file mode 100644
index 000000000000..18afc161ab50
--- /dev/null
+++ b/net-im/climm/climm-0.7.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="ICQ text-mode client with many features"
+HOMEPAGE="http://www.climm.org/"
+SRC_URI="http://www.climm.org/source/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="xmpp gnutls otr tcl ssl"
+
+# In case user don't need xmpp there is a choice gnutls/openssl. Since xmpp
+# requires gnutls then without explicit request to use gnutls (USE=gnutls)
+# for ssl we fall back on gnutls instead of openssl.
+REQUIRED_USE="xmpp? ( ssl gnutls )"
+
+RDEPEND="
+ xmpp? (
+ || (
+ >=dev-libs/iksemel-1.4[ssl]
+ >=dev-libs/iksemel-1.3[gnutls]
+ )
+ )
+ ssl? (
+ gnutls? (
+ >=net-libs/gnutls-0.8.10
+ dev-libs/libgcrypt:0
+ )
+ !gnutls? ( dev-libs/openssl )
+ )
+ tcl? ( dev-lang/tcl:0 )
+ otr? ( <net-libs/libotr-4 )"
+DEPEND="${RDEPEND}
+ ssl? ( gnutls? ( virtual/pkgconfig ) )"
+
+src_configure() {
+ local myconf
+ if use ssl; then
+ if use gnutls; then
+ einfo "Using gnutls"
+ myconf="--enable-ssl=gnutls"
+ else
+ einfo "Using openSSL"
+ myconf="--enable-ssl=openssl"
+ fi
+ else
+ myconf="--disable-ssl"
+ fi
+
+ econf \
+ $(use_enable xmpp) \
+ $(use_enable otr) \
+ $(use_enable tcl) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog FAQ NEWS README TODO
+}
diff --git a/net-im/climm/metadata.xml b/net-im/climm/metadata.xml
new file mode 100644
index 000000000000..923f5d919afc
--- /dev/null
+++ b/net-im/climm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-im</herd>
+<use>
+ <flag name='otr'>Enable encrypted conversations</flag>
+</use>
+</pkgmetadata>