summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/cpop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/cpop')
-rw-r--r--net-im/cpop/Manifest1
-rw-r--r--net-im/cpop/cpop-0.0.4-r1.ebuild28
-rw-r--r--net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch38
-rw-r--r--net-im/cpop/metadata.xml5
4 files changed, 72 insertions, 0 deletions
diff --git a/net-im/cpop/Manifest b/net-im/cpop/Manifest
new file mode 100644
index 000000000000..54df7ecf2161
--- /dev/null
+++ b/net-im/cpop/Manifest
@@ -0,0 +1 @@
+DIST cpop-0.0.4.tar.gz 68544 SHA256 68855387c20ce2adaf5a51464b68fc756acfe197ab9b53dbde910757526f45a8 SHA512 c7f4dbff7f8702a8a32447c09457fa6f0810768a41450c43ae71aa67c6fb2d40af634713d1a703dd7f1a9a97ac534f2dab11f8f3f88a79c549224e8b375d721a WHIRLPOOL 20bd2fc1b9d4e4e4d794a917861fc66dd90ebadf01fb8ab1531715beb05ce3504a381aa6623955fde1dc0fda1ef5a8026823124720b1d6b144e93a9e0f33c674
diff --git a/net-im/cpop/cpop-0.0.4-r1.ebuild b/net-im/cpop/cpop-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..5511135a08e0
--- /dev/null
+++ b/net-im/cpop/cpop-0.0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="GTK+ network popup message client. Compatible with the jpop protocol"
+HOMEPAGE="http://www.draxil.uklinux.net/hip/index.pl?page=cpop"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-implicit-exit_memset_strlen.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+}
diff --git a/net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch b/net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch
new file mode 100644
index 000000000000..3ce224c2910a
--- /dev/null
+++ b/net-im/cpop/files/cpop-0.0.4-implicit-exit_memset_strlen.patch
@@ -0,0 +1,38 @@
+pop_common.c:5:3: warning: incompatible implicit declaration of built-in function ‘exit’
+pop_common.c:10:3: warning: incompatible implicit declaration of built-in function ‘exit’
+pop_client.c:61:3: warning: incompatible implicit declaration of built-in function ‘exit’
+pop_gui_client.c:58:4: warning: incompatible implicit declaration of built-in function ‘memset’
+pop_gui_client.c:72:27: warning: incompatible implicit declaration of built-in function ‘strlen’
+pop_gui_client.c:128:3: warning: incompatible implicit declaration of built-in function ‘exit’
+
+--- pop_client.c
++++ pop_client.c
+@@ -1,11 +1,11 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <errno.h>
+ #include <glib.h>
+-#include <stdio.h>
+ #include <netdb.h>
+ #include "pop_common.h"
+ #include "pop_client.h"
+--- pop_common.c
++++ pop_common.c
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ void errquit(char *message)
+ {
+ perror(message);
+--- pop_gui_client.c
++++ pop_gui_client.c
+@@ -1,3 +1,5 @@
++#include <stdlib.h>
++#include <string.h>
+ #include <netdb.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
diff --git a/net-im/cpop/metadata.xml b/net-im/cpop/metadata.xml
new file mode 100644
index 000000000000..3e2b4181f5be
--- /dev/null
+++ b/net-im/cpop/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-im</herd>
+</pkgmetadata>