summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-02-20 10:56:05 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-02-20 10:56:31 +0000
commitac688e86083db94f0461d6ccb3ec5c3de25d084e (patch)
treeeabdd51c1e87343b35266b63fd01d539bad52f95 /net-im/dino
parentprefix/darwin/macos/arch/ppc/package.mask: drop gcc-8 mask (diff)
downloadgentoo-ac688e86083db94f0461d6ccb3ec5c3de25d084e.tar.gz
gentoo-ac688e86083db94f0461d6ccb3ec5c3de25d084e.tar.bz2
gentoo-ac688e86083db94f0461d6ccb3ec5c3de25d084e.zip
net-im/dino: specify valac for build system to use
Before, dino's cmake scripts just searched for unversioned valac, and versioned ones with versions in the range 0.32 - 0.38. There are good reasons to let Portage decide which valac to use. * Now we have 0.40 and 0.42 in Gentoo tree. These are not detected by dino build system (bug 678402). * Allow users to override valac version uniformly across Gentoo with VALAC envvar. Suggested-by: Daniel Kenzelmann <gentoo@k8n.de> Bug: https://bugs.gentoo.org/678402 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'net-im/dino')
-rw-r--r--net-im/dino/dino-9999.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
index bbf506d8456..80ecc7fbd0b 100644
--- a/net-im/dino/dino-9999.ebuild
+++ b/net-im/dino/dino-9999.ebuild
@@ -47,6 +47,7 @@ DEPEND="
src_prepare() {
cmake-utils_src_prepare
+ vala_src_prepare
}
src_configure() {
@@ -57,6 +58,7 @@ src_configure() {
)
local mycmakeargs+=(
"-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
+ "-DVALA_EXECUTABLE=${VALAC}"
)
if has test ${FEATURES}; then