summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:48:46 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:37 +0100
commit21a42a5a0e331b110ea9857ac0c29199489f7cee (patch)
tree90c970a5d41913b2d9202036f3465d948dc2a8ab /net-im/gajim
parentnet-analyzer/net-snmp: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-21a42a5a0e331b110ea9857ac0c29199489f7cee.tar.gz
gentoo-21a42a5a0e331b110ea9857ac0c29199489f7cee.tar.bz2
gentoo-21a42a5a0e331b110ea9857ac0c29199489f7cee.zip
net-im/gajim: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/gajim-1.0.3-r1.ebuild78
-rw-r--r--net-im/gajim/gajim-1.0.3-r2.ebuild80
-rw-r--r--net-im/gajim/gajim-1.0.3-r3.ebuild80
-rw-r--r--net-im/gajim/gajim-1.0.3.ebuild78
-rw-r--r--net-im/gajim/gajim-1.1.3-r1.ebuild88
-rw-r--r--net-im/gajim/gajim-1.1.3.ebuild86
6 files changed, 248 insertions, 242 deletions
diff --git a/net-im/gajim/gajim-1.0.3-r1.ebuild b/net-im/gajim/gajim-1.0.3-r1.ebuild
deleted file mode 100644
index e8d7bd3df207..000000000000
--- a/net-im/gajim/gajim-1.0.3-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite,xml"
-DISTUTILS_SINGLE_IMPL=1
-
-inherit gnome2-utils distutils-r1 versionator xdg-utils
-
-DESCRIPTION="Jabber client written in PyGTK"
-HOMEPAGE="https://www.gajim.org/"
-SRC_URI="https://www.gajim.org/downloads/$(get_version_component_range 1-2)/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-#KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-KEYWORDS="~amd64 ~x86"
-IUSE="+crypt geolocation jingle keyring networkmanager remote rst +spell upnp
- +webp"
-
-COMMON_DEPEND="
- dev-libs/gobject-introspection[cairo]
- >=x11-libs/gtk+-3.22:3[introspection]"
-DEPEND="${COMMON_DEPEND}
- app-arch/unzip
- >=dev-util/intltool-0.40.1
- virtual/pkgconfig
- >=sys-devel/gettext-0.17-r1"
-RDEPEND="${COMMON_DEPEND}
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/precis-i18n[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pycurl[${PYTHON_USEDEP}]
- dev-python/pygobject[cairo,${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
- >=dev-python/python-nbxmpp-0.6.6[${PYTHON_USEDEP}]
- x11-libs/libXScrnSaver
- crypt? (
- dev-python/pycryptodome[${PYTHON_USEDEP}]
- >=dev-python/python-gnupg-0.4.0[${PYTHON_USEDEP}] )
- geolocation? ( app-misc/geoclue[introspection] )
- jingle? (
- net-libs/farstream:0.2[introspection]
- media-libs/gstreamer:1.0[introspection]
- media-libs/gst-plugins-base:1.0[introspection]
- media-libs/gst-plugins-ugly:1.0
- )
- keyring? (
- app-crypt/libsecret[crypt,introspection]
- dev-python/keyring[${PYTHON_USEDEP}]
- )
- networkmanager? ( net-misc/networkmanager[introspection] )
- remote? (
- >=dev-python/dbus-python-1.2.0[${PYTHON_USEDEP}]
- sys-apps/dbus[X]
- )
- rst? ( dev-python/docutils[${PYTHON_USEDEP}] )
- spell? (
- app-text/gspell[introspection]
- app-text/hunspell
- )
- upnp? ( net-libs/gupnp-igd[introspection] )
- webp? ( dev-python/pillow[${PYTHON_USEDEP}] )"
-
-RESTRICT="test"
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
diff --git a/net-im/gajim/gajim-1.0.3-r2.ebuild b/net-im/gajim/gajim-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..ecd507a5add9
--- /dev/null
+++ b/net-im/gajim/gajim-1.0.3-r2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite,xml"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit gnome2-utils distutils-r1 versionator xdg-utils
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="https://www.gajim.org/"
+SRC_URI="https://www.gajim.org/downloads/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+#KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 x86"
+IUSE="+crypt geolocation jingle keyring networkmanager remote rst +spell upnp
+ +webp"
+
+COMMON_DEPEND="
+ dev-libs/gobject-introspection[cairo]
+ >=x11-libs/gtk+-3.22:3[introspection]"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+ >=dev-util/intltool-0.40.1
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17-r1"
+RDEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/idna[${PYTHON_MULTI_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyasn1[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycurl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject[cairo,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/python-nbxmpp-0.6.6[${PYTHON_MULTI_USEDEP}]
+ x11-libs/libXScrnSaver
+ crypt? (
+ dev-python/pycryptodome[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/python-gnupg-0.4.0[${PYTHON_MULTI_USEDEP}] )
+ geolocation? ( app-misc/geoclue[introspection] )
+ jingle? (
+ net-libs/farstream:0.2[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/gst-plugins-ugly:1.0
+ )
+ keyring? (
+ app-crypt/libsecret[crypt,introspection]
+ dev-python/keyring[${PYTHON_MULTI_USEDEP}]
+ )
+ networkmanager? ( net-misc/networkmanager[introspection] )
+ remote? (
+ >=dev-python/dbus-python-1.2.0[${PYTHON_MULTI_USEDEP}]
+ sys-apps/dbus[X]
+ )
+ rst? ( dev-python/docutils[${PYTHON_MULTI_USEDEP}] )
+ spell? (
+ app-text/gspell[introspection]
+ app-text/hunspell
+ )
+ upnp? ( net-libs/gupnp-igd[introspection] )
+ webp? ( dev-python/pillow[${PYTHON_MULTI_USEDEP}] )
+ ')"
+
+RESTRICT="test"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/net-im/gajim/gajim-1.0.3-r3.ebuild b/net-im/gajim/gajim-1.0.3-r3.ebuild
new file mode 100644
index 000000000000..6bda29b9abd0
--- /dev/null
+++ b/net-im/gajim/gajim-1.0.3-r3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite,xml"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit gnome2-utils distutils-r1 versionator xdg-utils
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="https://www.gajim.org/"
+SRC_URI="https://www.gajim.org/downloads/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+#KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~x86"
+IUSE="+crypt geolocation jingle keyring networkmanager remote rst +spell upnp
+ +webp"
+
+COMMON_DEPEND="
+ dev-libs/gobject-introspection[cairo]
+ >=x11-libs/gtk+-3.22:3[introspection]"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+ >=dev-util/intltool-0.40.1
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17-r1"
+RDEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/idna[${PYTHON_MULTI_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyasn1[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycurl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject[cairo,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/python-nbxmpp-0.6.6[${PYTHON_MULTI_USEDEP}]
+ x11-libs/libXScrnSaver
+ crypt? (
+ dev-python/pycryptodome[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/python-gnupg-0.4.0[${PYTHON_MULTI_USEDEP}] )
+ geolocation? ( app-misc/geoclue[introspection] )
+ jingle? (
+ net-libs/farstream:0.2[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/gst-plugins-ugly:1.0
+ )
+ keyring? (
+ app-crypt/libsecret[crypt,introspection]
+ dev-python/keyring[${PYTHON_MULTI_USEDEP}]
+ )
+ networkmanager? ( net-misc/networkmanager[introspection] )
+ remote? (
+ >=dev-python/dbus-python-1.2.0[${PYTHON_MULTI_USEDEP}]
+ sys-apps/dbus[X]
+ )
+ rst? ( dev-python/docutils[${PYTHON_MULTI_USEDEP}] )
+ spell? (
+ app-text/gspell[introspection]
+ app-text/hunspell
+ )
+ upnp? ( net-libs/gupnp-igd[introspection] )
+ webp? ( dev-python/pillow[${PYTHON_MULTI_USEDEP}] )
+ ')"
+
+RESTRICT="test"
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/net-im/gajim/gajim-1.0.3.ebuild b/net-im/gajim/gajim-1.0.3.ebuild
deleted file mode 100644
index 373bb4d2f1ae..000000000000
--- a/net-im/gajim/gajim-1.0.3.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite,xml"
-DISTUTILS_SINGLE_IMPL=1
-
-inherit gnome2-utils distutils-r1 versionator xdg-utils
-
-DESCRIPTION="Jabber client written in PyGTK"
-HOMEPAGE="https://www.gajim.org/"
-SRC_URI="https://www.gajim.org/downloads/$(get_version_component_range 1-2)/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-#KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-KEYWORDS="amd64 x86"
-IUSE="+crypt geolocation jingle keyring networkmanager remote rst +spell upnp
- +webp"
-
-COMMON_DEPEND="
- dev-libs/gobject-introspection[cairo]
- >=x11-libs/gtk+-3.22:3[introspection]"
-DEPEND="${COMMON_DEPEND}
- app-arch/unzip
- >=dev-util/intltool-0.40.1
- virtual/pkgconfig
- >=sys-devel/gettext-0.17-r1"
-RDEPEND="${COMMON_DEPEND}
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/precis-i18n[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pycurl[${PYTHON_USEDEP}]
- dev-python/pygobject[cairo,${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
- >=dev-python/python-nbxmpp-0.6.6[${PYTHON_USEDEP}]
- x11-libs/libXScrnSaver
- crypt? (
- dev-python/pycryptodome[${PYTHON_USEDEP}]
- >=dev-python/python-gnupg-0.4.0[${PYTHON_USEDEP}] )
- geolocation? ( app-misc/geoclue[introspection] )
- jingle? (
- net-libs/farstream:0.2[introspection]
- media-libs/gstreamer:1.0[introspection]
- media-libs/gst-plugins-base:1.0[introspection]
- media-libs/gst-plugins-ugly:1.0
- )
- keyring? (
- app-crypt/libsecret[crypt,introspection]
- dev-python/keyring[${PYTHON_USEDEP}]
- )
- networkmanager? ( net-misc/networkmanager[introspection] )
- remote? (
- >=dev-python/dbus-python-1.2.0[${PYTHON_USEDEP}]
- sys-apps/dbus[X]
- )
- rst? ( dev-python/docutils[${PYTHON_USEDEP}] )
- spell? (
- app-text/gspell[introspection]
- app-text/hunspell
- )
- upnp? ( net-libs/gupnp-igd[introspection] )
- webp? ( dev-python/pillow[${PYTHON_USEDEP}] )"
-
-RESTRICT="test"
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
diff --git a/net-im/gajim/gajim-1.1.3-r1.ebuild b/net-im/gajim/gajim-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..cfa793c7bc50
--- /dev/null
+++ b/net-im/gajim/gajim-1.1.3-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="sqlite,xml"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="https://www.gajim.org/"
+SRC_URI="https://www.gajim.org/downloads/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+#KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~x86"
+IUSE="+crypt geolocation jingle networkmanager remote rst +spell upnp
+ +webp"
+
+COMMON_DEPEND="
+ dev-libs/gobject-introspection[cairo]
+ >=x11-libs/gtk+-3.22:3[introspection]"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+ >=dev-util/intltool-0.40.1
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17-r1"
+RDEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/idna[${PYTHON_MULTI_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyasn1[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycurl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject[cairo,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/python-nbxmpp-0.6.9[${PYTHON_MULTI_USEDEP}]
+ x11-libs/libXScrnSaver
+ app-crypt/libsecret[crypt,introspection]
+ dev-python/keyring[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/secretstorage-3.1.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/cssutils-1.0.2[${PYTHON_MULTI_USEDEP}]
+ crypt? (
+ dev-python/pycryptodome[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/python-gnupg-0.4.0[${PYTHON_MULTI_USEDEP}] )
+ geolocation? ( app-misc/geoclue[introspection] )
+ jingle? (
+ net-libs/farstream:0.2[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/gst-plugins-ugly:1.0
+ )
+ networkmanager? ( net-misc/networkmanager[introspection] )
+ remote? (
+ >=dev-python/dbus-python-1.2.0[${PYTHON_MULTI_USEDEP}]
+ sys-apps/dbus[X]
+ )
+ rst? ( dev-python/docutils[${PYTHON_MULTI_USEDEP}] )
+ spell? (
+ app-text/gspell[introspection]
+ app-text/hunspell
+ )
+ upnp? ( net-libs/gupnp-igd[introspection] )
+ webp? ( dev-python/pillow[${PYTHON_MULTI_USEDEP}] )
+ ')"
+
+RESTRICT="test"
+
+src_install() {
+ distutils-r1_src_install
+
+ # avoid precompressed man pages
+ rm -r "${D}/usr/share/man"
+ doman data/*.1
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/net-im/gajim/gajim-1.1.3.ebuild b/net-im/gajim/gajim-1.1.3.ebuild
deleted file mode 100644
index e8d0781880c4..000000000000
--- a/net-im/gajim/gajim-1.1.3.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="sqlite,xml"
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="Jabber client written in PyGTK"
-HOMEPAGE="https://www.gajim.org/"
-SRC_URI="https://www.gajim.org/downloads/$(ver_cut 1-2)/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-#KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-KEYWORDS="~amd64 ~x86"
-IUSE="+crypt geolocation jingle networkmanager remote rst +spell upnp
- +webp"
-
-COMMON_DEPEND="
- dev-libs/gobject-introspection[cairo]
- >=x11-libs/gtk+-3.22:3[introspection]"
-DEPEND="${COMMON_DEPEND}
- app-arch/unzip
- >=dev-util/intltool-0.40.1
- virtual/pkgconfig
- >=sys-devel/gettext-0.17-r1"
-RDEPEND="${COMMON_DEPEND}
- dev-python/idna[${PYTHON_USEDEP}]
- dev-python/precis-i18n[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pycurl[${PYTHON_USEDEP}]
- dev-python/pygobject[cairo,${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
- >=dev-python/python-nbxmpp-0.6.9[${PYTHON_USEDEP}]
- x11-libs/libXScrnSaver
- app-crypt/libsecret[crypt,introspection]
- dev-python/keyring[${PYTHON_USEDEP}]
- >=dev-python/secretstorage-3.1.1[${PYTHON_USEDEP}]
- >=dev-python/cssutils-1.0.2[${PYTHON_USEDEP}]
- crypt? (
- dev-python/pycryptodome[${PYTHON_USEDEP}]
- >=dev-python/python-gnupg-0.4.0[${PYTHON_USEDEP}] )
- geolocation? ( app-misc/geoclue[introspection] )
- jingle? (
- net-libs/farstream:0.2[introspection]
- media-libs/gstreamer:1.0[introspection]
- media-libs/gst-plugins-base:1.0[introspection]
- media-libs/gst-plugins-ugly:1.0
- )
- networkmanager? ( net-misc/networkmanager[introspection] )
- remote? (
- >=dev-python/dbus-python-1.2.0[${PYTHON_USEDEP}]
- sys-apps/dbus[X]
- )
- rst? ( dev-python/docutils[${PYTHON_USEDEP}] )
- spell? (
- app-text/gspell[introspection]
- app-text/hunspell
- )
- upnp? ( net-libs/gupnp-igd[introspection] )
- webp? ( dev-python/pillow[${PYTHON_USEDEP}] )"
-
-RESTRICT="test"
-
-src_install() {
- distutils-r1_src_install
-
- # avoid precompressed man pages
- rm -r "${D}/usr/share/man"
- doman data/*.1
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}