summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2021-03-05 10:01:49 +0100
committerHanno Böck <hanno@gentoo.org>2021-03-05 10:02:19 +0100
commitfc5e43321c8e451eecb00cd7e5d324184e3e5073 (patch)
tree9dedc1f29d014d057f19c96214778e6c4be44316 /net-im/gajim
parentnet-analyzer/wapiti: 3.0.4 bump, add Python 3.9 (diff)
downloadgentoo-fc5e43321c8e451eecb00cd7e5d324184e3e5073.tar.gz
gentoo-fc5e43321c8e451eecb00cd7e5d324184e3e5073.tar.bz2
gentoo-fc5e43321c8e451eecb00cd7e5d324184e3e5073.zip
net-im/gajim: Version bump
Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.16, Repoman-3.0.2
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/Manifest1
-rw-r--r--net-im/gajim/gajim-1.3.1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-im/gajim/Manifest b/net-im/gajim/Manifest
index 6dfe55086c30..6b9094fdcf70 100644
--- a/net-im/gajim/Manifest
+++ b/net-im/gajim/Manifest
@@ -1,3 +1,4 @@
DIST gajim-1.2.1.tar.gz 9421625 BLAKE2B 890c4ac30506a771a3158f46c687723aacfed5fe7b7da3984e8de7354d8a448508cf98e5b224060078571bb27eecb2bb74927d610dae23709a522d77bb018961 SHA512 1a1ebc3a0605a12b5f459c576037359543814686a170199148e44e409d4f054cefdb66505e68ed4c28bd8c64a7910a70301c2d90d1d4b31b9587d9126329e8c4
DIST gajim-1.2.2.tar.gz 9416794 BLAKE2B ab1dd2997422175bb7591bc11b230c47f9b72326fbf5b652ae15710bb46798ac8a1514dc2e1361e89bef4a80f43d5f64cf09879f3faffa927aa4407fe696b564 SHA512 297afa2b0ac44aad59b203907b1479fb8f004e2dc2a00681fa8034d76e4fb89ee3dcb4fb96011028382659bcb978cf214c396073d29b3dd0a7a711454915057b
DIST gajim-1.3.0.tar.gz 9886259 BLAKE2B c9d0912f4d2cb76668978ca48fb1bc2db203cae7ea8dba7fd03c40d1cfee3da84131e2cd82ed6b27ed4c9a70a37328c57551fe1190e29bbd0c9a3cd6f9fa4a66 SHA512 4b68b97f6e4edcc2aa4b009a0131e4781c4ca52340ce98369154c602f7ee71e974e0840af0ae6ab28fc9e2fd34433ec0f304e10847e6cc257de3cde60b90b349
+DIST gajim-1.3.1.tar.gz 9885129 BLAKE2B ee1fac7f1354576879c5ef14d167d4f7248e497f5b7c468d4bdeb9bf93b749482e221e4ad7a965c86799baa959020303b1b3e49ca99ce1607fc721d0722cbffd SHA512 840b9424c4f93281fe32569331917ba3bdd0afc51428d778ec357b1b0dfc9aecdf77a48c44fa4b66259d82633ca277ccab6b4d6ead47e7eb66d22f078e8ebb84
diff --git a/net-im/gajim/gajim-1.3.1.ebuild b/net-im/gajim/gajim-1.3.1.ebuild
new file mode 100644
index 000000000000..3e2cb3f1105e
--- /dev/null
+++ b/net-im/gajim/gajim-1.3.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="sqlite,xml"
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="https://gajim.org/"
+SRC_URI="https://gajim.org/downloads/$(ver_cut 1-2)/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+crypt geolocation jingle remote rst +spell upnp +webp"
+S="${WORKDIR}/${PN}-${P}"
+
+COMMON_DEPEND="
+ dev-libs/gobject-introspection[cairo(+)]
+ >=x11-libs/gtk+-3.22:3[introspection]"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+ >=dev-util/intltool-0.40.1
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17-r1"
+RDEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/python-nbxmpp-2.0.2[${PYTHON_USEDEP}]
+ x11-libs/libXScrnSaver
+ app-crypt/libsecret[crypt,introspection]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ >=dev-python/secretstorage-3.1.1[${PYTHON_USEDEP}]
+ dev-python/css-parser[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ net-libs/libsoup[introspection]
+ media-libs/gsound[introspection]
+ crypt? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/python-gnupg-0.4.0[${PYTHON_USEDEP}] )
+ geolocation? ( app-misc/geoclue[introspection] )
+ jingle? (
+ net-libs/farstream:0.2[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/gst-plugins-ugly:1.0
+ )
+ remote? (
+ >=dev-python/dbus-python-1.2.0[${PYTHON_USEDEP}]
+ sys-apps/dbus[X]
+ )
+ rst? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ spell? (
+ app-text/gspell[introspection]
+ app-text/hunspell
+ )
+ upnp? ( net-libs/gupnp-igd[introspection] )
+ webp? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ')"
+
+src_install() {
+ distutils-r1_src_install
+
+ # avoid precompressed man pages
+ rm -r "${D}/usr/share/man"
+ doman data/*.1
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}