summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-01-13 18:07:24 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-01-13 18:07:36 +0100
commit8152eb0f238d49407a6c567f76a67f19f3a5b173 (patch)
treea30100d3b93a1abc611a37c31dbb2cab4f9b2027 /net-im/prosody
parentsci-mathematics/why3: add missing latex dependencies (diff)
downloadgentoo-8152eb0f238d49407a6c567f76a67f19f3a5b173.tar.gz
gentoo-8152eb0f238d49407a6c567f76a67f19f3a5b173.tar.bz2
gentoo-8152eb0f238d49407a6c567f76a67f19f3a5b173.zip
net-im/prosody: add 0.11.12
Bug: https://bugs.gentoo.org/831140 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im/prosody')
-rw-r--r--net-im/prosody/Manifest1
-rw-r--r--net-im/prosody/prosody-0.11.12.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index 3a2882c40b55..d04f6a5349f4 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -1,2 +1,3 @@
DIST prosody-0.11.10.tar.gz 438888 BLAKE2B 590f97f4eb8a333701eca516de3c3bcee9cf093267d2000af03b48d32396a1be21a0cf2f8ff542e7fbcb8419138bab5cf411f71b17666593559004a8a9674367 SHA512 419d8f8465f1807015f0a52d8f35ee89892b0869084dae38b60fc833d63c3d70892d8e59ae00039cd15e0e25f46d042954896f51f8c0520650a877f5296707cb
DIST prosody-0.11.11.tar.gz 439395 BLAKE2B d9662ff9e5a767aaee86c2b0762249c702e755191359ee276f37019ac98fab52d75a23590f0c3a14f3bfde356cc2bd9802e842e1f1a7ea5da8ec3d034fa028a0 SHA512 eb9851e1b279bef894d556ca6bc6210d1cd55e0c02a9d475f74e6e6b4a2dfef704fd3de77b71cff97909925c48c60940c34cfb541e6f3801e23e90ea21d119a9
+DIST prosody-0.11.12.tar.gz 439656 BLAKE2B 593bb24d7e84ed337e8d8a11b387ac50abd27ea62be0fd18e8c8441472c09565a6603ccb070250b620b3f50f4d1e33fad579f988e68250c083b8a9aa25a8e03b SHA512 cd03ee8b02ffaa478b5329d9942d833cfed2d8bf720bf580a2082d681e7d333bc34f45041cea7234bee75f1a0e7c07983a685fe2ac9b31d51a0dbb36e87ba5d2
diff --git a/net-im/prosody/prosody-0.11.12.ebuild b/net-im/prosody/prosody-0.11.12.ebuild
new file mode 100644
index 000000000000..9a4dc0782f50
--- /dev/null
+++ b/net-im/prosody/prosody-0.11.12.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+LUA_REQ_USE="deprecated(+)"
+
+inherit lua-single systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="Prosody is a modern XMPP communication server"
+HOMEPAGE="https://prosody.im/"
+SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="icu +idn +libevent mysql postgres selinux +sqlite +ssl test +zlib"
+REQUIRED_USE="
+ ^^ ( icu idn )
+ ${LUA_REQUIRED_USE}
+"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ $(lua_gen_cond_dep 'dev-lua/luaexpat[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/luafilesystem[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/luasocket[${LUA_USEDEP}]')
+ net-im/jabber-base
+ icu? ( dev-libs/icu:= )
+ idn? ( net-dns/libidn:= )
+ libevent? ( $(lua_gen_cond_dep 'dev-lua/luaevent[${LUA_USEDEP}]') )
+ dev-libs/openssl:0=
+ lua_single_target_lua5-1? ( $(lua_gen_cond_dep 'dev-lua/lua-bit32[lua_targets_lua5-1(-)]') )
+ mysql? ( $(lua_gen_cond_dep 'dev-lua/luadbi[mysql,${LUA_USEDEP}]') )
+ postgres? ( $(lua_gen_cond_dep 'dev-lua/luadbi[postgres,${LUA_USEDEP}]') )
+ sqlite? ( $(lua_gen_cond_dep 'dev-lua/luadbi[sqlite,${LUA_USEDEP}]') )
+ ssl? ( $(lua_gen_cond_dep 'dev-lua/luasec[${LUA_USEDEP}]') )
+ zlib? ( $(lua_gen_cond_dep 'dev-lua/lua-zlib[${LUA_USEDEP}]') )
+ ${LUA_DEPS}
+"
+
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-jabber )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]') )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.11.7-gentoo.patch" )
+
+src_prepare() {
+ default
+
+ # Set correct plugin path for optional net-im/prosody-modules package
+ sed -e "s/GENTOO_LIBDIR/$(get_libdir)/g" -i prosody.cfg.lua.dist || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --add-cflags="${CFLAGS}"
+ --add-ldflags="${LDFLAGS}"
+ --c-compiler="$(tc-getCC)"
+ --datadir="${EPREFIX}/var/spool/jabber"
+ --idn-library="$(usex idn 'idn' 'icu')"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --linker="$(tc-getCC)"
+ --lua-version="$(usex lua_single_target_luajit '5.1' $(ver_cut 1-2 $(lua_get_version)))"
+ --no-example-certs
+ --ostype="linux"
+ --prefix="${EPREFIX}/usr"
+ --runwith="${ELUA}"
+ --sysconfdir="${EPREFIX}/etc/jabber"
+ --with-lua-include="${EPREFIX}/$(lua_get_include_dir)"
+ --with-lua-lib="${EPREFIX}/$(lua_get_cmod_dir)"
+ )
+
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure "${myeconfargs[@]}" || die
+
+ rm makefile || die
+ mv GNUmakefile Makefile || die
+}
+
+src_install() {
+ default
+
+ keepdir /var/spool/jabber
+
+ newinitd "${FILESDIR}"/prosody.initd-r5 prosody
+ systemd_newunit "${FILESDIR}"/prosody.service-r2 prosody.service
+
+ newtmpfiles "${FILESDIR}"/prosody.tmpfilesd-r1 prosody.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process prosody.conf
+}