summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-28 12:31:15 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-28 12:31:43 +0100
commitccf3bf5d44b4aa8c46e5207e6f83bbc3560d512e (patch)
tree5f1b0a051eb266f61e9e8bc340b6d8d973b8a4e0 /net-im/rocketchat-desktop-bin
parentdev-python/pytest-httpbin: Bump to 1.0.1 (diff)
downloadgentoo-ccf3bf5d44b4aa8c46e5207e6f83bbc3560d512e.tar.gz
gentoo-ccf3bf5d44b4aa8c46e5207e6f83bbc3560d512e.tar.bz2
gentoo-ccf3bf5d44b4aa8c46e5207e6f83bbc3560d512e.zip
net-im/rocketchat-desktop-bin: add version 3.7.3
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im/rocketchat-desktop-bin')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index f50de2ac8795..a3b9d5b04837 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.7.2.x86_64.rpm 72045336 BLAKE2B 7c40abf16fa9a5d45809bb142f491da35b8bd0096b66b966e4e6a63520e6b4387aed6cbfeefc9ccdd1806171cb6e71259833c3691a88c3093cb8465e74d4672c SHA512 bcf94c6b0c1fbf1ae0c2c57609865a3b849283315c0e60682926cbc49eb556d144358e3c1d3792ae5f901ed7cef992f0f868c4338b9418fc6d37d0e99168778f
+DIST rocketchat-3.7.3.x86_64.rpm 72060836 BLAKE2B 4d7760c954a9e9f75440bb27a2a3b60dc788a72da2e20a64d3231684ec1f465657448426b26c3e261de6f6a06a60ecb072325e00b334258211ade2ed4532095b SHA512 b88f49a567460f6b6ec6c4dc809a0bdc6dbe14194841e85b4a7136113ccf504b020a36fd489ee0b859bacb0d5555b29ff55cf8cf32b2c11f60f79b37550a4535
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.3.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.3.ebuild
new file mode 100644
index 000000000000..46fc3d26d958
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}