summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-20 11:23:07 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-03-20 11:23:07 +0100
commite5021697e801c6eed9e8ecf53597876302c7e5a8 (patch)
treef683ac4c23c4e65df38917d0ad2f0199e38f664d /net-im/rocketchat-desktop-bin
parentwww-servers/adsf: add ruby30; EAPI 8 (diff)
downloadgentoo-e5021697e801c6eed9e8ecf53597876302c7e5a8.tar.gz
gentoo-e5021697e801c6eed9e8ecf53597876302c7e5a8.tar.bz2
gentoo-e5021697e801c6eed9e8ecf53597876302c7e5a8.zip
net-im/rocketchat-desktop-bin: add 3.8.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im/rocketchat-desktop-bin')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 3a9a696ec86f..46fc6c2cb037 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.7.9.x86_64.rpm 62177412 BLAKE2B 0acb4fb3c36e758073e81cfe41a2a2b184091e22ce9bf92290c9df6ba5c73da8bdd8525829d6b5795ed4c7910eb26aa761c08ec8f9efc84b6ec94182dc0ccd3d SHA512 6e1a65723ed7e419d94d58bb71d35596a0d261d92f1bcb56cc9341b3108714c4d9ff0e09982bfafd26e42e0ba48a6e7a181f4cfdb630f59659e6823c8aa9b39c
+DIST rocketchat-3.8.0.x86_64.rpm 62219204 BLAKE2B 60c6a1d46138007da82214347790d5fce2cd8e8616ec0fa1d1344f064ab58281843c6692830f8a860cfb6e4ab4f41a5b2ad3bcde928c133e694b2c4fe365d885 SHA512 68b0a1c455b7d3c68bafcf2007470d89301a17b922b61cc3d1b38485235120aeacc449157f76b1629971c4329fb12244d23fb6a0b22a77082da6e37a24b6141e
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.0.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.0.ebuild
new file mode 100644
index 000000000000..194a95979a80
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Rocket.Chat/*"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}