summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-27 14:42:56 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-27 14:42:56 +0100
commit4b2b84a7d4d69c914746c0ad9f199d98fbcb765c (patch)
tree1e5ceb36b0064806f89f46995af566e183f8f8ac /net-im/simpserver-bin
parentnet-im/qwit: EAPI bump (diff)
downloadgentoo-4b2b84a7d4d69c914746c0ad9f199d98fbcb765c.tar.gz
gentoo-4b2b84a7d4d69c914746c0ad9f199d98fbcb765c.tar.bz2
gentoo-4b2b84a7d4d69c914746c0ad9f199d98fbcb765c.zip
net-im/simpserver-bin: EAPI bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-im/simpserver-bin')
-rw-r--r--net-im/simpserver-bin/simpserver-bin-2.1.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-im/simpserver-bin/simpserver-bin-2.1.0-r1.ebuild b/net-im/simpserver-bin/simpserver-bin-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..e7f2955c5a15
--- /dev/null
+++ b/net-im/simpserver-bin/simpserver-bin-2.1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=${PN/-bin/}
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SimpServer for Unix: IM instant security transparent proxy"
+SRC_URI="http://download.secway.com/public/products/simpserver/${MY_P}-linux-x86.tgz"
+HOMEPAGE="http://www.secway.com/"
+LICENSE="simpserver-test"
+
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+SLOT="0"
+S=${WORKDIR}/simp
+
+RESTRICT="strip"
+
+src_compile() {
+ einfo "Binary distribution. No compilation required."
+}
+
+src_install () {
+ dodoc README VERSION doc/CONFIG doc/TODO
+
+ exeinto /opt/bin
+ doexe bin/${MY_PN}
+
+ insinto /etc
+ doins etc/simp.conf
+
+ newinitd "${FILESDIR}/${MY_PN}".rc ${MY_PN}
+}
+
+pkg_postinst() {
+ elog "Please edit the configuration file: /etc/simp.conf."
+}