summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2018-02-06 18:31:07 +0200
committerMichał Górny <mgorny@gentoo.org>2018-02-09 10:31:36 +0100
commitf4e5de720dd63b6c4ea7c0e650bd7f20b3bcf772 (patch)
tree1e2eab80b0d5dac21677cc7478c902df6ebce7df /net-im/slack-bin
parentapp-admin/apachetop: Fixing source URI (diff)
downloadgentoo-f4e5de720dd63b6c4ea7c0e650bd7f20b3bcf772.tar.gz
gentoo-f4e5de720dd63b6c4ea7c0e650bd7f20b3bcf772.tar.bz2
gentoo-f4e5de720dd63b6c4ea7c0e650bd7f20b3bcf772.zip
net-im/slack-bin: version bump to 3.0.5 with security update
Security update was in relation with CVE-2017-5754 (Meltdown) and CVE-2017-5753 (Spectre) Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-im/slack-bin')
-rw-r--r--net-im/slack-bin/Manifest1
-rw-r--r--net-im/slack-bin/slack-bin-3.0.5.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/net-im/slack-bin/Manifest b/net-im/slack-bin/Manifest
index 2fb6f2c4536a..e0ecba8835d1 100644
--- a/net-im/slack-bin/Manifest
+++ b/net-im/slack-bin/Manifest
@@ -5,3 +5,4 @@ DIST slack-desktop-2.6.3-amd64.deb 51434914 BLAKE2B 7924e0e220c97946a5e1eb944e9e
DIST slack-desktop-2.8.0-amd64.deb 51225854 BLAKE2B 746a11d85941272c53a9c7d2433c2801fb880e6d59bf2ee1599597650a3ce59369e04b15c51af28c1e90e3375f9b9fcc88a1bf9cfc130472faafa2b7b8809be5 SHA512 9a3a8c4eec95583cde76003e99679dda9d6e44692258242bef888043666d589da8a7a5d68898f61e645a6810291ef36fea9551834c3d2fbec8e3baa6a84313d0
DIST slack-desktop-2.8.2-amd64.deb 51257834 BLAKE2B 85f06aa634b40f3ddd1450fcfaa044bf4cf9b5a7463525ac0ee98b07cd882e0b30e0a894c8ab2e2605e3db903e570c318d6d6cb968223d59abc5013053528547 SHA512 533b360ff22ff74743fb7323c08f01230509428e752aed2ed090bf002475934063e6c3853727ab030f6267ca332d783a045df02da02a3a12d045d6a168bf5b58
DIST slack-desktop-3.0.2-amd64.deb 55654542 BLAKE2B 70a1da6cc7be1313b02e74225ee87fbb93c0050f40301e0a02c01241efe91db9d09149fd8feeecf33786c657b53e8aec3a4d7563e61ae88e4b46f85bad27ded7 SHA512 29d7d96dbf4b81ac4164043c0cae0e314d94770b74118068684770763a52eed2a3fd430b4a307db2d133ad46cc57379a71415d92790946f5c1b448153c9bc2c1
+DIST slack-desktop-3.0.5-amd64.deb 55664624 BLAKE2B ad53ab04debf12d5af79069132a6852b03b85d1e99fc318e1e118556adc709fcd77e3bf866eed53ba34411b451ca46be42094deb6e7effde4ae8a21c9ccf1123 SHA512 a8bf160440d46ced92f70b57d8998dec957cd3a4f56813193974a9c0693ff45ad6493f74b682a9590ad3b9fbe2ac3fc01586b052e5c16f7570b0eb1430d25b12
diff --git a/net-im/slack-bin/slack-bin-3.0.5.ebuild b/net-im/slack-bin/slack-bin-3.0.5.ebuild
new file mode 100644
index 000000000000..6f2f809380dd
--- /dev/null
+++ b/net-im/slack-bin/slack-bin-3.0.5.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin/}"
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop gnome2-utils multilib-build pax-utils unpacker xdg-utils
+
+DESCRIPTION="Team collaboration tool"
+HOMEPAGE="http://www.slack.com/"
+SRC_URI="https://downloads.slack-edge.com/linux_releases/${MY_PN}-desktop-${PV}-amd64.deb"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 -*"
+IUSE="pax_kernel"
+RESTRICT="bindist mirror"
+
+RDEPEND="app-crypt/libsecret:0[${MULTILIB_USEDEP}]
+ dev-libs/atk:0[${MULTILIB_USEDEP}]
+ dev-libs/expat:0[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr:0[${MULTILIB_USEDEP}]
+ dev-libs/nss:0[${MULTILIB_USEDEP}]
+ gnome-base/gconf:2[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib:0[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ net-misc/curl:0[${MULTILIB_USEDEP}]
+ net-print/cups:0[${MULTILIB_USEDEP}]
+ sys-apps/dbus:0[${MULTILIB_USEDEP}]
+ x11-libs/cairo:0[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11:0[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:0/1.12[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite:0[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor:0[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage:0[${MULTILIB_USEDEP}]
+ x11-libs/libXext:0[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes:0[${MULTILIB_USEDEP}]
+ x11-libs/libXi:0[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrender:0[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver:0[${MULTILIB_USEDEP}]
+ x11-libs/libXtst:0[${MULTILIB_USEDEP}]
+ x11-libs/pango:0[${MULTILIB_USEDEP}]"
+
+QA_PREBUILT="opt/slack/slack
+ opt/slack/resources/app.asar.unpacked/node_modules/*
+ opt/slack/libnode.so
+ opt/slack/libffmpeg.so
+ opt/slack/libCallsCore.so"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/pixmaps
+ doins usr/share/pixmaps/${MY_PN}.png
+
+ newicon -s 512 usr/share/pixmaps/${MY_PN}.png ${MY_PN}.png
+ domenu usr/share/applications/${MY_PN}.desktop
+
+ insinto /opt/${MY_PN}
+ doins -r usr/lib/${MY_PN}/.
+ fperms +x /opt/${MY_PN}/${MY_PN}
+ dosym ../../opt/${MY_PN}/${MY_PN} usr/bin/${MY_PN}
+
+ use pax_kernel && pax-mark -m ${ED%/}/opt/${MY_PN}/${MY_PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}