summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2022-04-12 00:28:30 +0200
committerSam James <sam@gentoo.org>2022-04-15 07:04:19 +0100
commiteabc16b768077a41ec4b4cd74d8088e52b024ccd (patch)
treecce10dfe2dc8b33da66a61085c2a3e32caf4b5ac /net-im/telegram-desktop
parentmedia-libs/libtgvoip: Drop old (diff)
downloadgentoo-eabc16b768077a41ec4b4cd74d8088e52b024ccd.tar.gz
gentoo-eabc16b768077a41ec4b4cd74d8088e52b024ccd.tar.bz2
gentoo-eabc16b768077a41ec4b4cd74d8088e52b024ccd.zip
net-im/telegram-desktop: Fix building with KWayland 5.93
Closes: https://bugs.gentoo.org/837569 Thanks-to: Nick Sarnie <sarnex@gentoo.org> Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24998 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-im/telegram-desktop')
-rw-r--r--net-im/telegram-desktop/files/tdesktop-3.6.1-fix-kwayland-5.93.patch55
-rw-r--r--net-im/telegram-desktop/telegram-desktop-3.5.2-r1.ebuild1
-rw-r--r--net-im/telegram-desktop/telegram-desktop-3.6.1.ebuild1
3 files changed, 57 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/files/tdesktop-3.6.1-fix-kwayland-5.93.patch b/net-im/telegram-desktop/files/tdesktop-3.6.1-fix-kwayland-5.93.patch
new file mode 100644
index 000000000000..e818ffe46456
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-3.6.1-fix-kwayland-5.93.patch
@@ -0,0 +1,55 @@
+Fix compatibility with kwayland-5.93.0
+
+The header files were moved, the include directory wasn't being added correctly.
+
+https://bugs.gentoo.org/837569
+
+--- tdesktop-3.6.1-full.orig/Telegram/SourceFiles/platform/linux/linux_wayland_integration.cpp
++++ tdesktop-3.6.1-full/Telegram/SourceFiles/platform/linux/linux_wayland_integration.cpp
+@@ -9,10 +9,10 @@
+
+ #include "base/platform/base_platform_info.h"
+
+-#include <connection_thread.h>
+-#include <registry.h>
+-#include <surface.h>
+-#include <plasmashell.h>
++#include <KWayland/Client/connection_thread.h>
++#include <KWayland/Client/registry.h>
++#include <KWayland/Client/surface.h>
++#include <KWayland/Client/plasmashell.h>
+
+ using namespace KWayland::Client;
+
+--- tdesktop-3.6.1-full.orig/Telegram/lib_base/base/platform/linux/base_linux_wayland_integration.cpp
++++ tdesktop-3.6.1-full/Telegram/lib_base/base/platform/linux/base_linux_wayland_integration.cpp
+@@ -13,11 +13,11 @@
+ #include <QtCore/QPointer>
+ #include <QtGui/QWindow>
+
+-#include <connection_thread.h>
+-#include <registry.h>
+-#include <surface.h>
+-#include <xdgforeign.h>
+-#include <idleinhibit.h>
++#include <KWayland/Client/connection_thread.h>
++#include <KWayland/Client/registry.h>
++#include <KWayland/Client/surface.h>
++#include <KWayland/Client/xdgforeign.h>
++#include <KWayland/Client/idleinhibit.h>
+
+ using namespace KWayland::Client;
+
+--- tdesktop-3.6.1-full.orig/Telegram/lib_ui/ui/platform/linux/ui_linux_wayland_integration.cpp
++++ tdesktop-3.6.1-full/Telegram/lib_ui/ui/platform/linux/ui_linux_wayland_integration.cpp
+@@ -24,8 +24,8 @@
+ #include <private/qwaylandwindow_p.h>
+ #include <private/qwaylandshellsurface_p.h>
+
+-#include <connection_thread.h>
+-#include <registry.h>
++#include <KWayland/Client/connection_thread.h>
++#include <KWayland/Client/registry.h>
+
+ Q_DECLARE_METATYPE(QMargins);
+
diff --git a/net-im/telegram-desktop/telegram-desktop-3.5.2-r1.ebuild b/net-im/telegram-desktop/telegram-desktop-3.5.2-r1.ebuild
index fd97841de5b2..e5bd2fb2c389 100644
--- a/net-im/telegram-desktop/telegram-desktop-3.5.2-r1.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-3.5.2-r1.ebuild
@@ -73,6 +73,7 @@ PATCHES=(
"${FILESDIR}/tdesktop-3.3.0-fix-enchant.patch"
"${FILESDIR}/tdesktop-3.5.2-musl.patch"
"${FILESDIR}/tdesktop-3.5.2-jemalloc-optional.patch"
+ "${FILESDIR}/tdesktop-3.6.1-fix-kwayland-5.93.patch"
)
# Current desktop-file-utils-0.26 does not understand Version=1.5
diff --git a/net-im/telegram-desktop/telegram-desktop-3.6.1.ebuild b/net-im/telegram-desktop/telegram-desktop-3.6.1.ebuild
index 5d77d8964fd7..d2fc536e145f 100644
--- a/net-im/telegram-desktop/telegram-desktop-3.6.1.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-3.6.1.ebuild
@@ -76,6 +76,7 @@ PATCHES=(
"${FILESDIR}/tdesktop-3.3.0-fix-enchant.patch"
"${FILESDIR}/tdesktop-3.5.2-musl.patch"
"${FILESDIR}/tdesktop-3.6.0-support-ffmpeg5.patch"
+ "${FILESDIR}/tdesktop-3.6.1-fix-kwayland-5.93.patch"
)
# Current desktop-file-utils-0.26 does not understand Version=1.5