summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosiah Mullins <JoMull01@protonmail.com>2020-12-06 17:55:29 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-12-16 10:29:16 +0200
commitebb2bc13d30361e4d585c691c481c36127db9623 (patch)
treef0d8d2e8cf7294545d351f669a6b4711702efd57 /net-im/toxic
parentnet-im/toxic: add python 3.8 and 3.9 support to toxic-0.8.3-r1 (diff)
downloadgentoo-ebb2bc13d30361e4d585c691c481c36127db9623.tar.gz
gentoo-ebb2bc13d30361e4d585c691c481c36127db9623.tar.bz2
gentoo-ebb2bc13d30361e4d585c691c481c36127db9623.zip
net-im/toxic: Bump to version 0.10.0
The new ebuild includes a rewritten src_configure function. It also adds the global use flags debug and png. "png" enables exporting qrcodes as png images with "qrcode". It introduces two new local use flags: audio-notify and llvm. "audio-notify" enables built in audio notifications. "llvm" enables llvm's address sanitizer with "debug". Signed-off-by: Josiah Mullins <JoMull01@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/18566 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-im/toxic')
-rw-r--r--net-im/toxic/Manifest1
-rw-r--r--net-im/toxic/metadata.xml2
-rw-r--r--net-im/toxic/toxic-0.10.0.ebuild99
3 files changed, 102 insertions, 0 deletions
diff --git a/net-im/toxic/Manifest b/net-im/toxic/Manifest
index 70b8a4152fb6..cc10e69b4772 100644
--- a/net-im/toxic/Manifest
+++ b/net-im/toxic/Manifest
@@ -1 +1,2 @@
+DIST toxic-0.10.0.tar.gz 1160161 BLAKE2B 30089398211945f366fd7b52ab4014cd9b020f58b7d3e47ec1a12a87055f10cdb723211f38d1028a3fb149cd76aa7771591e37f7961cda37b7bcbb8e21b33181 SHA512 bfbe8e4c90b4fcbdbe7cc96cb402e4c2f1609e2970e51d6d2ad2c8596350ce96ac9f4d06fbb71350e56d8892e2ed4ee8c5adf4f66cdad6b152c959802bddc6cc
DIST toxic-0.8.3.tar.gz 1147100 BLAKE2B d73a861112aca65e54773c98473c2858bb81e63fef11212633e34dac9e87101956e3ab0d9d56757767bc5d48d1d5a406e550f8fc55ae34860dbc4977c94ee347 SHA512 c8d746efcc055592dd990dfa57415cc1eacaaa3b66303d7583d9f9e7e98b8829c8f1ae849f36a243c8896e99787dd2e493c92367de719b20a4a160bc7daea76e
diff --git a/net-im/toxic/metadata.xml b/net-im/toxic/metadata.xml
index 02e709980dad..f101e28e63b5 100644
--- a/net-im/toxic/metadata.xml
+++ b/net-im/toxic/metadata.xml
@@ -20,6 +20,8 @@
An ncurses-based Tox client written in C. Supports audio and video calling, file sharing, and desktop notifications.
</longdescription>
<use>
+ <flag name="audio-notify">Enables native sound notifications</flag>
+ <flag name="llvm">Enables support for LLVM Address Sanitizer</flag>
<flag name="notification">Enables desktop notifications with libnotify, with sound support.</flag>
<flag name="qrcode">Enables QR code support</flag>
<flag name="sound">Enables audio calling</flag>
diff --git a/net-im/toxic/toxic-0.10.0.ebuild b/net-im/toxic/toxic-0.10.0.ebuild
new file mode 100644
index 000000000000..7936c90bcd70
--- /dev/null
+++ b/net-im/toxic/toxic-0.10.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="A curses-based client for Tox"
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+audio-notify debug doc llvm notification png python qrcode +sound +video +X"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ video? ( sound X ) "
+
+BDEPEND="dev-libs/libconfig"
+
+RDEPEND="net-libs/tox
+ net-misc/curl
+ sys-libs/ncurses:*
+ audio-notify? ( media-libs/freealut
+ media-libs/openal )
+ notification? ( x11-libs/libnotify )
+ debug? ( llvm? ( sys-devel/llvm:* ) )
+ python? ( ${PYTHON_DEPS} )
+ qrcode? ( media-gfx/qrencode
+ png? ( media-libs/libpng ) )
+ sound? ( media-libs/openal
+ net-libs/tox[av] )
+ X? ( x11-base/xorg-proto
+ x11-libs/libX11 )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ #prevent man files from being compressed.
+ sed -i -e "/gzip/d" cfg/targets/install.mk || die "Unable to prevent compression of man pages."
+ #Fix incorrect linkage of pthread (may be optional)
+ sed -i -e 's/pthread/lpthread/g' Makefile || die "Unable to fix linking of pthread."
+ #Makefile sets some required CFLAGS only if CFLAGS variable is undefined,
+ #This line changes the "lazy set if absent" assignment to a "lazy set" assignment.
+ #look below in src_configure to see how CFLAGS are passed to the makefile in USER_CFLAGS
+ sed -i -e 's/?=/=/g' Makefile || die "Unable to change assignment of CFLAGS and LDFLAGS"
+}
+
+src_configure() {
+ if ! use audio-notify; then
+ USER_CFLAGS+="-DDISABLE_SOUND_NOTIFY=1 "
+ fi
+ if use debug; then
+ USER_CFLAGS+="-DENABLE_RELEASE=0 "
+ if use llvm; then
+ USER_CFLAGS+="-DENABLE_ASAN=1 "
+ fi
+ fi
+ if ! use notification; then
+ USER_CFLAGS+="-DDISABLE_DESKTOP_NOTIFY=1 "
+ fi
+ if ! use png; then
+ USER_CFLAGS+="-DDISABLE_QRPNG=1 "
+ fi
+ if use python; then
+ USER_CFLAGS+="-DENABLE_PYTHON=1"
+ fi
+ if ! use qrcode; then
+ USER_CFLAGS+="-DDISABLE_QRCODE=1"
+ fi
+ if ! use sound; then
+ USER_CFLAGS+="-DDISABLE_AV=1 "
+ fi
+ if ! use video; then
+ USER_CFLAGS+="-DDISABLE_VI=1"
+ fi
+ if ! use X; then
+ USER_CFLAGS+="-DDISABLE_X11=1 "
+ fi
+ USER_CFLAGS+="${CFLAGS}"
+ export USER_CFLAGS
+ export USER_LDFLAGS="${LDFLAGS}"
+ #set install directory to /usr.
+ sed -i -e "s,/usr/local,${EPREFIX}/usr,g" cfg/global_vars.mk || die "Failed to set install directory!"
+}
+
+src_install() {
+ default
+ if ! use audio-notify; then
+ rm -r ${ED}/usr/share/${PN}/sounds || die "Could not remove sounds directory"
+ fi
+}