summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorreagentoo <reagentoo@gmail.com>2018-01-04 17:06:31 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-06 03:58:42 +0100
commitdf03269f345a6f67a82de46d9515f47368c3e5bf (patch)
treee5ac687e1cfc69fde18324bb086a53bf8ba2084f /net-im/vacuum
parentnet-im/vacuum: Add 1.3.0.20180105-Alpha (diff)
downloadgentoo-df03269f345a6f67a82de46d9515f47368c3e5bf.tar.gz
gentoo-df03269f345a6f67a82de46d9515f47368c3e5bf.tar.bz2
gentoo-df03269f345a6f67a82de46d9515f47368c3e5bf.zip
net-im/vacuum: Drop unused NO_WEBKIT option, fix src_prepare
Closes: https://github.com/gentoo/gentoo/pull/6746
Diffstat (limited to 'net-im/vacuum')
-rw-r--r--net-im/vacuum/vacuum-9999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/net-im/vacuum/vacuum-9999.ebuild b/net-im/vacuum/vacuum-9999.ebuild
index 56de1a0b3375..b2f5d478a4d4 100644
--- a/net-im/vacuum/vacuum-9999.ebuild
+++ b/net-im/vacuum/vacuum-9999.ebuild
@@ -13,9 +13,9 @@ HOMEPAGE="http://www.vacuum-im.org/"
LICENSE="GPL-3"
SLOT="0/37" # subslot = libvacuumutils soname version
KEYWORDS=""
-PLUGINS=( annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filemessagearchive filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver messagecarbons multiuserchat pepmanager privacylists privatestorage recentcontacts registration remotecontrol rosteritemexchange rostersearch servermessagearchive servicediscovery sessionnegotiation shortcutmanager socksstreams urlprocessor vcard xmppuriqueries )
+PLUGINS=( adiummessagestyle annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filemessagearchive filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver messagecarbons multiuserchat pepmanager privacylists privatestorage recentcontacts registration remotecontrol rosteritemexchange rostersearch servermessagearchive servicediscovery sessionnegotiation shortcutmanager socksstreams urlprocessor vcard xmppuriqueries )
SPELLCHECKER_BACKENDS="aspell +enchant hunspell"
-IUSE="adiummessagestyle ${PLUGINS[@]/#/+} ${SPELLCHECKER_BACKENDS} +spell"
+IUSE="${PLUGINS[@]/#/+} ${SPELLCHECKER_BACKENDS} +spell"
REQUIRED_USE="
annotations? ( privatestorage )
@@ -65,7 +65,11 @@ DOCS=( AUTHORS CHANGELOG README TRANSLATORS )
src_prepare() {
# Force usage of system libraries
- rm -rf src/thirdparty/{idn,hunspell,minizip,zlib}
+ rm -rf src/thirdparty/{hunspell,idn,minizip,qtlockedfile,zlib} || die
+
+ # Supress find thirdparty library in the system
+ sed -i -r -e "/find_library.+qxtglobalshortcut/d" \
+ CMakeLists.txt || die
cmake-utils_src_prepare
}
@@ -78,12 +82,9 @@ src_configure() {
-DINSTALL_DOCS=OFF
-DFORCE_BUNDLED_MINIZIP=OFF
-DPLUGIN_statistics=OFF
- -DNO_WEBKIT=$(usex !adiummessagestyle)
-DPLUGIN_spellchecker=$(usex spell)
)
- use adiummessagestyle && mycmakeargs+=( -DPLUGIN_adiummessagestyle=ON )
-
for x in ${PLUGINS[@]}; do
mycmakeargs+=( -DPLUGIN_${x}=$(usex $x) )
done