summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-07-26 23:18:08 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-02 21:14:42 +0300
commitf7e529155909025558089340c0f828c4c22977b6 (patch)
treefa34b3fb9d6126ff803e2739cba86e0b9869b8d5 /net-im/yowsup/yowsup-3.2.3.ebuild
parentdev-python/transitions: New package (diff)
downloadgentoo-f7e529155909025558089340c0f828c4c22977b6.tar.gz
gentoo-f7e529155909025558089340c0f828c4c22977b6.tar.bz2
gentoo-f7e529155909025558089340c0f828c4c22977b6.zip
net-im/yowsup: bump to version 3.2.3
This is a new major release of net-im/yowsup, which needs new dependencies: dev-python/consonance dev-python/dissononce dev-python/transitions Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12550 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-im/yowsup/yowsup-3.2.3.ebuild')
-rw-r--r--net-im/yowsup/yowsup-3.2.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-im/yowsup/yowsup-3.2.3.ebuild b/net-im/yowsup/yowsup-3.2.3.ebuild
new file mode 100644
index 000000000000..69b80264ed28
--- /dev/null
+++ b/net-im/yowsup/yowsup-3.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE="readline"
+
+inherit distutils-r1
+
+DESCRIPTION="A library that enables you to build applications which use the WhatsApp service"
+HOMEPAGE="https://github.com/tgalal/yowsup"
+SRC_URI="https://github.com/tgalal/yowsup/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/configargparse[${PYTHON_USEDEP}]
+ dev-python/consonance[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/python-axolotl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-fix-install-path.patch" )
+
+pkg_postinst() {
+ einfo "Warning: It seems that recently yowsup gets detected during registration"
+ einfo "resulting in an instant ban for your number right after registering"
+ einfo "with the code you receive by sms/voice."
+ einfo "See https://github.com/tgalal/yowsup/issues/2829 for more information."
+}