summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 14:40:11 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-20 14:41:31 +0200
commit124c0cf2a0965ace2f68bd6da6b14dad8f8e5ded (patch)
tree49280126fd095b808d6db2701abbe356e1ddc8d1 /net-im
parentgnome-extra/pch-session: Drop old (diff)
downloadgentoo-124c0cf2a0965ace2f68bd6da6b14dad8f8e5ded.tar.gz
gentoo-124c0cf2a0965ace2f68bd6da6b14dad8f8e5ded.tar.bz2
gentoo-124c0cf2a0965ace2f68bd6da6b14dad8f8e5ded.zip
net-im/rocketchat-desktop-bin: import from ::guru
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/metadata.xml12
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.2.2.ebuild53
3 files changed, 66 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
new file mode 100644
index 000000000000..a1e56775b509
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -0,0 +1 @@
+DIST rocketchat-3.2.2.x86_64.rpm 55347028 BLAKE2B 77fb7f5461b28ae4cf896742b4a65bd19a877aa69984f1040e509b2dfdacdceb4db83d9f6af58e2ef357e5884a927a05d707b0af502cf83c9aeb238a1cec8fad SHA512 5f48168529804d6fc849dac21f3ca0f94b6d8cb5d3ef0086a8f1631c0a66b69741ff5e642e64b08a3df2dd7e3a6d36f97dca5157a43c3a716238f293dcadad7e
diff --git a/net-im/rocketchat-desktop-bin/metadata.xml b/net-im/rocketchat-desktop-bin/metadata.xml
new file mode 100644
index 000000000000..355f962599cc
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">RocketChat/Rocket.Chat.Electron</remote-id>
+ <bugs-to>https://github.com/RocketChat/Rocket.Chat.Electron/issues</bugs-to>
+ </upstream>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.2.2.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.2.2.ebuild
new file mode 100644
index 000000000000..0c6ba72c3682
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.2.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ cp -a "${S}"/* "${ED}" || die
+}